Started over, almost there. (Was: First-time RT install questions.)

I started over.

First, I aliased an ip address onto eth0 and set it up in dns as ‘
rt.blackdogsoft.net http://rt.blackdogsoft.net’. Then I configured a
separate ssl virtual host for that site, and verified I could access it with
a browser properly.

Next, I built and installed rt as user apache, which is what my webserver
runs as. rt is installed directly ito the document root. Accessing that with
a browser got me to the ‘Almost there!’ page. I then built and installed
fastcgi, as root. Continuing to follow method #1 on the wiki’s
fastcgiconfiguration page, I added just the entries in the example, only
changing the paths to match mine.

Outside the virtual host definition, I have:

FastCgiIpcDir /tmp
FastCgiServer /u1/www/sites/rt-secure/bin/mason_handler.fcgi -idle-timeout
120 -processes 4

and in the virtual host definition, I have:

ServerName rt.blackdogsoft.net http://rt.blackdogsoft.net
DocumentRoot "/u1/www/sites/rt-secure/share/html"
AddDefaultCharset UTF-8

AddHandler fastcgi-script fcgi
ScriptAlias / /u1/www/sites/rt-secure/bin/mason_handler.fcgi/

Use separate log files:

ErrorLog /u1/www/logs/rt-secure/error_log
CustomLog /u1/www/logs/rt-secure/access_log combined

When I tried to access rt, the logs complained that ‘FCGI.pm’ couldn’t be
located in ‘@INC’, so I used cpan to install it.

Now I have four mason_handler.fcgi processes running, as I should. However,
I’m still getting the ‘Almost there!’ page, when I try to access rt, and
this is in the logs:

[Thu Oct 20 15:49:27 2005] [error] [client
192.168.32.111http://192.168.32.111]
FastCGI: comm with server “/u1/www/sites/rt-secure/bin/mason_handler.fcgi"
aborted: idle timeout (120 sec)
[Thu Oct 20 15:49:27 2005] [error] [client
192.168.32.111http://192.168.32.111]
FastCGI: incomplete headers (0 bytes) received from server
”/u1/www/sites/rt-secure/bin/mason_handler.fcgi"

My config file has this in it:

Set( $rtname, ‘rt.blackdogsoft.net http://rt.blackdogsoft.net’);
Set($Organization , “blackdogsoft.net http://blackdogsoft.net”);
Set($DatabasePassword , ‘my-password-here’);

I feel like I’m really close now. Could someone help me to figure out this
last part, please? TIA.
-ste

Shaun T. Erickson wrote:

I started over.

First, I aliased an ip address onto eth0 and set it up in dns as
rt.blackdogsoft.net http://rt.blackdogsoft.net’. Then I configured
a separate ssl virtual host for that site, and verified I could access
it with a browser properly.

Next, I built and installed rt as user apache, which is what my
webserver runs as. rt is installed directly ito the document root.
Accessing that with a browser got me to the ‘Almost there!’ page. I
then built and installed fastcgi, as root. Continuing to follow method
#1 on the wiki’s fastcgiconfiguration page, I added just the entries
in the example, only changing the paths to match mine.

Outside the virtual host definition, I have:

    FastCgiIpcDir /tmp
    FastCgiServer /u1/www/sites/rt-secure/bin/mason_handler.fcgi 

-idle-timeout 120 -processes 4

and in the virtual host definition, I have:

    ServerName rt.blackdogsoft.net <http://rt.blackdogsoft.net>
    DocumentRoot "/u1/www/sites/rt-secure/share/html"
    AddDefaultCharset UTF-8

    AddHandler fastcgi-script fcgi
    ScriptAlias / /u1/www/sites/rt-secure/bin/mason_handler.fcgi/

Try making this ScriptAlias /rt
/u1/www/sites/rt-secure/bin/mason_handler.fcgi
or removing the trailing slash from what you have. One or both of those
might help you out.

    # Use separate log files:
    ErrorLog /u1/www/logs/rt-secure/error_log
    CustomLog /u1/www/logs/rt-secure/access_log combined

When I tried to access rt, the logs complained that ‘FCGI.pm’ couldn’t
be located in ‘@INC’, so I used cpan to install it.

Now I have four mason_handler.fcgi processes running, as I should.
However, I’m still getting the ‘Almost there!’ page, when I try to
access rt, and this is in the logs:

[Thu Oct 20 15:49:27 2005] [error] [client 192.168.32.111
http://192.168.32.111] FastCGI: comm with server
"/u1/www/sites/rt-secure/bin/mason_handler.fcgi" aborted: idle timeout
(120 sec)
[Thu Oct 20 15:49:27 2005] [error] [client 192.168.32.111
http://192.168.32.111] FastCGI: incomplete headers (0 bytes)
received from server “/u1/www/sites/rt-secure/bin/mason_handler.fcgi”

My config file has this in it:

Set( $rtname, ‘rt.blackdogsoft.net http://rt.blackdogsoft.net’);
Set($Organization , “blackdogsoft.net http://blackdogsoft.net”);
Set($DatabasePassword , ‘my-password-here’);

I feel like I’m really close now. Could someone help me to figure out
this last part, please? TIA.

    -ste


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Buy your copy of our new book, RT Essentials, today!

Download a free sample chapter from http://rtbook.bestpractical.com

Drew Barnes
Applications Analyst
Raymond Walters College
University of Cincinnati

ScriptAlias / /u1/www/sites/rt-secure/bin/mason_handler.fcgi/
Try making this ScriptAlias /rt
/u1/www/sites/rt-secure/bin/mason_handler.fcgi
or removing the trailing slash from what you have. One or both of those
might help you out.

Neither seemed to help. The odd thing is that I don’t seem to be getting an
errors in the logs anymore, to help me figure this out.

I did add this to my site config file:

Set($WebBaseURL , “https://rt.blackdogsoft.net”);

but it didn’t seem to help either. I’m really stumped.
-ste

Shaun T. Erickson wrote:

>         ScriptAlias /
/u1/www/sites/rt-secure/bin/mason_handler.fcgi/
Try making this ScriptAlias /rt
/u1/www/sites/rt-secure/bin/mason_handler.fcgi
or removing the trailing slash from what you have.  One or both of
those
might help you out.

Neither seemed to help. The odd thing is that I don’t seem to be
getting an errors in the logs anymore, to help me figure this out.

I did add this to my site config file:

Set($WebBaseURL , “https://rt.blackdogsoft.net”)
https://rt.blackdogsoft.net");

but it didn’t seem to help either. I’m really stumped.
You did stop apache completely and then start it, right? As I recall, a
simple restart doesn’t always do it.

Perhaps stop apache, empty the mason cache (rm -rf
rtdir/var/mason_data/obj/*) and then start apache again?


-ste

Drew Barnes
Applications Analyst
Raymond Walters College
University of Cincinnati

You did stop apache completely and then start it, right? As I recall, a
simple restart doesn’t always do it.

Perhaps stop apache, empty the mason cache (rm -rf
rtdir/var/mason_data/obj/*) and then start apache again?

No, I didn’t - I’ve been using restart. I’ll be sure to try this when I get
back to work Monday.

-ste

 You  did  stop  apache  completely  and then start it, right?  As I
 recall, a
 simple restart doesn't always do it.
 Perhaps stop apache, empty the mason cache (rm -rf
 rtdir/var/mason_data/obj/*) and then start apache again?

No, I didn’t - I’ve been using restart. I’ll be sure to try this when
I get back to work Monday.

I’ve found that ‘svc apache restart’ (svc is my wrapper script for the
init.d scripts) doesn’t help most of the time; I added a manual
’bounce’ option.

#!/bin/bash

service helper script

go to the directory

cd /etc/init.d

if no argument, list services and exit

[ $# = 0 ] && ls && exit 0

must exist (no longer check executable, since root will be able to run it)

[ -f $1 ] || { echo “$1: no such service” && exit 1; }

if we’re not root, fix it

[ $UID = 0 ] || exec su root -c “$0 $*”

run the actual script

SCRIPT=$1
shift

case $1 in
on)
./$SCRIPT start
echo "Enabling $SCRIPT…"
chkconfig $SCRIPT on
exit 0
;;
off)
./$SCRIPT stop
echo "Disabling $SCRIPT…"
chkconfig $SCRIPT off
exit 0
;;
bounce) ./$SCRIPT stop
./$SCRIPT start
exit 0
;;
) ./${SCRIPT} $
;;
esac

Cheers,
– jra
Jay R. Ashworth jra@baylink.com
Designer Baylink RFC 2100
Ashworth & Associates The Things I Think '87 e24
St Petersburg FL USA http://baylink.pitas.com +1 727 647 1274

"NPR has a lot in common with Nascar... we both turn to the left."
	- Peter Sagal, on Wait Wait, Don't Tell Me!

You did stop apache completely and then start it, right? As I recall, a
simple restart doesn’t always do it.

Perhaps stop apache, empty the mason cache (rm -rf
rtdir/var/mason_data/obj/*) and then start apache again?

No, I didn’t - I’ve been using restart. I’ll be sure to try this when I
get back to work Monday.

That did the trick - thanks!
-ste

I’ve found that ‘svc apache restart’ (svc is my wrapper script for the
init.d scripts) doesn’t help most of the time; I added a manual
’bounce’ option.

I think I’ll add that to mine as well, as it definitely did the trick.
Thanks.
-ste