Speed Issues?

Hi, I was just curious if anyone else has had any speed issues with a setup
similar to mine:

Ultra 10, 1024 megs of RAM
Solaris 8
RT 2.0.14
Apache 1.3.26 - mod_perl 1.27
PostGresQL 7.2.1

I’ve just set up RT and began using it. My Postgres databases are extremely
small right now. I’ve got maybe a total of 5 tickets in the system, and the
postgres database isn’t being used all that much by anything else.

Whenever someone goes to look at a specific ticket however, it seems to take
on average about 1-4 seconds for the page to be displayed. During this time
I notice that my CPU usage goes to 100%.

I’m wondering if postgres is the culprit here, but thats just a guess. Has
anyone used RT with the latest postgres?

Any help you can give would be great. Thanks.

            Mike Barrett | "I used to read, now I go to raves."
         mike@daboyz.org | -- Random MUNI Rider, speaking
          www.daboyz.org |    to my friend Allison.

Whenever someone goes to look at a specific ticket however, it seems to take
on average about 1-4 seconds for the page to be displayed. During this time
I notice that my CPU usage goes to 100%.

First access of the day it took a slow count to 6. CPU jumped on httpd to
about 40%, PostgreSQL made about 10%. (I was running to with a 1 second
refresh so it slipped right through be fore I could really notice it.)

I’m wondering if postgres is the culprit here, but thats just a guess. Has
anyone used RT with the latest postgres?

Yup. 7.2.1-4 from Redhat RPMs.

AMD K6 3D, 128 MByte RAM, IDE hard drive. Machine is also used as name
server for about 4000 customers.

Rod
"Open Source Software - Sometimes you get more than you paid for…"

Mike Barrett [mike@daboyz.org] wrote:

Whenever someone goes to look at a specific ticket however, it seems to take
on average about 1-4 seconds for the page to be displayed. During this time
I notice that my CPU usage goes to 100%.

I’m wondering if postgres is the culprit here, but thats just a guess. Has
anyone used RT with the latest postgres?

I can’t say it’s true for every system, but in our case, PostgreSQL was
definitely the culprit. We’re pretty much an all-postgresql shop here,
so we installed RT on postgresql.

Since then, we’ve had nothing but trouble, the speed is abysmal, with a
database of 10 or 20,000 tickets it would literally take 10 seconds to go
from the summary page into a queue list!

We’ve since switched to MySQL for RT and got a new lease on our ticketing
system (we’d actually started research other, ugh, commercial, offerings to
replace it, it was so slow).

Normally I’m a big psql booster, but one of it’s biggest failings is in the
handling of large text columns, which RT’s database is, primarily. I would
suggest switching to mysql if you want any reasonable performance. No
guarantees it’ll fix your issue, but it definitely did for us. =)

Ben Reed (ben@oculan.com)
http://www.oculan.com/
“Is it considered bad form to quote yourself in your sig?” – Me

“MB” == Mike Barrett mike@daboyz.org writes:

MB> on average about 1-4 seconds for the page to be displayed. During
MB> this time I notice that my CPU usage goes to 100%.

MB> I’m wondering if postgres is the culprit here, but thats just a
MB> guess. Has anyone used RT with the latest postgres?

Postgres is generally not a CPU-bound process. It is usually a disk-bound
process. What kind of disks do you have? I hope they’re SCSI.

Anyhow, you should also do the regular maintenance required of
postgres.

Is your apache dedicated to RT or does it do other stuff? I’d
recommend running a dedicated instance (not virtual host) just for RT.

Vivek Khera, Ph.D. Khera Communications, Inc.
Internet: khera@kciLink.com Rockville, MD +1-240-453-8497
AIM: vivekkhera Y!: vivek_khera http://www.khera.org/~vivek/

“RAA” == Roderick A Anderson raanders@acm.org writes:

RAA> On Tue, 13 Aug 2002, Mike Barrett wrote:

Whenever someone goes to look at a specific ticket however, it seems to take
on average about 1-4 seconds for the page to be displayed. During this time
I notice that my CPU usage goes to 100%.

RAA> First access of the day it took a slow count to 6. CPU jumped on
RAA> httpd to about 40%, PostgreSQL made about 10%. (I was running to
RAA> with a 1 second refresh so it slipped right through be fore I
RAA> could really notice it.)

So, basically, overnight when nobody accessed RT, all the memory used
by it got swapped out. When you came in, it took a few seconds to
pull back all the memory from swap…

Only solution is to add RAM or get faster disks.

“BR” == Benjamin Reed ben@oculan.com writes:

BR> I can’t say it’s true for every system, but in our case, PostgreSQL was
BR> definitely the culprit. We’re pretty much an all-postgresql shop here,
BR> so we installed RT on postgresql.

We have no performance issues with RT on postgres. Works pretty
darned fast, even when some other process is pounding the DB server
for some large query.

Vivek Khera, Ph.D. Khera Communications, Inc.
Internet: khera@kciLink.com Rockville, MD +1-240-453-8497
AIM: vivekkhera Y!: vivek_khera http://www.khera.org/~vivek/

Whenever someone goes to look at a specific ticket however, it seems to
take
on average about 1-4 seconds for the page to be displayed. During this
time
I notice that my CPU usage goes to 100%.

We experience the same behavior, pretty consistently, but we are using
mysql. Is anyone else experiencing the same thing?

John DeBerry

So, basically, overnight when nobody accessed RT, all the memory used
by it got swapped out. When you came in, it took a few seconds to
pull back all the memory from swap…

I knew this. I was just letting people know it was not all that slow
unless you’re doing like we are - slow processor, minimal RAM, and slow
disks - and it was the first access of the day. DNS access probably was
causing it to swap out.

Only solution is to add RAM or get faster disks.

Not a problem. In fact I think less than 10 seconds isn’t all that bad.
I couldn’t type out an entry in less than 5 seconds. (Sometimes being
slow isn’t all that bad. :slight_smile:

Rod
"Open Source Software - Sometimes you get more than you paid for…"

Hi All.
I’m attempting to run RT 2 underApache/1.3.26, mod_perl 1.26, with Mason
from CPAN.

When I add (not running as a Vhost)
Alias /webrt/ /usr/share/request-tracker/WebRT/html/NoAuth/images
Alias /rt/ /usr/share/request-tracker/WebRT/html
PerlRequire /usr/share/request-tracker/bin/webmux.pl
<Location /rt>
SetHandler perl-script
PerlHandler RT::Mason

to the httpd.conf,
Apache will not restart. No errors in error.log.
It specifically chokes on the PerlRequire entry and
on another note apachectl configtest seg faults :slight_smile:

Has anyone run into this problem before or have any advice?

Many thanks,
Alan

Alan Sawyer wrote:

When I add (not running as a Vhost)

[…]

to the httpd.conf,
Apache will not restart. No errors in error.log.
It specifically chokes on the PerlRequire entry and
on another note apachectl configtest seg faults :slight_smile:

Has anyone run into this problem before or have any advice?

Yes, I had a similar problem once after upgrading our system. I could
only get it working by putting it inside a virtual host statement.
See http://fsck.com/rtfm/article.html?id=2#100 for an example.

pg

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

El Mar 13 Ago 2002 16:47, John DeBerry escribi�:

Whenever someone goes to look at a specific ticket however, it seems to

take

on average about 1-4 seconds for the page to be displayed. During this

time

I notice that my CPU usage goes to 100%.

We experience the same behavior, pretty consistently, but we are using
mysql. Is anyone else experiencing the same thing?

We have something similar on here. Our system is been using for 80 people and
it’s keeps with the loads Ok, except when the httpd process (maybe mod_perl)
gots crazy.

Normaly each httpd process use arround 19Mb, but sometimes some of them eat
64Mb each one, in that moment each of this crazy httpd use as much CPU as
can. If there are too much crazy-process the machine goes up to 10 load and
finaly die and must be reboot. This problem is killing us. :frowning:

Now, because vacation, only 15 people are using it and the problem is not
happening.

Hardware: PIV 2Ghz, RAM 2GB, Ultra Wide SCSI Disks, Hardware Raid
Software: rt-2.0.11, mysql, Redhat 7.3 (same with Redhat 7.2)

We chage the machine thinking is some hardware related problem (PIV 1.6Ghz,
RAM 750Mb, IDE disks) and the same problem happend.

Is anyone noticed something similar?


“Alone? you are not alone, Bigbrother is watching you”


Victor Barahona Cabezon
http://rincon.uam.es/dir?cw=870938110351562 PGP ID-0x8750AB79
Soporte Seguridad en red…http://www.utc.uam.es/ss


-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.6 (GNU/Linux)
Comment: For info see http://www.gnupg.org

iD8DBQE9Wh0nShbwHIdQq3kRAmkSAJ9ULFHk9/stBwH+7Tc22Bn/HVdM4QCg8fGW
XpE5vpfWQNyt94auNy6aEk8=
=1DBg
-----END PGP SIGNATURE-----

Hi Paul,
Thanks for the tip. I’ll give it a try if I can’t get to the bottom of the
problem with webmux/apache.

Thanks,
AlanOn Tue, 13 Aug 2002, Paul Goracke wrote:

Alan Sawyer wrote:

When I add (not running as a Vhost)

[…]

to the httpd.conf,
Apache will not restart. No errors in error.log.
It specifically chokes on the PerlRequire entry and
on another note apachectl configtest seg faults :slight_smile:

Has anyone run into this problem before or have any advice?

Yes, I had a similar problem once after upgrading our system. I could
only get it working by putting it inside a virtual host statement.
See http://fsck.com/rtfm/article.html?id=2#100 for an example.

pg


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1On Wed, 14 Aug 2002, Victor Barahona wrote:

We have something similar on here. Our system is been using for 80 people and
it’s keeps with the loads Ok, except when the httpd process (maybe mod_perl)
gots crazy.

Normaly each httpd process use arround 19Mb, but sometimes some of them eat
64Mb each one, in that moment each of this crazy httpd use as much CPU as
can. If there are too much crazy-process the machine goes up to 10 load and
finaly die and must be reboot. This problem is killing us. :frowning:

I find the following settings in Apache’s httpd.conf useful to avoid the
run-away affect in Apache from completely killing your machine.

MinSpareServers 5
MaxSpareServers 10
StartServers 5
MaxClients 150

# Each child process will die after this many requests,
# incidentally freeing up the memory that it has used.  Apache
# leaks like a sieve sometimes.
MaxRequestsPerChild 30

Regards,


                         Bruce Campbell                            RIPE
               Systems/Network Engineer                             NCC
             www.ripe.net - PGP562C8B1B             Operations/Security

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.6 (GNU/Linux)
Comment: For info see http://www.gnupg.org

iD8DBQE9Wjcj5GBMOVYsixsRAt42AJwNnX6UG+y3h9/Cwz0TrdDaCU5f/QCePFEu
9yXEz2C8xAX0awEQTQQOaqg=
=vPh1
-----END PGP SIGNATURE-----

Alan,

I had this problem too. You didn’t specify, but I’m assuming you’re
installing Apache from the Redhat RPM along with the mod_perl RPM running as
a DSO. Or perhaps you’ve compiled Apache instead of using the RPM and are
using mod_perl as a DSO.

To fix my problem, I ended up compiling mod_perl statically into Apache.
Everything worked just fine after that.

Hope this helps.

-Jim Ficarra

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

I find the following settings in Apache’s httpd.conf useful to avoid the
run-away affect in Apache from completely killing your machine.

MinSpareServers 5
MaxSpareServers 10
StartServers 5
MaxClients 150

Each child process will die after this many requests,

incidentally freeing up the memory that it has used. Apache

leaks like a sieve sometimes.

MaxRequestsPerChild 30

I forgot mention it but we allready did something similar (even more radical)
and then, things went better but from times to times happen again (once a
week). Our configurati�n is:

MinSpareServers 3
MaxSpareServers 6
StartServers 3
MaxClients 150

MaxRequestsPerChild 10

Why is this happening? is a bug? is apache? is mod_perl? is mysql? is rt? Any
light to this will be VERY appreciate.

Regards.


“Alone? you are not alone, Bigbrother is watching you”


Victor Barahona Cabezon
http://rincon.uam.es/dir?cw=870938110351562 PGP ID-0x8750AB79
Soporte Seguridad en red…http://www.utc.uam.es/ss


-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.6 (GNU/Linux)
Comment: For info see http://www.gnupg.org

iD8DBQE9Wlj9ShbwHIdQq3kRArtyAJwMM7/2RfZe2is+wdrz68Pl1LFk/QCfQHE9
hq+XS/AltLnWyyzMXDvvdY4=
=+aas
-----END PGP SIGNATURE-----