Slowness with RRDtool graphing

Hardware:
CPU: Intel® Pentium® 4 CPU 2.80GHz (2806.37-MHz 686-class CPU)
real memory = 2146631680 (2047 MB)

Load:
CPU: 2.2% user, 0.0% nice, 1.1% system, 0.0% interrupt, 96.6% idle
Mem: 162M Active, 1461M Inact, 178M Wired, 96M Cache, 112M Buf, 99M Free
Swap: 4061M Total, 84K Used, 4061M Free
Disks ad0 ad1 183024 wire
KB/t 128 0.00 186724 act
tps 0 0 1496468 inact
MB/s 0.02 0.00 98392 cache
%busy 0 0 80408 free
114880 buf

Versions:
6.4-RELEASE FreeBSD
Server version: Apache/2.2.9 (FreeBSD)
PHP 5.2.6 with Suhosin-Patch 0.9.6.2 (cli) (built: Apr 16 2009 17:45:37)
Cacti Version 0.8.7g
RRDTool versions tried:
Currently RRDtool 1.4.5
Also tried RRDtool 1.0.49
Also tried RRDtool 1.3.1

Summary: Loading of a given page of graphs in Cacti taking minutes to load
PID USERNAME THR PRI NICE SIZE RES STATE C TIME WCPU
COMMAND
53185 www 1 101 0 9292K 6096K RUN 0 0:03 15.79%
rrdtool
53186 www 1 101 0 9288K 6092K RUN 0 0:03 15.54%
rrdtool
53192 www 1 101 0 9284K 6088K RUN 0 0:03 15.51%
rrdtool
53197 www 1 101 0 9292K 6096K RUN 0 0:03 15.51%
rrdtool
53198 www 1 101 0 9284K 6088K RUN 0 0:03 15.42%
rrdtool
53194 www 1 101 0 9288K 6092K RUN 0 0:03 15.08%
rrdtool

Extended description:
I’ve installed Cacti on 30+ machines for 20+ organizations over
the last 5 years and have never before experienced this. I find tons of
reports of this via Google and the ‘search’ function at cacti.net, but
have yet to find the silver bullet that fixes the issue.

What would be causing this?  How can I fix it?  The rest of the 

Cacti interface loads instantly, so I have no reason to believe that it’s
a PHP limitation/setting, nor a resource issue with Apache in any way.

Advice?

-Jake

Did you perhaps mean to send this to the RRDtool mailinglist?On Thu, Jan 20, 2011 at 02:20:46PM -0500, elsif wrote:

Hardware:
CPU: Intel® Pentium® 4 CPU 2.80GHz (2806.37-MHz 686-class CPU)
real memory = 2146631680 (2047 MB)

Load:
CPU: 2.2% user, 0.0% nice, 1.1% system, 0.0% interrupt, 96.6% idle
Mem: 162M Active, 1461M Inact, 178M Wired, 96M Cache, 112M Buf, 99M Free
Swap: 4061M Total, 84K Used, 4061M Free
Disks ad0 ad1 183024 wire
KB/t 128 0.00 186724 act
tps 0 0 1496468 inact
MB/s 0.02 0.00 98392 cache
%busy 0 0 80408 free
114880 buf

Versions:
6.4-RELEASE FreeBSD
Server version: Apache/2.2.9 (FreeBSD)
PHP 5.2.6 with Suhosin-Patch 0.9.6.2 (cli) (built: Apr 16 2009 17:45:37)
Cacti Version 0.8.7g
RRDTool versions tried:
Currently RRDtool 1.4.5
Also tried RRDtool 1.0.49
Also tried RRDtool 1.3.1

Summary: Loading of a given page of graphs in Cacti taking minutes to load
PID USERNAME THR PRI NICE SIZE RES STATE C TIME
WCPU COMMAND
53185 www 1 101 0 9292K 6096K RUN 0 0:03
15.79% rrdtool
53186 www 1 101 0 9288K 6092K RUN 0 0:03
15.54% rrdtool
53192 www 1 101 0 9284K 6088K RUN 0 0:03
15.51% rrdtool
53197 www 1 101 0 9292K 6096K RUN 0 0:03
15.51% rrdtool
53198 www 1 101 0 9284K 6088K RUN 0 0:03
15.42% rrdtool
53194 www 1 101 0 9288K 6092K RUN 0 0:03
15.08% rrdtool

Extended description:
I’ve installed Cacti on 30+ machines for 20+ organizations over the
last 5 years and have never before experienced this. I find tons of
reports of this via Google and the ‘search’ function at cacti.net,
but have yet to find the silver bullet that fixes the issue.

What would be causing this? How can I fix it? The rest of the
Cacti interface loads instantly, so I have no reason to believe that
it’s a PHP limitation/setting, nor a resource issue with Apache in
any way.

Advice?

-Jake