Setting up RT 3.8.8 on CentOS 5.5

Hi RT Community,
I have been having a difficulty in setting up RT on my CentOS [Apache2,
mysql, postfix]. Its defaulting on FCGI while I want it to use
mod-perl2.

In my /tmp/rt-3.8.8. when I test my RT installation,

[root@rt_sys]# make testdeps
/usr/bin/perl ./sbin/rt-test-dependencies --verbose --with-mysql
–with-fastcgi
perl:
>=5.8.3(5.8.8) …found
users:
rt group (rt) …found
bin owner (root) …found
libs owner (root) …found
libs group (bin) …found
web owner (apache) …found
web group (apache) …found
CLI dependencies:

The RT configure file doesn’t give me options for mod_perl, only
apachectl

[root@rt_sys]#./configure --with-mysql --with-modperl2 --with-apachectl
configure: WARNING: unrecognized options: --with-mysql, --with-modperl2
configure: error: cannot find install-sh, install.sh, or shtool in “.”
"./…" “./…/…”

Please help me pinpoint where I might be going wrong, or better, a guide
to help me complete the installation from start to finish on CentOS. I
have been using the root account (the only account on the system) in my
installation…

Regards,

Gregory Okoth

The args between ./configure and rt-test-dependencies don’t have the
same syntax.

Read this carefully.

http://requesttracker.wikia.com/wiki/ManualInstallationOn 12/20/10 9:15 AM, Gregory Greafers wrote:

Hi RT Community,
I have been having a difficulty in setting up RT on my CentOS
[Apache2, mysql, postfix]. Its defaulting on FCGI while I want it to
use mod-perl2.

In my /tmp/rt-3.8.8. when I test my RT installation,

[root@rt_sys]# make testdeps
/usr/bin/perl ./sbin/rt-test-dependencies --verbose --with-mysql
–with-fastcgi
perl:

=5.8.3(5.8.8) …found
users:
rt group (rt) …found
bin owner (root) …found
libs owner (root) …found
libs group (bin) …found
web owner (apache) …found
web group (apache) …found
CLI dependencies:

The RT configure file doesn’t give me options for mod_perl, only apachectl

[root@rt_sys mailto:root@rt_sys]#./configure --with-mysql
–with-modperl2 --with-apachectl
configure: WARNING: unrecognized options: --with-mysql, --with-modperl2
configure: error: cannot find install-sh, install.sh, or shtool in “.”
"./…" “./…/…”

Please help me pinpoint where I might be going wrong, or better, a
guide to help me complete the installation from start to finish on
CentOS. I have been using the root account (the only account on the
system) in my installation…


Regards,

Gregory Okot**h

John Arends
jarends@illinois.edu
Network Analyst
College of ACES ITCS
University of Illinois at Urbana-Champaign

Hi RT Community,
I have been having a difficulty in setting up RT on my CentOS [Apache2, mysql, postfix]. Its
defaulting on FCGI while I want it to use mod-perl2.

In my /tmp/rt-3.8.8. when I test my RT installation,

[root@rt_sys]# make testdeps
/usr/bin/perl ./sbin/rt-test-dependencies --verbose --with-mysql --with-fastcgi
perl:

=5.8.3(5.8.8) …found
users:
rt group (rt) …found
bin owner (root) …found
libs owner (root) …found
libs group (bin) …found
web owner (apache) …found
web group (apache) …found
CLI dependencies:

The RT configure file doesn’t give me options for mod_perl, only apachectl

[[1]root@rt_sys]#./configure --with-mysql --with-modperl2 --with-apachectl

run ./configure --help to get a sense of the correct options.

-kevin