Sendmail configuration error


#1

In v1.0.1 I’ve noticed a slight glitch with the sendmail options:
in /rt_path/etc/config.pm around line 73:

$mail_options = “-oi -t -ODeliveryMode=b -OErrorMode=m”;

The above was what was in my copy. My version of sendmail didn’t like this, and
although RT functioned, e-mail transactions took quite some time.
My sendmail version wants spaces between the -O and the option names. i.e. the
line should read:

$mail_options = “-oi -t -O DeliveryMode=b -O ErrorMode=m”;

I don’t know if this is wrong for everybody, or just a few, so DON’T run off
and change it just because you got this message.
If however, when you used the cli to create a new request, you receive a lot
of warnings about “write_log: failed”, “eliveryMode=b: Permission
denied”, and e-mail transactions in general being very slow, although working,
this is possibly the source of the problem.

The version of sendmail is V8/Berkeley, Config version number V8.9.3, on
FreeBSD 4.2 stable.

My suspicion is that sendmail made a change to remove those spaces, but my
version doesn’t know that, or something.
Anyway, thought you might like to know.

-Feargal.

Feargal Reilly,
Systems Administrator,
The Communications Interactive Agency.
Phone: +353-86-8157621


#2

Feargal Reilly said:

In v1.0.1 I’ve noticed a slight glitch with the sendmail options:
in /rt_path/etc/config.pm around line 73:

$mail_options = “-oi -t -ODeliveryMode=b -OErrorMode=m”;

the default works for me on FreeBSD-3.3 with sendmail 8.9.3

The version of sendmail is V8/Berkeley, Config version number V8.9.3, on
FreeBSD 4.2 stable.

I don’t think 4.2 is out, but if you are running FreeBSD 4-STABLE
/usr/sbin/sendmail is not really sendmail but mailwrapper,
which looks at mailer.conf. This is new to FreeBSD 4.

–clark