Running RT at /rt rather than / with Nginx

Hi all,

I am trying to change the location of our RT server to access it at
http://mysite.com/rt instead of http://mysite.com.

We are using NGINX and I followed instructions from the documentation,
namely, we changed the default file content of sites-enabled to:

server {

    listen 80;

    server_name mysite.com;

    access_log  /var/log/nginx/access.log;


    location /rt {

        fastcgi_param  QUERY_STRING       $query_string;

        fastcgi_param  REQUEST_METHOD     $request_method;

        fastcgi_param  CONTENT_TYPE       $content_type;

        fastcgi_param  CONTENT_LENGTH     $content_length;


        fastcgi_param  SCRIPT_NAME        "";

        fastcgi_param  PATH_INFO          $uri;

        fastcgi_param  REQUEST_URI        $request_uri;

        fastcgi_param  DOCUMENT_URI       $document_uri;

        fastcgi_param  DOCUMENT_ROOT      $document_root;

        fastcgi_param  SERVER_PROTOCOL    $server_protocol;


        fastcgi_param  GATEWAY_INTERFACE  CGI/1.1;

        fastcgi_param  SERVER_SOFTWARE    nginx/$nginx_version;


        fastcgi_param  REMOTE_ADDR        $remote_addr;

        fastcgi_param  REMOTE_PORT        $remote_port;

        fastcgi_param  SERVER_ADDR        $server_addr;

        fastcgi_param  SERVER_PORT        $server_port;

        fastcgi_param  SERVER_NAME        $server_name;

        fastcgi_pass 127.0.0.1:9000;

    }

}

and in Site_Config.pm we put the following:

Set($WebPath, “/rt”);

Set($WebBaseURL, ‘http://mysite.com’);

When trying to access the site we get the following error “Too many
redirect occurred trying to open http://mysite.com/rt/NoAuth/Login.html?”

Any ideas?

Thanks in advance,

François MEEHAN
Technical Support | Support Technique
VuWall Technology, Inc.

Tel: +1 514-505-4436
Skype: VuWall-Support

Hi,
I know that problem I had this on my installation althoug.

To resolve that Problem I changed the Login template. In that template you have to add the suburl. In your case /rt to the submit function.> Am 29.02.2016 um 23:14 schrieb François Meehan fmeehan@vuwall.com:

Hi all,

I am trying to change the location of our RT server to access it at http://mysite.com/rt instead of http://mysite.com.

We are using NGINX and I followed instructions from the documentation, namely, we changed the default file content of sites-enabled to:

server {
listen 80;
server_name mysite.com;
access_log /var/log/nginx/access.log;

    location /rt {
        fastcgi_param  QUERY_STRING       $query_string;
        fastcgi_param  REQUEST_METHOD     $request_method;
        fastcgi_param  CONTENT_TYPE       $content_type;
        fastcgi_param  CONTENT_LENGTH     $content_length;

        fastcgi_param  SCRIPT_NAME        "";
        fastcgi_param  PATH_INFO          $uri;
        fastcgi_param  REQUEST_URI        $request_uri;
        fastcgi_param  DOCUMENT_URI       $document_uri;
        fastcgi_param  DOCUMENT_ROOT      $document_root;
        fastcgi_param  SERVER_PROTOCOL    $server_protocol;

        fastcgi_param  GATEWAY_INTERFACE  CGI/1.1;
        fastcgi_param  SERVER_SOFTWARE    nginx/$nginx_version;

        fastcgi_param  REMOTE_ADDR        $remote_addr;
        fastcgi_param  REMOTE_PORT        $remote_port;
        fastcgi_param  SERVER_ADDR        $server_addr;
        fastcgi_param  SERVER_PORT        $server_port;
        fastcgi_param  SERVER_NAME        $server_name;
        fastcgi_pass 127.0.0.1:9000;
    }
}

and in Site_Config.pm we put the following:

Set($WebPath, “/rt”);
Set($WebBaseURL, ‘http://mysite.com’);

When trying to access the site we get the following error “Too many redirect occurred trying to open http://mysite.com/rt/NoAuth/Login.html?”

Any ideas?

Thanks in advance,


François MEEHAN
Technical Support | Support Technique
VuWall Technology, Inc.

Tel: +1 514-505-4436
Skype: VuWall-Support


RT 4.4 and RTIR Training Sessions (http://bestpractical.com/services/training.html)

  • Hamburg Germany - March 14 & 15, 2016
  • Washington DC - May 23 & 24, 2016

I checked what i have changed.

I copied the Login template to /opt/rt4/local/html/Elements and than
changed this line from

to

On Mon, Feb 29, 2016 at 11:14 PM, François Meehan fmeehan@vuwall.com wrote:

Hi all,

I am trying to change the location of our RT server to access it at
http://mysite.com/rt instead of http://mysite.com.

We are using NGINX and I followed instructions from the documentation,
namely, we changed the default file content of sites-enabled to:

server {

    listen 80;

    server_name mysite.com;

    access_log  /var/log/nginx/access.log;


    location /rt {

        fastcgi_param  QUERY_STRING       $query_string;

        fastcgi_param  REQUEST_METHOD     $request_method;

        fastcgi_param  CONTENT_TYPE       $content_type;

        fastcgi_param  CONTENT_LENGTH     $content_length;


        fastcgi_param  SCRIPT_NAME        "";

        fastcgi_param  PATH_INFO          $uri;

        fastcgi_param  REQUEST_URI        $request_uri;

        fastcgi_param  DOCUMENT_URI       $document_uri;

        fastcgi_param  DOCUMENT_ROOT      $document_root;

        fastcgi_param  SERVER_PROTOCOL    $server_protocol;


        fastcgi_param  GATEWAY_INTERFACE  CGI/1.1;

        fastcgi_param  SERVER_SOFTWARE    nginx/$nginx_version;


        fastcgi_param  REMOTE_ADDR        $remote_addr;

        fastcgi_param  REMOTE_PORT        $remote_port;

        fastcgi_param  SERVER_ADDR        $server_addr;

        fastcgi_param  SERVER_PORT        $server_port;

        fastcgi_param  SERVER_NAME        $server_name;

        fastcgi_pass 127.0.0.1:9000;

    }

}

and in Site_Config.pm we put the following:

Set($WebPath, “/rt”);

Set($WebBaseURL, ‘http://mysite.com’);

When trying to access the site we get the following error “Too many
redirect occurred trying to open http://mysite.com/rt/NoAuth/Login.html?”

Any ideas?

Thanks in advance,

François MEEHAN
Technical Support | Support Technique
VuWall Technology, Inc.

Tel: +1 514-505-4436
Skype: VuWall-Support


RT 4.4 and RTIR Training Sessions (
http://bestpractical.com/services/training.html)

  • Hamburg Germany - March 14 & 15, 2016
  • Washington DC - May 23 & 24, 2016

Hi,

the docs says for $WebBaseURL “Usually you don’t want to set these
options” [1].
Remove $WebBaseURL config and set $WebDomain to ‘mysite.com’ and
everything should be fine.
If you use SSL, remember to also set $WebPort to 443.

Chris

[1]
https://www.bestpractical.com/docs/rt/4.2/RT_Config.html#WebBaseURL-WebURL
[2] https://www.bestpractical.com/docs/rt/4.2/RT_Config.html#WebDomainAm 29.02.2016 um 23:14 schrieb Fran�ois Meehan:

Set($WebPath, “/rt”);

Set($WebBaseURL, ‘http://mysite.com’);