RTFM in loaded modules/Plugins, but no Link/not active?

Hi,
I am upgrading an old version of RT & RTFM to the latest/greatest. The
RT upgrade went off without a hitch, and the RTFM upgrade also produced
no errors, but I am not seeing the RTFM links in my menu, and my old
RTFM URLs are giving 404 “not found” errors. What is even weirder, is
that the RTFM module DOES show up in my list of “Loaded Modules” and is
listed under Plugins on my RT’s System Configuration page.

Any advice/help as to how to resolve this would be appreciated.

Here are more details:
Original installation versions:
RT = 3.4.4
RTFM = 2.2.0RC2
OS = FreeBSD 6.0

Using a non-standard installation directory at /web/mydomain.com/rt-3.8.4
NOTE: I was able to specify this with the --prefix option during the
’configure’ stage of the RT install, but nothing similar for the RTFM
installation, so I manually edited the generated Makefile and replaced
all instances of /usr/local/rt3/local/ as well as /usr/local/rt3/share/
and finally /usr/local/rt3/ with my custom install directory. The ‘make
install’ went off without any errors and I verified that the RT::FM
modules and config did end up in the correct lib and etc directories
under by custom install dir.
Thinking that this may have been the cause of my error, I re-ran the
’make install’ using the original makefile, and still have not had any
luck getting it to show up anywhere.

Here are my full installation notes.

  1. Upgraded RT from 3.4.4 -> 3.8.4 by basically doing a fresh code
    installation of 3.8.4, upgrading my database, and copying over the
    configuration from RT_SiteConfig - no problem, everything is running
    except that RTFM is not there.
  2. ran perl Makefile.PL
    NOTE: this seemed to pick up default installation directory at
    /usr/local/rt3/local/
    trying with a --prefix option… unsuccessful.

‘–PREFIX’ is not a known MakeMaker parameter name.

the Makefile.PL itself is pretty sparse.
checking the web for instructions on installing RTFM in a non-standard
directory…
seeing references to this problem, but no clear answers
ref:
http://www.mail-archive.com/rt-users@lists.bestpractical.com/msg04487.html

checking out the generated makefile…
there are a few references, looks like i can probably just replace them
with sed:
sed -e “s@/usr/local/rt3/local@/web/mydomain.comrt-3.8.4@g” -i .bak Makefile
sed -e “s@/usr/local/rt3/share@/web/mydomain.comrt-3.8.4@g” -i .bak Makefile
sed -e “s@/usr/local/rt3@/web/mydomain.com/rt-3.8.4@g” -i .bak Makefile

trying out the installation:
$ make install
… seems to have completed successfully, no errors.

generate table upgrade SQL:
$ perl etc/upgrade/upgrade-mysql-schema.pl mydomain_com rt_user rt_pass

sql.queries

Applied the queries:
$ mysql -u root -p mydomain_com < sql.queries

enabled RTFM in RT_SiteConfig.pm file - added the following line:
Set(@Plugins,qw(RT::FM));

Cleared the mason cache:
$ rm -rf /web/mydomain.com/rt-3.8.4/var/mason_data/*

restart apache
$ apachectl stop / startssl

Testing!!!
hmm… still getting “page not found” for an RTFM link:
https://mydomain.com/rt/RTFM/Article/Display.html?id=59
also, RTFM is not showing up in the menu bar links.

RT/FM modules DO exist in the lib/ directory…

NOTE:under RT’s system configuration:
https://mydomain.com/rt/Admin/Tools/Configuration.html
I DO see the RT::FM Plugin is loaded…
and under loaded modules, the new version (RT::FM v2.4.2;) is listed.

reviewing the documentation at lib/RT/FM/Introduction.pod …

tried clearing the cache and restarting apache again…
hmm… still no RTFM in the menu.

trying an installation with the default makefile…
cleared the cache and restarted apache…
nope… still no RTFM in the menu.

Benjamin Bradley
benjamin@gaiahost.coop 1-800-672-8060 x802
GAIA Host Collective, LLC http://www.gaiahost.coop
"Reliable Internet hosting services
from a worker-owned cooperative dedicated to
environmental and social sustainability."
general support email: support@gaiahost.coop
urgent support issues: 1-800-672-8060 x0

Hi,
I am upgrading an old version of RT & RTFM to the latest/greatest. The
RT upgrade went off without a hitch, and the RTFM upgrade also
produced
no errors, but I am not seeing the RTFM links in my menu, and my old
RTFM URLs are giving 404 “not found” errors. What is even weirder, is
that the RTFM module DOES show up in my list of “Loaded Modules” and
is
listed under Plugins on my RT’s System Configuration page.

Any advice/help as to how to resolve this would be appreciated.

Here are more details:
Original installation versions:
RT = 3.4.4
RTFM = 2.2.0RC2
OS = FreeBSD 6.0

Using a non-standard installation directory at /web/mydomain.com/
rt-3.8.4
NOTE: I was able to specify this with the --prefix option during the
’configure’ stage of the RT install, but nothing similar for the RTFM
installation, so I manually edited the generated Makefile and replaced
all instances of /usr/local/rt3/local/ as well as /usr/local/rt3/
share/
and finally /usr/local/rt3/ with my custom install directory. The
’make
install’ went off without any errors and I verified that the RT::FM
modules and config did end up in the correct lib and etc directories
under by custom install dir.
Thinking that this may have been the cause of my error, I re-ran the
’make install’ using the original makefile, and still have not had any
luck getting it to show up anywhere.

Here are my full installation notes.

  1. Upgraded RT from 3.4.4 -> 3.8.4 by basically doing a fresh code
    installation of 3.8.4, upgrading my database, and copying over the
    configuration from RT_SiteConfig - no problem, everything is running
    except that RTFM is not there.
  2. ran perl Makefile.PL
    NOTE: this seemed to pick up default installation directory at
    /usr/local/rt3/local/
    trying with a --prefix option… unsuccessful.

‘–PREFIX’ is not a known MakeMaker parameter name.

try

RTHOME=/path/to/your/rt/root/directory perl Makefile.PL

This sounds like your files somehow didn’t end up in
$RTHOME/local/plugins/RT-FM/ like they should have

You say that RT/FM.pm is in lib/ which is really the wrong place,
it should all be installed under the plugins directory

-kevin

Kevin,
That did it. Thanks for the tip!

That RTHOME trick should be included in the RTFM README docs! :slight_smile:

Cheers,
Benjamin

Kevin Falcone wrote:

try

RTHOME=/path/to/your/rt/root/directory perl Makefile.PL

This sounds like your files somehow didn’t end up in
$RTHOME/local/plugins/RT-FM/ like they should have

You say that RT/FM.pm is in lib/ which is really the wrong place,
it should all be installed under the plugins directory

-kevin

Benjamin Bradley
benjamin@gaiahost.coop 1-800-672-8060 x802
GAIA Host Collective, LLC http://www.gaiahost.coop
"Reliable Internet hosting services
from a worker-owned cooperative dedicated to
environmental and social sustainability."
general support email: support@gaiahost.coop
urgent support issues: 1-800-672-8060 x0