Rt344 on solaris 9, syslog error

Hi.

I’m installing rt3.4.4 on solaris 9.
I’ve come across the syslog bug.
The one that gives you this output when you try to log in:

error: no connection to syslog available at
/webhosting/stow/perl-5.8.5/perl5/lib/site_perl/5.8.5/Log/Dispatch/Syslog.pm
line 77

I’ve tried the fix that mentions putting:
@LogToSyslogConf = ( ) unless (@LogToSyslogConf);
@LogToSyslogConf = ( socket => ‘inet’ ) unless (@LogToSyslogConf);

However, this fix doesn’t work for me.
I think I might have to edit RT.pm.
Any suggestions?

Thanks.
Kind regards.

Luke

Hi.

I’m installing rt3.4.4 on solaris 9.
I’ve come across the syslog bug.
The one that gives you this output when you try to log in:

error: no connection to syslog available at
/webhosting/stow/perl-5.8.5/perl5/lib/site_perl/5.8.5/Log/Dispatch/Syslog.pm
line 77

I’ve tried the fix that mentions putting:
@LogToSyslogConf = ( ) unless (@LogToSyslogConf);
@LogToSyslogConf = ( socket => ‘inet’ ) unless (@LogToSyslogConf);

However, this fix doesn’t work for me.
I think I might have to edit RT.pm.
Any suggestions?
You need to put: “@LogToSyslogConf = ( socket => ‘inet’ );” without
unless and restart RT server. Stop and start

Thanks.
Kind regards.


Luke


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Buy your copy of our new book, RT Essentials, today!

Download a free sample chapter from http://rtbook.bestpractical.com

Best regards, Ruslan.

Hi.

Ruslan Zakirov wrote:>On 10/11/05, Luke Vanderfluit lvanderf@internode.com.au wrote:

Hi.

I’m installing rt3.4.4 on solaris 9.
I’ve come across the syslog bug.
The one that gives you this output when you try to log in:

error: no connection to syslog available at
/webhosting/stow/perl-5.8.5/perl5/lib/site_perl/5.8.5/Log/Dispatch/Syslog.pm
line 77

I’ve tried the fix that mentions putting:
@LogToSyslogConf = ( ) unless (@LogToSyslogConf);
@LogToSyslogConf = ( socket => ‘inet’ ) unless (@LogToSyslogConf);

However, this fix doesn’t work for me.
I think I might have to edit RT.pm.
Any suggestions?

You need to put: “@LogToSyslogConf = ( socket => ‘inet’ );” without
unless and restart RT server. Stop and start

OK.
I’ve done the following from the source tree.
./configure --with-db-rt-pass=‘somepass’ --prefix=/usr/local/rt3

perl sbin/rt-test-dependencies --with-mysql --with-modperl1
shows up with everything found.

make install went fine.

Then I have the following section in my RT_SiteConfig.pm:

/~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Set($LogToSyslog , ‘’);
Set($LogToScreen , ‘debug’);
Set($LogToFile , ‘debug’);
Set($LogDir, ‘/usr/local/rt3/var/log’);
Set($LogToFileNamed , “rt.log”); #log to rt.log

On Solaris or UnixWare, set to ( socket => ‘inet’ ). Options here

override any other options RT passes to Log::Dispatch::Syslog.

Other interesting flags include facility and logopt. (See the

Log::Dispatch::Syslog documentation for more information.) (Maybe

ident too, if you have multiple RT installations.)

#@LogToSyslogConf = () unless (@LogToSyslogConf);
@LogToSyslogConf = ( socket => ‘inet’ ); #unless (@LogToSyslogConf);
_____________________________________
I restarted the webserver and still got the same error.
Then I stop httpd and made sure no httpd was running.
Then started the server and it worked.
:slight_smile:

However now I can’t log in.
I’ve tried “root”:"somepass"
somepass is the same password as I used with ./configure
–with-db-rt-pass=‘somepass’

But I couldn’t get it.
Then I tried “rtuser”:“somepass” as they are set the RT_SiteConfig.pm file.
That didn’t work either.

Which username and password combination is the one to use for an initial
login?

Thanks.

Luke

Hi.

Harald Wagener wrote:

Am 11.10.2005 um 09:20 schrieb Luke Vanderfluit:

However now I can’t log in.
I’ve tried “root”:"somepass"
somepass is the same password as I used with ./configure --with-db-
rt-pass=‘somepass’

As stated in the readme, the default password for RT’s root user is
’password’. It is not the same as the password for database
authentication.

Thanks heaps.
Kind regards.

Luke

Hi.

Hello.

[…]

However now I can’t log in.
I’ve tried “root”:"somepass"
somepass is the same password as I used with ./configure --with-db-
rt-pass=‘somepass’

As stated in the readme, the default password for RT’s root user is
’password’. It is not the same as the password for database
authentication.

Regards,
Harald

Harald Wagener
Technischer Leiter

Foote Cone & Belding
FCB Wilkens
An der Alster 42
20099 Hamburg
Germany

T: +49 (0)40 2881 1252
F: +49 (0)40 2881 1217
hwagener@hamburg.fcb.com
http://www.footeconebelding.de