Rt3 sends emails from "nobody".. ? help!

Hello,

I am using rt3 with postfix as the MTA. The “From:” line that is being passed in the header is the correct value that I’ve configured. However, the value that shows up in the mail log is:

Jun 9 23:40:34 rt postfix/nqmgr[1359]: 85BCC97447: from=nobody@rt.vmdirect.com, size=1579, nrcpt=1 (queue active)

I don’t know where that nobody is coming from nor how to fix it. Can anyone give me clues on which direction I should look? Is it more likely a postfix config than a rt3 config?

My problem being, if the email that creates a ticket is submitted with a bogus email address (from an online form), I would like that bounce to make its way back into RT, hopefully into the same ticket so the tech support person knows that the emails aren’t making it. As it is, they’re being bounced back to ‘nobody’.

I see that it was injected into the postfix system from UID 99, which is indeed ‘nobody’… here is the headers:

Received: by rt.vmdirect.com (Postfix, from userid 99)
id D71A897446; Mon, 9 Jun 2003 23:41:41 -0400 (EDT)
RT-Attach-Message: yesSubject: [VMdirect #47] testing bounce two - this is the text here
From: “Val Luck via RT” techsupport@vmdirect.com
Reply-To: techsupport@vmdirect.com
In-Reply-To: rt-47@VMdirect
Message-ID: rt-3.0.2-47-127.7.79077214750117@VMdirect
Precedence: bulk
X-RT-Loop-Prevention: VMdirect
RT-Ticket: VMdirect #47
Managed-by: RT 3.0.2 (http://www.bestpractical.com/rt/)
RT-Originator: valentine.luck@vmdirect.com
To: bogusbounce@yatoopos.net

I see the “From” line and the “Reply-To” line both have the correct address that I’d like the bounce to come to. Why is postfix deciding to bounce it back to the UID 99 user (nobody)?

This is seeming more and more like a postfix issue… Anyway, as I have this email typed up, if anyone can shed any light on which direction I should go, that’d be great.

Thanks!

Val

Kenneth,

Thanks so much for the info. As it turns out, I discovered the same thing with more research. I did get the -f and -r flags to work.

I ended up adding a line to the SendEmail.pm module to add an Errors-To header, which worked flawlessly. (RT users, is there a way to configure a Errors-To destination in the Config file? If not, is there a process submit modified/updated/fixed code for future versions of RT?)

However, I’ll never get it to work because I can not depend on remote MTAs maintaining the [ticket ##] information in the subject line, so if it is forwarded back to RT it ends up creating a new ticket. :frowning: Has anyone devised a workaround for this?

Thanks again Kenneth!

ValFrom: kenneth dombrowski [mailto:kenneth@ylayali.net]
Sent: Tuesday, June 10, 2003 5:59 AM
To: Val Luck
Subject: Re: [rt-users] rt3 sends emails from “nobody”… ? help!

Hi Val,

in case you haven’t had another reply,

it’s definitely a postfix thing. I use exim so can’t tell you exactly
what the equivalent is, but exim has a trusted_users setting which
allows specified users to set their own From: header, and not have exim
add a Sender: header (or perhaps exim will set the trusted_user’s
Sender: to the From: rather than the actual system account…). My debian
server runs apache as “www-data”, but most distros use “nobody”… looks
like yours does. I’m not sure about the order (or the rfc#) but I think
it’s this: if an Errors-to: is defined, bounces will go there, if not,
Sender: is used, and only as a last resort will bounces go to the From:
address

a google for “postfix trusted_users” returns an interesting NeoMail
configuration thread,

http://archives.neohapsis.com/archives/postfix/2000-04/0079.html

which implies there’s actually not an equivalent to trusted_users, but
that you can achieve the same effect with the -r flag to sendmail

I didn’t look further than that,

Kenneth