RT3 is very slow

Hallo,
we’ve a machine with RT3, about 300 tickets and 50 users and RT is very
slow. Ticket, that have meny attachemets and comments, is displaying 2:45 min
on dual PII 350 MHz. But overal system is very slow, not only big tickets.
If I move RT3 on Duron 1,8 GHz, 1 GB RAM, the same ticket is displaying 45
sec. - it’s no good result.

Does everyone the same experience? Is it possible to speedup system, because
this is unusable speed.

Thanks

Tomas Huryn

Hallo,
we’ve a machine with RT3, about 300 tickets and 50 users and RT is
very
slow. Ticket, that have meny attachemets and comments, is displaying
2:45 min
on dual PII 350 MHz. But overal system is very slow, not only big
tickets.
If I move RT3 on Duron 1,8 GHz, 1 GB RAM, the same ticket is
displaying 45
sec. - it’s no good result.

You need to tell us which versions of rt, perl You use.
You need to tell us which database You use (and which version).

Then we can try helping You.

Recommmended is

RT 3.0.9 (latest)
perl 5.8.3 (latest)
MySQL 4.0.18 (latest) with innodb type tables

A lot of speed can be gained by tuning MySQL.

Regards,
Harald

OK, we have all versions described below, that is:

RT 3.0.9 (latest)
perl 5.8.3 (latest)
MySQL 4.0.18 (latest) with innodb type tables

Dne čt 18. března 2004 11:24 Harald Wagener napsal(a):

Am 18.03.2004 um 09:56 schrieb Tomáš Hurýn:

Hallo,
we’ve a machine with RT3, about 300 tickets and 50 users and RT is
very
slow. Ticket, that have meny attachemets and comments, is displaying
2:45 min
on dual PII 350 MHz. But overal system is very slow, not only big
tickets.
If I move RT3 on Duron 1,8 GHz, 1 GB RAM, the same ticket is
displaying 45
sec. - it’s no good result.

You need to tell us which versions of rt, perl You use.
You need to tell us which database You use (and which version).

Then we can try helping You.

Recommmended is

RT 3.0.9 (latest)
perl 5.8.3 (latest)
MySQL 4.0.18 (latest) with innodb type tables

A lot of speed can be gained by tuning MySQL.

Regards,
Harald


rt-users mailing list
rt-users@lists.bestpractical.com
The rt-users Archives

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

Tomáš Hurýn

OK, we have all versions described below, that is:

RT 3.0.9 (latest)
perl 5.8.3 (latest)
MySQL 4.0.18 (latest) with innodb type tables

Did You tune the innodb settings for MySQL according to
http://www.innodb.com/ibman.php, especially
http://www.innodb.com/ibman.php#InnoDB.tuning ? That helped alot here -
in our experience, having 1 Gig of RAM in Your machine is a bit
pointless if the database does not use it…

Regards,
Harald

OK, but perl always is at 100 % CPU, not mysql. I understand that the problem
can be in mysql, but the question is any tuning of database will lead to the
solution.

Dne čt 18. března 2004 12:24 Harald Wagener napsal(a):

Am 18.03.2004 um 12:05 schrieb Tomáš Hurýn:

OK, we have all versions described below, that is:

RT 3.0.9 (latest)
perl 5.8.3 (latest)
MySQL 4.0.18 (latest) with innodb type tables

Did You tune the innodb settings for MySQL according to
http://www.innodb.com/ibman.php, especially
http://www.innodb.com/ibman.php#InnoDB.tuning ? That helped alot here -
in our experience, having 1 Gig of RAM in Your machine is a bit
pointless if the database does not use it…

Regards,
Harald


rt-users mailing list
rt-users@lists.bestpractical.com
The rt-users Archives

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

Tomáš Hurýn

OK, but perl always is at 100 % CPU, not mysql. I understand that the
problem
can be in mysql, but the question is any tuning of database will lead
to the
solution.

My experience was that perl was spinning the cpu waiting for MySQL to
answer it’s request.

Regards,
Harald