RT3 is very slow (Tom? Hur?n)

Hi Tom,

we had the same problem a month ago. We have fixed it by tuning the perl
environment. we had switched from mod_perl to fastCGI. Open a lot of Fastcgi
Prozesses for the lot of users (we have 1 process for 50 users)

We had decreased the time for the steps down to < 2sek for a normal work
process

Our Environment:

6000 User
45000 Tickets
Dual Xeon 2400
2 GB RAM

APACHE 2
Perl 5.8.x
FastCGI
MySQL 4 (innodb)

Hope this helps you, btw. you can contact me directly, i will give you our
configuration

Message: 8Date: Thu, 18 Mar 2004 09:56:51 +0100
From: Tom?? Hur?n thuryn@aplis.cz
Subject: [rt-users] RT3 is very slow
To: rt-users@lists.bestpractical.com
Message-ID: 200403180956.52029.thuryn@aplis.cz
Content-Type: text/plain; charset=“iso-8859-2”

Hallo,
we’ve a machine with RT3, about 300 tickets and 50 users and RT is very
slow. Ticket, that have meny attachemets and comments, is displaying 2:45
min
on dual PII 350 MHz. But overal system is very slow, not only big tickets.
If I move RT3 on Duron 1,8 GHz, 1 GB RAM, the same ticket is displaying 45
sec. - it’s no good result.

Does everyone the same experience? Is it possible to speedup system,
because
this is unusable speed.

Thanks

Tomas Huryn

Message: 9
Date: Thu, 18 Mar 2004 11:24:58 +0100
From: Harald Wagener hwagener@hamburg.fcb.com
Subject: Re: [rt-users] RT3 is very slow
To: ‘rt-users@lists.fsck.com’ rt-users@lists.fsck.com
Message-ID: 81EF6644-78C6-11D8-B540-003065DC18B8@hamburg.fcb.com
Content-Type: text/plain; charset=WINDOWS-1252; format=flowed

Hallo,
we’ve a machine with RT3, about 300 tickets and 50 users and RT is
very
slow. Ticket, that have meny attachemets and comments, is displaying
2:45 min
on dual PII 350 MHz. But overal system is very slow, not only big
tickets.
If I move RT3 on Duron 1,8 GHz, 1 GB RAM, the same ticket is
displaying 45
sec. - it’s no good result.

You need to tell us which versions of rt, perl You use.
You need to tell us which database You use (and which version).

Then we can try helping You.

Recommmended is

RT 3.0.9 (latest)
perl 5.8.3 (latest)
MySQL 4.0.18 (latest) with innodb type tables

A lot of speed can be gained by tuning MySQL.

Regards,
Harald

Message: 10
Date: Thu, 18 Mar 2004 12:05:28 +0100
From: Tom?? Hur?n thuryn@aplis.cz
Subject: Re: [rt-users] RT3 is very slow
To: rt-users@lists.bestpractical.com
Message-ID: 200403181205.28941.thuryn@aplis.cz
Content-Type: text/plain; charset=“iso-8859-2”

OK, we have all versions described below, that is:

RT 3.0.9 (latest)
perl 5.8.3 (latest)
MySQL 4.0.18 (latest) with innodb type tables

Dne ht 18. bxezna 2004 11:24 Harald Wagener napsal(a):

Am 18.03.2004 um 09:56 schrieb Toma9 Hur}n:

Hallo,
we’ve a machine with RT3, about 300 tickets and 50 users and RT is
very
slow. Ticket, that have meny attachemets and comments, is displaying
2:45 min
on dual PII 350 MHz. But overal system is very slow, not only big
tickets.
If I move RT3 on Duron 1,8 GHz, 1 GB RAM, the same ticket is
displaying 45
sec. - it’s no good result.

You need to tell us which versions of rt, perl You use.
You need to tell us which database You use (and which version).

Then we can try helping You.

Recommmended is

RT 3.0.9 (latest)
perl 5.8.3 (latest)
MySQL 4.0.18 (latest) with innodb type tables

A lot of speed can be gained by tuning MySQL.

Regards,
Harald


rt-users mailing list
rt-users@lists.bestpractical.com
http://lists.bestpractical.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

Toma9 Hur}n

Message: 11
Date: Thu, 18 Mar 2004 12:24:37 +0100
From: Harald Wagener hwagener@hamburg.fcb.com
Subject: Re: [rt-users] RT3 is very slow
To: ‘rt-users@lists.fsck.com’ rt-users@lists.fsck.com
Message-ID: D7245951-78CE-11D8-B540-003065DC18B8@hamburg.fcb.com
Content-Type: text/plain; charset=WINDOWS-1252; format=flowed

OK, we have all versions described below, that is:

RT 3.0.9 (latest)
perl 5.8.3 (latest)
MySQL 4.0.18 (latest) with innodb type tables

Did You tune the innodb settings for MySQL according to
http://www.innodb.com/ibman.php, especially
http://www.innodb.com/ibman.php#InnoDB.tuning ? That helped alot here -
in our experience, having 1 Gig of RAM in Your machine is a bit
pointless if the database does not use it…

Regards,
Harald

Message: 12
Date: Thu, 18 Mar 2004 13:29:10 +0100
From: Tom?? Hur?n thuryn@aplis.cz
Subject: Re: [rt-users] RT3 is very slow
To: rt-users@lists.bestpractical.com
Message-ID: 200403181329.10134.thuryn@aplis.cz
Content-Type: text/plain; charset=“iso-8859-2”

OK, but perl always is at 100 % CPU, not mysql. I understand that the
problem
can be in mysql, but the question is any tuning of database will lead to the
solution.

Dne ht 18. bxezna 2004 12:24 Harald Wagener napsal(a):

Am 18.03.2004 um 12:05 schrieb Toma9 Hur}n:

OK, we have all versions described below, that is:

RT 3.0.9 (latest)
perl 5.8.3 (latest)
MySQL 4.0.18 (latest) with innodb type tables

Did You tune the innodb settings for MySQL according to
http://www.innodb.com/ibman.php, especially
http://www.innodb.com/ibman.php#InnoDB.tuning ? That helped alot here -
in our experience, having 1 Gig of RAM in Your machine is a bit
pointless if the database does not use it…

Regards,
Harald


rt-users mailing list
rt-users@lists.bestpractical.com
http://lists.bestpractical.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

Toma9 Hur}n

rt-users mailing list
rt-users@lists.bestpractical.com
http://lists.bestpractical.com/mailman/listinfo/rt-users

End of rt-users Digest, Vol 5, Issue 66

Thanks for the info.

Would you mind sharing your apache2/fastcgi configuration?

I am setting up RT on RHEL3 and your configuration seems to be what I am
looking for.

Thanks,

Paul EdenOn Thu, 2004-03-18 at 06:07, HAM MI-IH / Torsten Brumm wrote:

Hi Tom,

we had the same problem a month ago. We have fixed it by tuning the perl
environment. we had switched from mod_perl to fastCGI. Open a lot of Fastcgi
Prozesses for the lot of users (we have 1 process for 50 users)

We had decreased the time for the steps down to < 2sek for a normal work
process

Our Environment:

6000 User
45000 Tickets
Dual Xeon 2400
2 GB RAM

APACHE 2
Perl 5.8.x
FastCGI
MySQL 4 (innodb)

Hope this helps you, btw. you can contact me directly, i will give you our
configuration

Yes, but I’m running Apache 1.3.29. Config is hear:

AddHandler fastcgi-script .fcgi
Alias /NoAuth/images/ /opt/rt3/schare/html/NoAuth/images/
FastCgiServer /opt/rt3/bin/mason_handler.fcgi
ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/
ScriptAliasMatch (./)$ /opt/rt3/bin/mason_handler.fcgi$1
ScriptAliasMatch (.
.html)$ /opt/rt3/bin/mason_handler.fcgi$1

NameVirtualHost 127.0.0.1:443

<VirtualHost 127.0.0.1:443>

    ServerName rt.domain
    DocumentRoot /opt/rt3/share/html
    AddDefaultCharset UTF-8

    ServerAdmin root@domain
    ErrorLog logs/ssl_error_log
    TransferLog logs/ssl_access_log
    SSLEngine on
    SSLCipherSuite ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv2:

+EXP:+eNULL
SSLCertificateFile /usr/local/apache/conf/ssl.crt/server.crt
SSLCertificateKeyFile /usr/local/apache/conf/ssl.key/server.key
<Files ~ “.(cgi|shtml|phtml|php3?)$”>
SSLOptions +StdEnvVars

<Directory “/var/www/cgi-bin”>
SSLOptions +StdEnvVars

SetEnvIf User-Agent “.MSIE.
nokeepalive ssl-unclean-shutdown
downgrade-1.0 force-response-1.0
CustomLog logs/ssl_request_log
“%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x “%r” %b”

Dne čt 18. března 2004 15:48 Paul D. Eden napsal(a):

Thanks for the info.

Would you mind sharing your apache2/fastcgi configuration?

I am setting up RT on RHEL3 and your configuration seems to be what I am
looking for.

Thanks,

Paul Eden

Hi Tom,

we had the same problem a month ago. We have fixed it by tuning the perl
environment. we had switched from mod_perl to fastCGI. Open a lot of
Fastcgi Prozesses for the lot of users (we have 1 process for 50 users)

We had decreased the time for the steps down to < 2sek for a normal work
process

Our Environment:

6000 User
45000 Tickets
Dual Xeon 2400
2 GB RAM

APACHE 2
Perl 5.8.x
FastCGI
MySQL 4 (innodb)

Hope this helps you, btw. you can contact me directly, i will give you
our configuration


rt-users mailing list
rt-users@lists.bestpractical.com
http://lists.bestpractical.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

Tomáš Hurýn

Thanks, that’s helpful.

Does anyone have a working apache2/fastcgi configuration they are
willing to share?

PaulOn Thu, 2004-03-18 at 07:57, Tomᅵ Hurᅵn wrote:

Yes, but I’m running Apache 1.3.29. Config is hear:

AddHandler fastcgi-script .fcgi
Alias /NoAuth/images/ /opt/rt3/schare/html/NoAuth/images/
FastCgiServer /opt/rt3/bin/mason_handler.fcgi
ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/
ScriptAliasMatch (./)$ /opt/rt3/bin/mason_handler.fcgi$1
ScriptAliasMatch (.
.html)$ /opt/rt3/bin/mason_handler.fcgi$1

NameVirtualHost 127.0.0.1:443

<VirtualHost 127.0.0.1:443>

    ServerName rt.domain
    DocumentRoot /opt/rt3/share/html
    AddDefaultCharset UTF-8

    ServerAdmin root@domain
    ErrorLog logs/ssl_error_log
    TransferLog logs/ssl_access_log
    SSLEngine on
    SSLCipherSuite ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv2:

+EXP:+eNULL
SSLCertificateFile /usr/local/apache/conf/ssl.crt/server.crt
SSLCertificateKeyFile /usr/local/apache/conf/ssl.key/server.key
<Files ~ “.(cgi|shtml|phtml|php3?)$”>
SSLOptions +StdEnvVars

<Directory “/var/www/cgi-bin”>
SSLOptions +StdEnvVars

SetEnvIf User-Agent “.MSIE.
nokeepalive ssl-unclean-shutdown
downgrade-1.0 force-response-1.0
CustomLog logs/ssl_request_log
“%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x “%r” %b”