RT3 installation problems (Mason)

I am trying to do a new install of the RT3 beta.

The dependency check seemed to go well, and everything installed fine.

However, I get a 500 server error when I try to access RT via a
browser. This shows up in my apache error_log:

[Thu Mar 6 11:51:59 2003] [error] Undefined subroutine &RT:Mason::handler called.

But I have Mason, as CPAN installed for me:
/usr/local/lib/perl5/site_perl/5.8.0/HTML/Mason.pm
/usr/local/lib/perl5/site_perl/5.8.0/Apache/Mason.pm
/usr/local/lib/perl5/site_perl/5.8.0/Bundle/HTML/Mason.pm

I’m using got mod_perl 1.27 w/apache 1.3.27, which I installed using the
PDF installation guide that somebody posted a link to several days back.

I am using OpenBSD and PostgreSQL.

Here is my (sanitized) section of my httpd.conf:

ServerName xxxx.xxxx.xxx DocumentRoot /var/www/rt3/share/html AddDefaultCharset UTF-8
    PerlModule Apache::DBI
    PerlRequire /var/www/rt3/bin/webmux.pl

    <Location />
            SetHandler perl-script
            PerlHandler RT:Mason
    </Location>

When I comment out the “PerlHandler RT:Mason”, I get what looks like
the perl source of something. The URL in my location box is
http://xxxx.xxxx.xxx/index.html? .

I’m guessing that RT just can’t find Mason. Is there a path setting
I’m just missing somewhere? Is there a dependency the script doesn’t
specifically check for?

Mary Hunter John F. Kennedy University
Information Services 12 Altarinda Road
Orinda, CA 94563-2603

Mary Hunter wrote:

    <Location />
            SetHandler perl-script
            PerlHandler RT:Mason
    </Location>

When I comment out the “PerlHandler RT:Mason”, I get what looks like
the perl source of something. The URL in my location box is
http://xxxx.xxxx.xxx/index.html? .

You want

PerlHandler RT::Mason

note the extra colon there.
�|� http://www.bestpractical.com/rt – Trouble Ticketing. Free.

PerlHandler RT::Mason

note the extra colon there.

D’oh!

It’s funny how sometimes you spend several days fixing big, far-reaching
problems in your system’s dependencies, and then don’t notice that you’ve
missed a colon…

It’s finally up and running, though.

Thanks!!!

  • Mary