Rt3 install problem (3.0.4)

Does anybody have any ideas on how to track this problem down?

I have an rt2 installation with 14k+ tickets, years of uptime.

Upgraded to 2.0.15, upgraded mason, ran the dependancy installer for
rt3. no errors, no problems.

configged rt3 with web user and group apache (redhat 7.2) installed, did
the database, etc. no problems.

added another alias (/rt3) configged as specified. Loaded the page, and
it looks like preprocessing isn’t happening.

This is what I get (part):

%# BEGIN LICENSE BLOCK %# %# Copyright © 1996-2003 Jesse Vincent %# %#
(Except where explictly superceded by other copyright notices) %# %#
This work is made available to you under the terms of Version 2 of %#
the GNU General Public License. A copy of that license should have %#
been provided with this software, but in any event can be snarfed %#
from www.gnu.org. %# %# This work is distributed in the hope that it
will be useful, but %# WITHOUT ANY WARRANTY; without even the implied
warranty of %# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See
the GNU %# General Public License for more details. %# %# Unless
otherwise specified, all modifications, corrections or %# extensions to
this work which alter its source code become the %# property of Best
Practical Solutions, LLC when submitted for %# inclusion in the work. %#
%# %# END LICENSE BLOCK <& /Elements/Header, Title=>loc(“RT at a
glance”), Refresh =>

I have tried commenting out the rt2 section in apache (saw the mod_perl
fastcgi notes), still no love.

[root@krypton rt-3-0-4]# ./sbin/rt-test-dependencies --with-mysql
–with-modperl1
I18N-COMPAT dependencies:
Text::Iconv …found
Encode::compat 0.04…found
MASON dependencies:
Params::Validate 0.02…found
Cache::Cache …found
Exception::Class …found
HTML::Mason 1.16…found
MLDBM …found
Errno …found
FreezeThaw …found
Digest::MD5 …found
CGI::Cookie 1.20…found
Storable …found
Apache::Session 1.53…found
MYSQL dependencies:
DBD::mysql 2.1018…found
MODPERL1 dependencies:
CGI …found
Apache::Request …found
Apache::DBI …found
MAILGATE dependencies:
HTML::TreeBuilder …found
HTML::FormatText …found
Getopt::Long …found
LWP::UserAgent …found
CLI dependencies:
Getopt::Long 2.24…found
DEV dependencies:
Regexp::Common …found
Time::HiRes …found
Test::Inline …found
WWW::Mechanize …found
CORE dependencies:
Digest::MD5 …found
DBI 1.18…found
Test::Inline …found
Class::ReturnValue 0.40…found
DBIx::SearchBuilder 0.86…found
Text::Template …found
File::Spec 0.8…found
HTML::Entities …found
Net::Domain …found
Log::Dispatch 2.0…found
Locale::Maketext 1.04…found
Locale::Maketext::Lexicon 0.25…found
Locale::Maketext::Fuzzy …found
MIME::Entity 5.108…found
Mail::Mailer 1.57…found
Net::SMTP …found
Text::Wrapper …found
Time::ParseDate …found
File::Temp …found
Term::ReadKey …found
Text::Autoformat …found
Text::Quoted …found

Did you upgrade perl or have you tried recompiling mod_perl statically
into
apache?

Charles Okochu
Snr. Network Engineer
MLBAM
Office: (212) 485-3473
Cell: (646) 996-3272 / (917) 518-5941-----Original Message-----
From: William Groh [mailto:william@miamiconsultant.com]
Sent: Thursday, July 31, 2003 4:38 PM
To: rt-users@lists.fsck.com
Subject: [rt-users] rt3 install problem (3.0.4)

Does anybody have any ideas on how to track this problem down?

I have an rt2 installation with 14k+ tickets, years of uptime.

Upgraded to 2.0.15, upgraded mason, ran the dependancy installer for
rt3. no errors, no problems.

configged rt3 with web user and group apache (redhat 7.2) installed, did
the database, etc. no problems.

added another alias (/rt3) configged as specified. Loaded the page, and
it looks like preprocessing isn’t happening.

This is what I get (part):

%# BEGIN LICENSE BLOCK %# %# Copyright © 1996-2003 Jesse Vincent %# %#
(Except where explictly superceded by other copyright notices) %# %#
This work is made available to you under the terms of Version 2 of %#
the GNU General Public License. A copy of that license should have %#
been provided with this software, but in any event can be snarfed %#
from www.gnu.org. %# %# This work is distributed in the hope that it
will be useful, but %# WITHOUT ANY WARRANTY; without even the implied
warranty of %# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See
the GNU %# General Public License for more details. %# %# Unless
otherwise specified, all modifications, corrections or %# extensions to
this work which alter its source code become the %# property of Best
Practical Solutions, LLC when submitted for %# inclusion in the work. %#
%# %# END LICENSE BLOCK <& /Elements/Header, Title=>loc(“RT at a
glance”), Refresh =>

I have tried commenting out the rt2 section in apache (saw the mod_perl
fastcgi notes), still no love.

[root@krypton rt-3-0-4]# ./sbin/rt-test-dependencies --with-mysql
–with-modperl1
I18N-COMPAT dependencies:
Text::Iconv …found
Encode::compat 0.04…found
MASON dependencies:
Params::Validate 0.02…found
Cache::Cache …found
Exception::Class …found
HTML::Mason 1.16…found
MLDBM …found
Errno …found
FreezeThaw …found
Digest::MD5 …found
CGI::Cookie 1.20…found
Storable …found
Apache::Session 1.53…found
MYSQL dependencies:
DBD::mysql 2.1018…found
MODPERL1 dependencies:
CGI …found
Apache::Request …found
Apache::DBI …found
MAILGATE dependencies:
HTML::TreeBuilder …found
HTML::FormatText …found
Getopt::Long …found
LWP::UserAgent …found
CLI dependencies:
Getopt::Long 2.24…found
DEV dependencies:
Regexp::Common …found
Time::HiRes …found
Test::Inline …found
WWW::Mechanize …found
CORE dependencies:
Digest::MD5 …found
DBI 1.18…found
Test::Inline …found
Class::ReturnValue 0.40…found
DBIx::SearchBuilder 0.86…found
Text::Template …found
File::Spec 0.8…found
HTML::Entities …found
Net::Domain …found
Log::Dispatch 2.0…found
Locale::Maketext 1.04…found
Locale::Maketext::Lexicon 0.25…found
Locale::Maketext::Fuzzy …found
MIME::Entity 5.108…found
Mail::Mailer 1.57…found
Net::SMTP …found
Text::Wrapper …found
Time::ParseDate …found
File::Temp …found
Term::ReadKey …found
Text::Autoformat …found
Text::Quoted …found

rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

[INFO] – Virus Manager:
No Viruses were detected in this message.

Want To Win World Series Tickets for Life?!
Do you have the winning hologram?
Watch the 2003 World Series on FOX.*

Major League Baseball Ultimate World Series Pass presented by
RadioShack.
For more information go to http://www.mlb.com/ultimatepass

*MLBI affiliate in Puerto Rico and Canada (check your local television
listing for games, dates and times)

Stock redhat 7.2, I think its all out of the box, I upgrade the cpan
module and install the RT specific modules from cpan.

I didn’t want to build another box, or another apache instance, I have
one apache with RT2, Cricket, Netsaint, NMIS, NorthStar, Rancid, and osu
flow-tools for Netflow reporting, LDAP and Kerberos SSO for
shell/mail/web, static content all nice and editable via mod_dav,
squirrelmail, phpgroupware, listening ssl only.

this is all bolted ontop of 7.2 with all updates, wont run on 7.1, 7.2
or 8.0 (moving to happy debian solution soon as LDAP SSL is default
enabled on woody)

I am not seeing any error messages in any logs, trying to track down the
culprit.

wg

Okochu, Charles wrote:

Did you upgrade perl or have you tried recompiling mod_perl statically
into
apache?

This looks like Mason is not working. Can You send a copy of Your
httpd.conf regarding the /rt3 entry?

As well, remember that You cannot have two different rt installations
in one particular instance of apache if You use mod_perl. At most one
rt instance can run under mod_perl, any other must use fstcgi or
speedycgi.

Regards,
Harald
The Statistics Package for RT 3 is available at
http://www.tzi.de/~hollow/Statistics3.tgz