Rt3, external auth, httpd.conf

What is the httpd.conf entry supposed to look like if one is using
external authentication?

The webu ui works fine with the entry below, but mailgate fails with a
"404 Authentication Error". If I remove the authentication lines,
mailgate works but then I’m not using external authentication…

How can I exempt the “NoAuth” documents from Apache authentication ???

DocumentRoot /usr/local/rt3/share/html
ErrorLog /usr/local/apache/logs/rterror_log
CustomLog /usr/local/apache/logs/rtaccess_log combined
AddDefaultCharset UTF-8
ServerName innuendo.ssww.com
PerlModule Apache::DBI
PerlRequire /usr/local/rt3/bin/webmux.pl

SetHandler perl-script
PerlHandler RT::Mason
AuthName "Login"
AuthType Basic
PerlSetVar BaseDN dc=ssww,dc=com
PerlSetVar LDAPServer ldap.ssww.com
PerlAuthenHandler Apache::AuthLDAP
require valid-user

Carrie Coy
S&S Worldwide
(860) 537-3451 x2357

Hi Carrie,

I came across the same problem, and this works for me (Apache 1.3),
“LocationMatch” does the trick.

<VirtualHost *>
AddDefaultCharset UTF-8

PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl

<Location />
    SetHandler perl-script
    PerlHandler RT::Mason
</Location>
<LocationMatch "/NoAuth">
    Satisfy Any
    Allow from all
</LocationMatch>
<Directory "/opt/rt3/share/html">
    AuthPAM_Enabled On
    AuthPAM_FallThrough On
    AuthType Basic
    AuthName "Log in using NT account"
    require valid-user
</Directory>

-----Original Message-----
From: CARRIE COY [mailto:ccoy@ssww.com]
Sent: woensdag 23 april 2003 19:06
To: rt-users
Subject: [rt-users] rt3, external auth, httpd.conf

What is the httpd.conf entry supposed to look like if one is using
external authentication?

The webu ui works fine with the entry below, but mailgate fails with a
"404 Authentication Error". If I remove the authentication lines,
mailgate works but then I’m not using external authentication…

How can I exempt the “NoAuth” documents from Apache authentication ???

DocumentRoot /usr/local/rt3/share/html
ErrorLog /usr/local/apache/logs/rterror_log
CustomLog /usr/local/apache/logs/rtaccess_log combined
AddDefaultCharset UTF-8
ServerName innuendo.ssww.com
PerlModule Apache::DBI
PerlRequire /usr/local/rt3/bin/webmux.pl

SetHandler perl-script
PerlHandler RT::Mason
AuthName "Login"
AuthType Basic
PerlSetVar BaseDN dc=ssww,dc=com
PerlSetVar LDAPServer ldap.ssww.com
PerlAuthenHandler Apache::AuthLDAP
require valid-user

Carrie Coy
S&S Worldwide
(860) 537-3451 x2357

rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

Another option:

Copy User_Local.pm to /opt/rt3/lib/RT/
Add the following lines to /opt/rt3/etc/RT_SiteConfig.pm
(This way you can logoff as well…)

$LDAPExternalAuth = 1;
$LdapServer=“chidir1.truenorth.com”;
$LdapUser="";
$LdapPass="";
$LdapBase=“o=True North”;
$LdapUidAttr=“uid”;
$LdapFilter="(objectclass=*)";

User_Local.pm (3.25 KB)