Rt3.8 package for debian

Hi,

I’m about to try out the new rt3.8 on debian etch and saw that
Emmanuel Lacour already built a package for it. Can I install rt3.8
directly by that package or is it only for the dependencies?On 1 Aug 2008, at 8:52 am, Emmanuel Lacour wrote:

As I already said here, I made needed packages for etch here:

http://rt.easter-eggs.org/debian/

this can help you :wink:

_

Br, Johan

Hi Johan,

The packages that Emmanuel Lacour have built only include the required
dependencies for Etch (they’re already present for Lenny).

I’ve built some RT 3.8.1rc5 packages which I’ve been using on Lenny.
I’ve back-ported them to Etch, but haven’t tested them on Etch. Feel
free to try using them (you’ll need Emmanuel’s repo as well for Etch).
Please let me know if there are any issues.

The lines for your apt sources.list file are:

deb http://debian.etc.gen.nz etch rt

or

deb http://debian.etc.gen.nz lenny rt

Cheers!On Thu, 2008-08-14 at 13:17 +0300, johan baarman wrote:

Hi,

I’m about to try out the new rt3.8 on debian etch and saw that
Emmanuel Lacour already built a package for it. Can I install rt3.8
directly by that package or is it only for the dependencies?

On 1 Aug 2008, at 8:52 am, Emmanuel Lacour wrote:

As I already said here, I made needed packages for etch here:

http://rt.easter-eggs.org/debian/

this can help you :wink:

_

Br, Johan


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Andrew Ruthven
Wellington, New Zealand
At home: andrew@etc.gen.nz | This space intentionally
| left blank.

signature.asc (189 Bytes)

Hi Andrew,

Yes, I found your instructions later while browsing the email-archive.
Since this is a fresh install I went ahead and upgraded to lenny at
the same time. It worked like a charm except when initializing the
database. It was complaining that “Can’t locate Email/Address.pm in
@INC…” I figured it was missing package libemail-address-perl and
after starting RT there were also an error about missing Graphviz so I
also had to install package libgraphviz-perl. It’s running fine now,
thanks to your package.

Br, JohanOn Sat, Aug 16, 2008 at 2:32 AM, Andrew Ruthven andrew@etc.gen.nz wrote:

Hi Johan,

The packages that Emmanuel Lacour have built only include the required
dependencies for Etch (they’re already present for Lenny).

I’ve built some RT 3.8.1rc5 packages which I’ve been using on Lenny.
I’ve back-ported them to Etch, but haven’t tested them on Etch. Feel
free to try using them (you’ll need Emmanuel’s repo as well for Etch).
Please let me know if there are any issues.

The lines for your apt sources.list file are:

deb http://debian.etc.gen.nz etch rt

or

deb http://debian.etc.gen.nz lenny rt

Cheers!

On Thu, 2008-08-14 at 13:17 +0300, johan baarman wrote:

Hi,

I’m about to try out the new rt3.8 on debian etch and saw that
Emmanuel Lacour already built a package for it. Can I install rt3.8
directly by that package or is it only for the dependencies?

On 1 Aug 2008, at 8:52 am, Emmanuel Lacour wrote:

As I already said here, I made needed packages for etch here:

http://rt.easter-eggs.org/debian/

this can help you :wink:

_

Br, Johan


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


Andrew Ruthven
Wellington, New Zealand
At home: andrew@etc.gen.nz | This space intentionally
| left blank.

Andrew Ruthven andrew@etc.gen.nz writes:

I’ve built some RT 3.8.1rc5 packages which I’ve been using on Lenny.
deb http://debian.etc.gen.nz lenny rt

There is a missing Recommends for libgraphviz-perl.

Also, I’d appreciate copies of the .dsc and .diff.gz.

Hi Johan,

Could you please let me know what request of my request-tracker3.8
package you’ve installed? libemail-address-perl is on the dependency
list at the moment, but there was a missing comma that might have caused
issues.

I’ve added libgraphviz-perl, thanks!

Cheers!On Mon, 2008-08-18 at 10:03 +0300, johan baarman wrote:

Hi Andrew,

Yes, I found your instructions later while browsing the email-archive.
Since this is a fresh install I went ahead and upgraded to lenny at
the same time. It worked like a charm except when initializing the
database. It was complaining that “Can’t locate Email/Address.pm in
@INC…” I figured it was missing package libemail-address-perl and
after starting RT there were also an error about missing Graphviz so I
also had to install package libgraphviz-perl. It’s running fine now,
thanks to your package.

Br, Johan

Andrew Ruthven
Wellington, New Zealand
At home: andrew@etc.gen.nz | This space intentionally
| left blank.

signature.asc (189 Bytes)

Andrew Ruthven andrew@etc.gen.nz writes:

I’ve built some RT 3.8.1rc5 packages which I’ve been using on Lenny.
deb http://debian.etc.gen.nz lenny rt

There is a missing Recommends for libgraphviz-perl.

Rats, so it is. I add the build-deps line, but not the dependency.
Fixed.

And I’ve updated the Lenny version to 3.8.1.

Also, I’d appreciate copies of the .dsc and .diff.gz.

Sure. My repository management software doesn’t handle source at the
moment. I’ll email them privately.

I’m storing my build tree in a git repo at:
http://git.catalyst.net.nz/gw?p=request-tracker.git;a=summary
You can check it out using:
git clone git://git.catalyst.net.nz/request-tracker.git

Cheers!

Andrew Ruthven
Wellington, New Zealand
At home: andrew@etc.gen.nz | This space intentionally
| left blank.

signature.asc (189 Bytes)