RT3.5.7 upgrade - no css picked up

Just upgraded RT from 3.2.3 to 3.5.7 on a RHEL V3 test server running
Apache 1.33, mod_perl.

After make upgrade, applying db changes, I deleted the mason_data and
stopped and started Apache.

Now when I navigate to RT, none of the stylesheet elements are picked up.
Everything that’s supposed to be displayed is displayed (queues, tix,
config options, etc) but I don’t have any real formating, no colors,
titlebars or anything. I’ve tried both stylesheets in RT_Siteconfig.pm and
no luck. Sorry, I can’t post a screenshot.

I have no errors in my rt.log or apache logs.

Any ideas?

BTW I believe this should be mentioned in the upgrade doc - even though
there are no schema, acl, or insert changes in rt-3.5.7/etc/upgrade/3.5.1/

Joe Micciche

Are you sure you have your WebBaseURL correct? Sounds like the browser
couldn’t request the stylesheet (which wouldn’t show up in the logs
since the request isn’t getting there).


Hi Rolf, thanks for the note. The web config in RT_SiteConfig.pm was fine.
This problem was entirely my error - I had a customized
/path-to-rt/rt/local/html/Elements/Header which took precedence over the
/path-to-rt/rt/share/html/Elements/Header. I moved my customized Header,
deleted mason cache, stopped & started Apache, and everything works fine.

I suppose after I run into this same problem a few more times, I’ll catch
on. :wink:



I am having the same issue. I first found this after an upgrade from 3.4.2 to 3.5.7.

Did a fresh install of 3.5.7 and have the same trouble.

I checked /path-to-rt/rt/local/html/Elements/Header, the dir is empty.

Nothing in the logs.

Any suggestions?


Steve Hache