RT2 on RedHat 8.0


This might have been discussed earlier, but I could not find it in the
I have tried to run RT 2.0.15 on RedHat 8.0. And I’m having difficulties
installing the perlmodule libapreq ( apache::cookie). Since RH 8.0 comes
with apache 2 this module won’t compile.
I’m using libapreq-1.0.
Is there someway around this module or is there a newer version of the
module available?

Remco van den Bosch

Thanks for the user guide.

I however do not have problems installing RT. I have a working RT on
Redhat 7.3 so installing RT is not the problem. Since we are using Rh 8.0
for all our servers, I’d like to install RT on RH 8.0.
The only problem I encountered while installing RT on RH 8.0 is that
libapreq (apache::request) does not compile. I tried using CPAN ( exactly
as is printed in the userguide). And I also tried installing it by hand.
These attempt where futile because this library is not compatible with
apache2 with comes with RH 8.0.
I tried the homepage of libapreq (http://www.apache.org/~joes/)
and some development patch seems to be available for apache2. This patch
however does not apply to any known source.

So my question is : is it possible to run RT without libapreq. Or might
there be some other workaround?

Thanks for your time,
Remco van den Bosch