RT won't start after crash

Error in syslog when trying to start : “Can’t locate HTML/Mason/Request/CGI.pm”

Installed on Debian jessie

I’ve tried multiple times to :

  • start the service using /etc/init.d/rt4
  • upgrade cpan modules, trying to restore a missing module, using “upgrade” in cpan shell
  • upgrade debian packages

Still no success.

What can cause the crash that gives no output in the log ?
What can I do to restore a working setup ?

On Debian Stretch it could be related to removal of ‘.’ from @INC [1], but check the version of Perl you run RT on. The ‘.’ removal is effective since Perl 5.26.

[1] https://lists.debian.org/debian-devel-announce/2016/08/msg00013.html

To ‘restore a working setup’ try restoring from latest backup.

Peter

It was related to Mason cache. Remove the Mason obj content of the folder was not enough because of an hidden file. Removing of the files including the folder helps. Adaptation of the recipe given under https://rt-wiki.bestpractical.com/wiki/CleanMasonCache is given below :

rm -Rf /opt/rt4/var/mason_data/obj

After emptying the folder and its content, I restarted the service and it recreated the folder and now runs again.

The installed version of perl is v5.20.2.