RT wont run after up2date in RHEL 4.0

Hi

  We have been running RT for about 1 month on RHEL 4.0

up2date was run last week, and now I get the following error in the
http logs:

RT requires the Scalar::Util module be built with support for the
’weaken’

function.

It is sometimes the case that operating system upgrades will replace

a working Scalar::Util with a non-working one. If your system was
working

correctly up until now, this is likely the cause of the problem.

Please reinstall Scalar::Util, being careful to let it build with your C

compiler. Ususally this is as simple as running the following command as

root.

perl -MCPAN -e'install Scalar::Util'</i>

If I run cpan install Scalar::Util, it says it is up to date.

How can I correct this problem to get RT up?

Thank you

-- 
Jim Glutting
I.T. Consultant
Continental Services, Inc.
248-310-7400
www.ContinentalServ.com

Jim GLutting wrote:

Hi
We have been running RT for about 1 month on RHEL 4.0
up2date was run last week, and now I get the following error in the http logs:

/RT requires the Scalar::Util module be built with support for the ‘weaken’
function.
It is sometimes the case that operating system upgrades will replace
a working Scalar::Util with a non-working one. If your system was working
correctly up until now, this is likely the cause of the problem.
Please reinstall Scalar::Util, being careful to let it build with your C
compiler. Ususally this is as simple as running the following command as
root.

perl -MCPAN -e'install Scalar::Util'/

If I run cpan install Scalar::Util, it says it is up to date.

How can I correct this problem to get RT up?

You’ll need to manually install Scalar::Util by downloading it from
search.cpan.org. RedHat installed a version that’s labeled as current,
but is broken (built without a C compiler).