RT-Users Digest, Vol 53, Issue 105

I have tried most thing to get 3.8.1 running without success so I have
done the following

  1. installed fedora 9 as a clean install
  2. yum update
  3. yum install rt3

got it to work as I need it to http://localhost/rt3
(http://localhost gives the apache welcome page) but get version rt-3.6.6

This has been explained to you already, you can’t use localhost to
anyone else than you. I.e., localhost will be different for different
machines. You have to use your machines ip-address. The sooner you get
rid of localhost the sooner you are little bit closer to a working system.

it installed it in /usr/share/rt3/html

That is the default yes. Except the directory is just /usr/share/rt3/ in
my opinion

next I downloaded rt-3.8.1.tar.gz

Why, when you installed RT already through packet management system?


  1. ./configure --prefix=/usr/share/rt3/html

what is “html” doing at the end of the path? Was it really installed in
that directory by yum?

  1. make fixdeps
  2. make upgrade
  3. upgraded the database

the problem is if i now run http://localhost/rt3 i still get version 3.6.6

Yes because you installed the new version to /usr/share/rt3/html

if I now change in/etc/httpd/conf.d/rt3.conf


PerlRequire /user/sbin/webmux.pl


PerlRequire /usr/share/rt3/http/bin/webmux.pl i get 404 not found

Do you have webmux in that directory you specified. The path with my
install is /opt/rt/sbin/webmux.pl

What do i need to do to get rt-3.8.1 running as http://localhost/rt3 and
NOT as http://localhost

Why you have to have localhost as the address? You need to understand
apaches configuration files to be able to configure the address to your

What I would do is to make a clean install if you don’t have tickets or
anything yet. And follow the instruction closely. I had some problems
too with upgrade but they were because I had an older RT instance
configured on the same server, so it’s better you remove all traces of
RT from httpd.conf I think.