RT Statistics package on Solaris (GD problems)

Hi Folks!

Has anyone had success in getting Apache::GD::Graph working on Solaris? I
don’t see much on the web about it (google search), but a couple of people
had said they had just done a force install, and it worked for them. I did
that, but still no luck on getting the stats package to work for RT. I
don’t get errors… I just get a broken link image. The stats show up in
the tables… I think those numbers are fine, but they don’t change
colours…

Here’s the output from force install Apache::GD::Graph (now that it’s
already installed… there were some dependencies - all GD ones - that had
issues too, but I can’t get the output from those.

Any GD for Solaris tips & tricks out there?

Thanks!

Output from CPAN Shell:

PERL_DL_NONLAZY=1
/usr/bin/perl -Iblib/arch -Iblib/lib -I/usr/local/lib/perl5/5.6.1/sun4-solar
is -I/usr/local/lib/perl5/5.6.1 -e ‘use Test::Harness qw(&runtests
$verbose); $verbose=0; runtests @ARGV;’ t/*.t
t/simple_request…Can’t load
’/usr/local/lib/perl5/site_perl/5.6.1/sun4-solaris/auto/GD/GD.so’ for module
GD: ld.so.1: /usr/bin/perl: fatal: relocation error: file
/usr/local/lib/perl5/site_perl/5.6.1/sun4-solaris/auto/GD/GD.so: symbol
gdImageStringFT: referenced symbol not found at
/usr/local/lib/perl5/5.6.1/sun4-solaris/DynaLoader.pm line 206.
at blib/lib/Apache/GD/Graph.pm line 364
Compilation failed in require at blib/lib/Apache/GD/Graph.pm line 364.
BEGIN failed–compilation aborted at blib/lib/Apache/GD/Graph.pm line 364.
Compilation failed in require at t/simple_request.t line 6.
BEGIN failed–compilation aborted at t/simple_request.t line 6.
t/simple_request…dubious
Test returned status 255 (wstat 65280, 0xff00)
FAILED–1 test script could be run, alas–no output ever seen
make: *** [test_dynamic] Error 2
/usr/local/bin/make test – NOT OK

Michael K. Brown
Lab Technician
ATM Engineering Services - Lab Services
Tel: (613) 784-4354
michael.k.brown@alcatel.com

Have you installed gd itself and the supporting libpng, xpm, and/or
freetype packages?

Regards,
Christian