RT_SiteConfig help

Hi!
I’m pretty new to RT and i had to install it here at work.
We will use it to manage the computer support request sent by our clients.
I finished installing it, following the tutorial below:
http://simonsmicrophone.com/2011/10/19/rt-4-debian-6-installation/

I’m using Debian Wheezy and RT 4.0.13, with apache2 and mysql.

By now, I still didn’t set it up, and I’m accessing RT at a Glance by
’localhost:8080’ (I’m using the port 8080 here.)

But, when I get to the RT at a Glance page, after login with root:password,
I just can’t access any of the menus avaiable, when I try to enter them, I’m
taken to a page with this error msg: An internal RT error has occurred. Your
administrator can find more details in RT’s log files.

My RT_SiteConfig has the following configurations:

Set($rtname, ‘rtlti.com’);
Set($Organization, ‘rtlti.com’);
Set($CorrespondAddress, ‘contato@rtlti.com’);
Set($CommentAddress, ‘contato@rtlti.com’);
Set($DatabaseUser, ‘root’);
Set($DatabaseName, ‘rtlti’);

Set($Timezone, “America/Sao_Paulo”);

Set($DatabaseType, “mysql”);
Set($DatabasePassword, ‘—’);
Set($DatabaseHost , ‘localhost’);
Set($DatabaseRTHost , ‘localhost’);

Set($WebBaseURL , “http://help.rtlti.com”);

I wonder if you guys could give me some tips and good configuration to my RT
files so I can start using it

View this message in context: http://requesttracker.8502.n7.nabble.com/RT-SiteConfig-help-tp54285.html

Set($WebBaseURL , “http://help.rtlti.com”);

Where did you take an idea that you should set above instead of “Base
configuration” [1]?

[1]
http://bestpractical.com/rt/docs/latest/RT_Config.html#Base-configuration

Quote from the documentation for the option you set [2]: “Usually you don’t
want to set these ($WebBaseURL, $WebURL) options.”

[2] RT Config - RT 5.0.3 Documentation - Best Practical

Best regards, Ruslan.

But wich configuration can I use to at least start using RT at a Glance page
whitout receiving “An internal RT error has occurred. Your administrator can
find more details in RT’s log files.” error?
I actually need a guide to configure RT and apache2 files after the
instalation to use it in the most simple way.

View this message in context: http://requesttracker.8502.n7.nabble.com/RT-SiteConfig-help-tp54285p54287.html

Hello

I installed the RT in the server with port is 8081 … for work only need
change into the file

/etc/request-tracker4/RT_SiteConfig.pm

# THE WEBSERVER:

Set($WebPath , “/rt”);
Set($WebBaseURL , “http://www.xxxxxxxx.com:8081”);

/etc/init.d/apache2 restart

good luck

View this message in context: http://requesttracker.8502.n7.nabble.com/RT-SiteConfig-help-tp54285p54288.html

 Set($WebBaseURL , "[2]http://help.rtlti.com");

Where did you take an idea that you should set above instead of “Base configuration” [1]?Â

RT Config - RT 5.0.3 Documentation - Best Practical

As Rus notes - you want to read the official RT docs, including the
config docs he links to and
http://bestpractical.com/rt/docs/latest/web_deployment.html
and
http://bestpractical.com/rt/docs/latest/README.htmlOn Thu, Jun 13, 2013 at 07:02:44AM -0700, Heracross77 wrote:

But wich configuration can I use to at least start using RT at a Glance page
whitout receiving “An internal RT error has occurred. Your administrator can
find more details in RT’s log files.” error?

You need to send the errors, from the logs, for us to be able to see
what’s going on. Without the errors, all we can do is point out
problems in your configuration.

-kevin