RT::ServiceBusinessHours failure

I’ve recently got the RT::Extension::SLA extension working and added the following config into the RT config for Service business hours:

%RT::ServiceBusinessHours = (
‘TechSupport’ => {

                    0 => { Name             => 'Sunday',
                            Start   => 'undef',
                            End     => 'undef'},

                    1 => { Name             => 'Monday',
                            Start   => '08:00',
                            End     => '18:00'},

                    2 => { Name             => 'Tuesday',
                            Start   => '08:00',
                            End     => '18:00'},

                    3 => { Name             => 'Wednesday',
                            Start   => '08:00',
                            End     => '18:00'},

                    4 => { Name             => 'Thursday',
                            Start   => '08:00',
                            End     => '18:00'},

                    5 => { Name             => 'Friday',
                            Start   => '08:00',
                            End     => '18:00'},

                    6 => { Name     => 'Saturday',
                            Start   => 'undef',
                            End     => 'undef'},

                    holidays => [qw(01-01 12-24 12-25 7-4 2012-04-08 2012-05-28 2012-09-03 2012-11-22)],
                            }

);

%RT::ServiceAgreements = (
‘Default’ => ‘8’,
Levels => {
‘24’ => {
BusinessHours => ‘TechSupport’,
Response => { RealMinutes => 6024},
KeepInLoop => { RealMinutes => 60
24},
},
‘8’ => {
BusinessHours => ‘TechSupport’,
Response => { BusinessMinutes => 608},
KeepInLoop => {BusinessMinutes => 60
8},
},
‘4’ => {
BusinessHours => ‘TechSupport’,
Response => { BusinessMinutes => 604},
KeepInLoop => { BusinessMinutes => 60
4},
},
‘1’ => {
BusinessHours => ‘TechSupport’,
Response => { BusinessMinutes => 601},
KeepInLoop => {BusinessMinutes => 60
1},
},
‘Critical’ => {
BusinessHours => ‘TechSupport’,
Response => { BusinessMinutes => 600.8 },
KeepInLoop => { BusinessMinutes => 60
0.8 },
},
},
);

But when I change the SLA and RT attempts to set Start and Due Dates based off SLA I get the following error and stack trace in the RT log:

[Fri Jan 13 23:08:53 2012] [debug]: Committing scrip #16 on txn #8150 of ticket #747 (/opt/rt4/sbin/…/lib/RT/Scrips.pm:192)
[Fri Jan 13 23:08:53 2012] [debug]: Last effective requestors’ reply to ticket #747 is txn #8139 (/opt/rt4/local/plugins/RT-Extension-SLA/lib/RT/Action/SLA_SetDue.pm:41)
[Fri Jan 13 23:08:53 2012] [error]: Scrip Commit 16 died. - Set::IntSpan::_copy_run_list: Bad order: 1326006000-1326005999,1326121200-1326157199,1326207600-1326243599,1326294000-1326329999,1326380400-1326416399,1326466800-1326502799,1326524400-1326524399
at /usr/lib/perl5/site_perl/5.8.8/Business/Hours.pm line 372

Stack:
[/usr/lib/perl5/5.8.8/Carp.pm:269]
[/usr/lib/perl5/site_perl/5.8.8/Set/IntSpan.pm:299]
[/usr/lib/perl5/site_perl/5.8.8/Set/IntSpan.pm:140]
[/usr/lib/perl5/site_perl/5.8.8/Set/IntSpan.pm:111]
[/usr/lib/perl5/site_perl/5.8.8/Business/Hours.pm:372]
[/usr/lib/perl5/site_perl/5.8.8/Business/Hours.pm:514]
[/opt/rt4/local/plugins/RT-Extension-SLA/lib/RT/Extension/SLA.pm:370]
[/opt/rt4/local/plugins/RT-Extension-SLA/lib/RT/Action/SLA_SetDue.pm:46]
[/opt/rt4/sbin/…/lib/RT/ScripAction.pm:232]
[/opt/rt4/sbin/…/lib/RT/Scrip.pm:475]
[/opt/rt4/sbin/…/lib/RT/Scrips.pm:198]
[/opt/rt4/sbin/…/lib/RT/Transaction.pm:201]
[/opt/rt4/sbin/…/lib/RT/Record.pm:1447]
[/opt/rt4/sbin/…/lib/RT/Record.pm:1691]
[/opt/rt4/sbin/…/lib/RT/Record.pm:1570]
[/opt/rt4/sbin/…/lib/RT/Interface/Web.pm:2242]
[/opt/rt4/sbin/…/lib/RT/Interface/Web.pm:2175]
[/opt/rt4/share/html/Ticket/Modify.html:82]
[/opt/rt4/sbin/…/lib/RT/Interface/Web.pm:538]
[/opt/rt4/sbin/…/lib/RT/Interface/Web.pm:285]
[/opt/rt4/share/html/autohandler:53] (/opt/rt4/sbin/…/lib/RT/Scrip.pm:483)

Any ideas what I did wrong?

Thanks!

David Hollinger III
IT Infrastructure Coordinator
Handwriting Without Tears
(301)263-2700 ext 285
(402)430-3127