RT Sending Email too SLOW

Hi

We really need some help resolving the slow email issue.
I have been researching this for over 2 weeks now before calling our to
RT_Users.
I have searched all of the below,

http://wiki.bestpractical.com/
http://gossamer-threads.com/lists/rt/
http://www.google.com/

and much wider across the Internet. Almost given up!!

++Description:
Overall there are no issues with email leaving RT - email reaches all
destinations
There are no issues raising tickets into the queue via email.
Overall speed of moving around RT Web front end is fast / acceptable

++Issue:
replying to a ticket takes up to 30 seconds to complete and sending the
email in some cases up to 1 min.
this is simply prohibitive to use in a professional setup.

++Other Issues:
Squirrel Mail (Linux Web Mail) has the same issue, up to 30 seconds to send
an email - no solution
SSH to shell remotely same problem 30s - Now resolved by removing the DNS
lookup: /etc/ssh/sshd_config [UseDNS no]
SFTP - Slow 30 sec - fixed by line above
Sendmail takes 30 sec to send an email from command line test an issue we
have had with php apps for over a year - now resolved by :
Edit the sendmail.cfg

Was:

pass to name server to make hostname canonical

R$* $| $* < @ $* > $* $: $2 < @ $[ $3 $] > $4

Now:

pass to name server to make hostname canonical

#R$* $| $* < @ $* > $* $: $2 < @ $[ $3 $] > $4

OR
sendmail.mc
Add:
FEATURE(`nocanonify’)dnl

then rebuiuld sendmail using m4

Sendmail now blistering fast.

++RT mail Configuration:
Previously I was using sendmailpipe
$MailCommand = ‘sendmailpipe’;
$SendmailArguments = “-oi -t”;
$SendmailPath = “/usr/sbin/sendmail”;

Now that I have confirmed that Sendmail is NOT the issue I am now using:
$MailCommand = ‘sendmailpipe’;
#$SendmailArguments = “-oi -t”;
$SendmailArguments = “-oi -ODeliveryMode=b -OErrorMode=m”;
$SendmailPath = “/usr/sbin/sendmail”;

Also have soft link:
/etc/smrsh/rt-mailgate -> /opt/rt3/bin/rt-mailgate

Note sure what else to test.

The common denominator here is Apache Http
So here is the conf entry for RT:

[root@caitanya conf]# diff httpd.conf httpd.conf.working.20101126
997,1015d996
< Alias /rt “/opt/rt3/share/html”
< PerlModule Apache::DBI
< PerlRequire /opt/rt3/bin/webmux.pl
< <Directory /opt/rt3/share/html>
< AllowOverride All
< Options ExecCGI FollowSymLinks
<
< Order allow,deny
< Allow from all
<
<
<
< <Location /rt>
< RewriteEngine On
< RedirectMatch permanent (.*)/$ $1/index.html
< AddDefaultCharset UTF-8
< SetHandler perl-script
< PerlHandler RT::Mason
<

Appreciate any help that one can give.
Its the only issue stopping us from moving RT from test environment to
production.

Naresh Maharaj,

Hewitt & May (Shirtmakers) Ltd
email: info@hewittandmay.com
web: http://www.hewittandmay.co.uk

It sounds like all of your problems are DNS related. Instead
of disabling the lookups everywhere because they are busted,
if you fixed them it would all just work. Barring that, you
will need to disable the DNS lookup that is causing the slow
mail problem. Good luck.

Cheers,
KenOn Thu, Dec 09, 2010 at 09:48:56PM +0000, Naresh Maharaj wrote:

Hi

We really need some help resolving the slow email issue.
I have been researching this for over 2 weeks now before calling our to
RT_Users.
I have searched all of the below,

http://wiki.bestpractical.com/
http://gossamer-threads.com/lists/rt/
http://www.google.com/

and much wider across the Internet. Almost given up!!

++Description:
Overall there are no issues with email leaving RT - email reaches all
destinations
There are no issues raising tickets into the queue via email.
Overall speed of moving around RT Web front end is fast / acceptable

++Issue:
replying to a ticket takes up to 30 seconds to complete and sending the
email in some cases up to 1 min.
this is simply prohibitive to use in a professional setup.

++Other Issues:
Squirrel Mail (Linux Web Mail) has the same issue, up to 30 seconds to send
an email - no solution
SSH to shell remotely same problem 30s - Now resolved by removing the DNS
lookup: /etc/ssh/sshd_config [UseDNS no]
SFTP - Slow 30 sec - fixed by line above
Sendmail takes 30 sec to send an email from command line test an issue we
have had with php apps for over a year - now resolved by :
Edit the sendmail.cfg

Was:

pass to name server to make hostname canonical

R$* $| $* < @ $* > $* $: $2 < @ $[ $3 $] > $4

Now:

pass to name server to make hostname canonical

#R$* $| $* < @ $* > $* $: $2 < @ $[ $3 $] > $4

OR
sendmail.mc
Add:
FEATURE(`nocanonify’)dnl

then rebuiuld sendmail using m4

Sendmail now blistering fast.

++RT mail Configuration:
Previously I was using sendmailpipe
$MailCommand = ‘sendmailpipe’;
$SendmailArguments = “-oi -t”;
$SendmailPath = “/usr/sbin/sendmail”;

Now that I have confirmed that Sendmail is NOT the issue I am now using:
$MailCommand = ‘sendmailpipe’;
#$SendmailArguments = “-oi -t”;
$SendmailArguments = “-oi -ODeliveryMode=b -OErrorMode=m”;
$SendmailPath = “/usr/sbin/sendmail”;

Also have soft link:
/etc/smrsh/rt-mailgate -> /opt/rt3/bin/rt-mailgate

Note sure what else to test.

The common denominator here is Apache Http
So here is the conf entry for RT:

[root@caitanya conf]# diff httpd.conf httpd.conf.working.20101126
997,1015d996
< Alias /rt “/opt/rt3/share/html”
< PerlModule Apache::DBI
< PerlRequire /opt/rt3/bin/webmux.pl
< <Directory /opt/rt3/share/html>
< AllowOverride All
< Options ExecCGI FollowSymLinks
<
< Order allow,deny
< Allow from all
<
<
<
< <Location /rt>
< RewriteEngine On
< RedirectMatch permanent (.*)/$ $1/index.html
< AddDefaultCharset UTF-8
< SetHandler perl-script
< PerlHandler RT::Mason
<

Appreciate any help that one can give.
Its the only issue stopping us from moving RT from test environment to
production.

Naresh Maharaj,

Hewitt & May (Shirtmakers) Ltd
email: info@hewittandmay.com
web: http://www.hewittandmay.co.uk

Hi,

The following may help you http://requesttracker.wikia.com/wiki/SendmailTipsOn Fri, Dec 10, 2010 at 12:48 AM, Naresh Maharaj naresh@hewittandmay.com wrote:

Hi

We really need some help resolving the slow email issue.
I have been researching this for over 2 weeks now before calling our to
RT_Users.
I have searched all of the below,

http://wiki.bestpractical.com/
http://gossamer-threads.com/lists/rt/
http://www.google.com/

and much wider across the Internet. Almost given up!!

++Description:
Overall there are no issues with email leaving RT - email reaches all
destinations
There are no issues raising tickets into the queue via email.
Overall speed of moving around RT Web front end is fast / acceptable

++Issue:
replying to a ticket takes up to 30 seconds to complete and sending the
email in some cases up to 1 min.
this is simply prohibitive to use in a professional setup.

++Other Issues:
Squirrel Mail (Linux Web Mail) has the same issue, up to 30 seconds to send
an email - no solution
SSH to shell remotely same problem 30s - Now resolved by removing the DNS
lookup: /etc/ssh/sshd_config [UseDNS no]
SFTP - Slow 30 sec - fixed by line above
Sendmail takes 30 sec to send an email from command line test an issue we
have had with php apps for over a year - now resolved by :
Edit the sendmail.cfg

Was:

pass to name server to make hostname canonical

R$* $| $* < @ $* > $* $: $2 < @ $[ $3 $] > $4

Now:

pass to name server to make hostname canonical

#R$* $| $* < @ $* > $* $: $2 < @ $[ $3 $] > $4

OR
sendmail.mc
Add:
FEATURE(`nocanonify’)dnl

then rebuiuld sendmail using m4

Sendmail now blistering fast.

++RT mail Configuration:
Previously I was using sendmailpipe
$MailCommand = ‘sendmailpipe’;
$SendmailArguments = “-oi -t”;
$SendmailPath = “/usr/sbin/sendmail”;

Now that I have confirmed that Sendmail is NOT the issue I am now using:
$MailCommand = ‘sendmailpipe’;
#$SendmailArguments = “-oi -t”;
$SendmailArguments = “-oi -ODeliveryMode=b -OErrorMode=m”;
$SendmailPath = “/usr/sbin/sendmail”;

Also have soft link:
/etc/smrsh/rt-mailgate -> /opt/rt3/bin/rt-mailgate

Note sure what else to test.

The common denominator here is Apache Http
So here is the conf entry for RT:

[root@caitanya conf]# diff httpd.conf httpd.conf.working.20101126
997,1015d996
< Alias /rt “/opt/rt3/share/html”
< PerlModule Apache::DBI
< PerlRequire /opt/rt3/bin/webmux.pl
< <Directory /opt/rt3/share/html>
< AllowOverride All
< Options ExecCGI FollowSymLinks
<
< Order allow,deny
< Allow from all
<
<
<
< <Location /rt>
< RewriteEngine On
< RedirectMatch permanent (.*)/$ $1/index.html
< AddDefaultCharset UTF-8
< SetHandler perl-script
< PerlHandler RT::Mason
<

Appreciate any help that one can give.
Its the only issue stopping us from moving RT from test environment to
production.

Naresh Maharaj,

Hewitt & May (Shirtmakers) Ltd
email: info@hewittandmay.com
web: http://www.hewittandmay.co.uk

Best regards, Ruslan.

Dear Ruslan

Thank you - have done all of this already.

Just checked the DNS Servers we use and it seems our ISP had not informed us
of a change to the DNS address.

Made a change to /etc/resolve.conf

added the new DNS server address and hey presto !!!

Super fast

Kind regards

Naresh Maharaj,

Hewitt & May (Shirtmakers) Ltd
email: info@hewittandmay.com
web: http://www.hewittandmay.co.ukOn 9 December 2010 23:39, Ruslan Zakirov ruz@bestpractical.com wrote:

Hi,

The following may help you
http://requesttracker.wikia.com/wiki/SendmailTips

On Fri, Dec 10, 2010 at 12:48 AM, Naresh Maharaj naresh@hewittandmay.com wrote:

Hi

We really need some help resolving the slow email issue.
I have been researching this for over 2 weeks now before calling our to
RT_Users.
I have searched all of the below,

http://wiki.bestpractical.com/
http://gossamer-threads.com/lists/rt/
http://www.google.com/

and much wider across the Internet. Almost given up!!

++Description:
Overall there are no issues with email leaving RT - email reaches all
destinations
There are no issues raising tickets into the queue via email.
Overall speed of moving around RT Web front end is fast / acceptable

++Issue:
replying to a ticket takes up to 30 seconds to complete and sending the
email in some cases up to 1 min.
this is simply prohibitive to use in a professional setup.

++Other Issues:
Squirrel Mail (Linux Web Mail) has the same issue, up to 30 seconds to
send
an email - no solution
SSH to shell remotely same problem 30s - Now resolved by removing the DNS
lookup: /etc/ssh/sshd_config [UseDNS no]
SFTP - Slow 30 sec - fixed by line above
Sendmail takes 30 sec to send an email from command line test an issue we
have had with php apps for over a year - now resolved by :
Edit the sendmail.cfg

Was:

pass to name server to make hostname canonical

R$* $| $* < @ $* > $* $: $2 < @ $[ $3 $] > $4

Now:

pass to name server to make hostname canonical

#R$* $| $* < @ $* > $* $: $2 < @ $[ $3 $] > $4

OR
sendmail.mc
Add:
FEATURE(`nocanonify’)dnl

then rebuiuld sendmail using m4

Sendmail now blistering fast.

++RT mail Configuration:
Previously I was using sendmailpipe
$MailCommand = ‘sendmailpipe’;
$SendmailArguments = “-oi -t”;
$SendmailPath = “/usr/sbin/sendmail”;

Now that I have confirmed that Sendmail is NOT the issue I am now using:
$MailCommand = ‘sendmailpipe’;
#$SendmailArguments = “-oi -t”;
$SendmailArguments = “-oi -ODeliveryMode=b -OErrorMode=m”;
$SendmailPath = “/usr/sbin/sendmail”;

Also have soft link:
/etc/smrsh/rt-mailgate -> /opt/rt3/bin/rt-mailgate

Note sure what else to test.

The common denominator here is Apache Http
So here is the conf entry for RT:

[root@caitanya conf]# diff httpd.conf httpd.conf.working.20101126
997,1015d996
< Alias /rt “/opt/rt3/share/html”
< PerlModule Apache::DBI
< PerlRequire /opt/rt3/bin/webmux.pl
< <Directory /opt/rt3/share/html>
< AllowOverride All
< Options ExecCGI FollowSymLinks
<
< Order allow,deny
< Allow from all
<
<
<
< <Location /rt>
< RewriteEngine On
< RedirectMatch permanent (.*)/$ $1/index.html
< AddDefaultCharset UTF-8
< SetHandler perl-script
< PerlHandler RT::Mason
<

Appreciate any help that one can give.
Its the only issue stopping us from moving RT from test environment to
production.

Naresh Maharaj,

Hewitt & May (Shirtmakers) Ltd
email: info@hewittandmay.com
web: http://www.hewittandmay.co.uk


Best regards, Ruslan.

Kenneth

Thanks. Fixing DNS fixed e’thing

Kind regards

Naresh Maharaj
Hewitt & May (Shirtmakers) Ltd.
email: naresh@hewittandmay.comFrom: Kenneth Marshall ktm@rice.edu
Date: Thu, 9 Dec 2010 16:03:25
To: Naresh Maharajnaresh@hewittandmay.com
Cc: rt-users@lists.bestpractical.com; Managementmanagement@hewittandmay.com
Subject: Re: [rt-users] RT Sending Email too SLOW

It sounds like all of your problems are DNS related. Instead
of disabling the lookups everywhere because they are busted,
if you fixed them it would all just work. Barring that, you
will need to disable the DNS lookup that is causing the slow
mail problem. Good luck.

Cheers,
Ken

Hi Naresh,

One thing that may be worth doing is to run a local caching
DNS server. This can help prevent transient DNS problems with
your ISP from tanking your RT performance. The best one that
I know of and that we use on our RT system is called
pdns-recursor-3.3. You can get it from www.powerdns.com as
a free download. I am glad that you got it all working again.

Cheers,
KenOn Thu, Dec 09, 2010 at 11:42:49PM +0000, Naresh Maharaj wrote:

Dear Ruslan

Thank you - have done all of this already.

Just checked the DNS Servers we use and it seems our ISP had not informed us
of a change to the DNS address.

Made a change to /etc/resolve.conf

added the new DNS server address and hey presto !!!

Super fast

Kind regards

Naresh Maharaj,

Hewitt & May (Shirtmakers) Ltd
email: info@hewittandmay.com
web: http://www.hewittandmay.co.uk

On 9 December 2010 23:39, Ruslan Zakirov ruz@bestpractical.com wrote:

Hi,

The following may help you
http://requesttracker.wikia.com/wiki/SendmailTips

On Fri, Dec 10, 2010 at 12:48 AM, Naresh Maharaj naresh@hewittandmay.com wrote:

Hi

We really need some help resolving the slow email issue.
I have been researching this for over 2 weeks now before calling our to
RT_Users.
I have searched all of the below,

http://wiki.bestpractical.com/
http://gossamer-threads.com/lists/rt/
http://www.google.com/

and much wider across the Internet. Almost given up!!

++Description:
Overall there are no issues with email leaving RT - email reaches all
destinations
There are no issues raising tickets into the queue via email.
Overall speed of moving around RT Web front end is fast / acceptable

++Issue:
replying to a ticket takes up to 30 seconds to complete and sending the
email in some cases up to 1 min.
this is simply prohibitive to use in a professional setup.

++Other Issues:
Squirrel Mail (Linux Web Mail) has the same issue, up to 30 seconds to
send
an email - no solution
SSH to shell remotely same problem 30s - Now resolved by removing the DNS
lookup: /etc/ssh/sshd_config [UseDNS no]
SFTP - Slow 30 sec - fixed by line above
Sendmail takes 30 sec to send an email from command line test an issue we
have had with php apps for over a year - now resolved by :
Edit the sendmail.cfg

Was:

pass to name server to make hostname canonical

R$* $| $* < @ $* > $* $: $2 < @ $[ $3 $] > $4

Now:

pass to name server to make hostname canonical

#R$* $| $* < @ $* > $* $: $2 < @ $[ $3 $] > $4

OR
sendmail.mc
Add:
FEATURE(`nocanonify’)dnl

then rebuiuld sendmail using m4

Sendmail now blistering fast.

++RT mail Configuration:
Previously I was using sendmailpipe
$MailCommand = ‘sendmailpipe’;
$SendmailArguments = “-oi -t”;
$SendmailPath = “/usr/sbin/sendmail”;

Now that I have confirmed that Sendmail is NOT the issue I am now using:
$MailCommand = ‘sendmailpipe’;
#$SendmailArguments = “-oi -t”;
$SendmailArguments = “-oi -ODeliveryMode=b -OErrorMode=m”;
$SendmailPath = “/usr/sbin/sendmail”;

Also have soft link:
/etc/smrsh/rt-mailgate -> /opt/rt3/bin/rt-mailgate

Note sure what else to test.

The common denominator here is Apache Http
So here is the conf entry for RT:

[root@caitanya conf]# diff httpd.conf httpd.conf.working.20101126
997,1015d996
< Alias /rt “/opt/rt3/share/html”
< PerlModule Apache::DBI
< PerlRequire /opt/rt3/bin/webmux.pl
< <Directory /opt/rt3/share/html>
< AllowOverride All
< Options ExecCGI FollowSymLinks
<
< Order allow,deny
< Allow from all
<
<
<
< <Location /rt>
< RewriteEngine On
< RedirectMatch permanent (.*)/$ $1/index.html
< AddDefaultCharset UTF-8
< SetHandler perl-script
< PerlHandler RT::Mason
<

Appreciate any help that one can give.
Its the only issue stopping us from moving RT from test environment to
production.

Naresh Maharaj,

Hewitt & May (Shirtmakers) Ltd
email: info@hewittandmay.com
web: http://www.hewittandmay.co.uk


Best regards, Ruslan.