RT problem with validation

Hi All,

We are trying to use validation” (?#Digits)^[\d.]+$ “in RT 4.2.1. But this validation is not accepting 0 as a digit. It only accepts 1-9 as a digit. Is there any possible way to change the behaviour and make it to accept 0 as a digit?

Cheers,
Atif

Atif Mehboob
Linux Administrator

Eckoh UK Limited
Telford House, Corner Hall
Hemel Hempstead, Hertfordshire HP3 9HN

T 01442 458336
M n/a
W www.eckoh.com

[cid:imagefb1b2b.PNG@0ea3c77b.479d8e17]http://www.linkedin.com/company/eckoh-plc [cid:imagebfc84c.PNG@c008d30f.45918e66] http://twitter.com/Eckoh

US Headquarters:
Eckoh, Inc.
11811 N. Tatum Blvd., Suite 3031
Phoenix, AZ 85028

This communication contains information, which is confidential and may also be privileged. It is for the exclusive use of the intended recipient(s) only. If you are not the intended recipient(s) please note that any form of distribution, copying or use of this communication or the information in it is strictly prohibited and may be unlawful. If you have received this communication in error please return it to the sender and then delete it. Opinions expressed in this message are those of the author, and are not binding on the company.
Registered in England and Wales, No. 2796531
Registered office: Telford House, Corner Hall, Hemel Hempstead, Hertfordshire HP3 9HN
A member of the Eckoh Plc group of companies.

We are trying to use validation” (?#Digits)^[\d.]+$ “in RT 4.2.1. But this
validation is not accepting 0 as a digit. It only accepts 1-9 as a digit. Is
there any possible way to change the behaviour and make it to accept 0 as a
digit?

This was fixed in RT 4.2.3 (along with a number of other custom field
validation bugs in later versions).

There have been numerous other bugfixes in the year+ since 4.2.1
https://www.bestpractical.com/rt/release-notes.html

-kevin