RT OnlineDocs version for RT 4.4?

Hi, I am installing RT 4.4.1 and trying to RT-OnlineDocs 1.1 to it. But the install gives an error, saying it only
for versions older than 4.2.0

Is there a newer version available for 4.4.1 ?


root@rt2:/opt/rt441/src/RT-OnlineDocs-1.1> perl Makefile.PL
Cannot determine perl version info from lib/RT/OnlineDocs.pm
Cannot find the location of RT.pm that defines $RT::LocalPath in: inc /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 . /usr/local/lib /usr/lib
Path to directory containing your RT.pm: /opt/rt441/lib
Using RT configuration from /opt/rt441/lib/RT.pm:
html => /opt/rt441/local/plugins/RT-OnlineDocs/html
lib => /opt/rt441/local/plugins/RT-OnlineDocs/lib

**** Error: Your installed version of RT (4.4.1) is too new; this extension
only works with versions older than 4.2.0.

Thanks !

I downloaded the dist and tried it out, it looks like the menu location where it is coded to display no longer exists. To get it running I commented out the line that says 4.4 is too new and moved the menu item to Admin > Tools. After that it worked for me:

diff -r -u RT-OnlineDocs-orig/Makefile.PL RT-OnlineDocs-1.1/Makefile.PL
--- RT-OnlineDocs-orig/Makefile.PL	2015-01-02 12:22:36.000000000 -0500
+++ RT-OnlineDocs-1.1/Makefile.PL	2017-05-19 00:36:26.000000000 -0400
@@ -3,7 +3,7 @@

+# rt_too_new('4.2.0');

diff -r -u RT-OnlineDocs-orig/html/Callbacks/RT-OnlineDocs/Elements/Tabs/Privileged RT-OnlineDocs-1.1/html/Callbacks/RT-OnlineDocs/Elements/Tabs/Privileged
--- RT-OnlineDocs-orig/html/Callbacks/RT-OnlineDocs/Elements/Tabs/Privileged	2011-10-26 21:22:23.000000000 -0400
+++ RT-OnlineDocs-1.1/html/Callbacks/RT-OnlineDocs/Elements/Tabs/Privileged	2017-05-19 00:45:11.000000000 -0400
@@ -4,7 +4,7 @@
     Object => $RT::System,

-Menu()->child('tools')->child('config')->child('tools')->child( perldoc =>
+Menu()->child('admin')->child('tools')->child( perldoc =>
     title => loc("API Docs"),
     path  => "/Developer/Perldoc",

Thanks ! I will give that a try.

You can also generate HTML from RTs docs using the same tool we use for the docs site. The script is available in devel/tools/rt-static-docs and you can see the options on the docs site. If you create the directory share/static/html, you could try running:

perl -Ilib devel/tools/rt-static-docs --to share/static/html/

You’ll then see a page at https://myrt/static/html/index.html. The main thing it’s missing is the styling.