RT on RHEL 4

There are a few people trying it now, myself included. After reading about some other’s experiences, I’ve elected to try the FastCGI method instead of modperl 2 which seems to be (still) not quite ready for prime time…-----Original Message-----
From: Bech-Yagher, Cirstyn [mailto:CBY@Teleplan.no]
Sent: Tuesday, March 15, 2005 5:09 AM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] (no subject)

Hi,

I just subscribed to the list, and I was wondering whether anyone else was foolhardy enough to try running the latest RT on RHES 4 ?

I had major problems with the RPM on the Fedora install pages (seemingly couldn’t find Perl), and had to change to installing from the .tar.gz file. Which lets me get only as far as “make install”

No matter what I set the user to, I get an error mssg.

I’m fairly new to installing RT - that’s why I was specifically wondering about RH users.

C

After reading
about some other’s experiences, I’ve elected to try the FastCGI method
instead of modperl 2 which seems to be (still) not quite ready for
prime time…

Just to add a note, the following combination is working fine here. We
have not tried FastCGI. So, I do not know how it compares.

Debian Sarge
Apache 2
mod_perl 2RC4
RT 3.4.1

Russell Mosemann, Ph.D. * Computing Services * Concordia University, Nebraska
"Excellence by accident."

After reading
about some other’s experiences, I’ve elected to try the FastCGI method
instead of modperl 2 which seems to be (still) not quite ready for
prime time…

Just to add a note, the following combination is working fine here. We
have not tried FastCGI. So, I do not know how it compares.

Debian Sarge
Apache 2
mod_perl 2RC4
RT 3.4.1

Any chance we could get you to post (here, or better yet, on the wiki)
the relevent (and sanitized) portions of your apache configs?

I’m running that combination as well, although over SuSE 9.1, and I
have it running ok, but it’s kind of slow, and I’m not sure where in
the chain it’s breaking. I’d like to rule out mod_perl2, since I know
that’s a pinch point, and I’m not sure what’s the best wat to do that
yet.

Cheres,
– jra
Jay R. Ashworth jra@baylink.com
Designer Baylink RFC 2100
Ashworth & Associates The Things I Think '87 e24
St Petersburg FL USA http://baylink.pitas.com +1 727 647 1274

  If you can read this... thank a system adminstrator.  Or two.  --me

Just to add a note, the following combination is working fine here. We
have not tried FastCGI. So, I do not know how it compares.

Debian Sarge
Apache 2
mod_perl 2RC4
RT 3.4.1

Any chance we could get you to post (here, or better yet, on the wiki)
the relevent (and sanitized) portions of your apache configs?

We’re not doing anything special (see below). The configuration is right
out of the README. We are using MySQL 4.1.9 with InnoDB tables and fairly
large memory settings. We set things up a month or two ago, and we only
have about 500 tickets at this point. This is on a Dell 1750, I believe,
with a 2.8GHz Xeon, 1GB memory and a mirrored 36GB disk. We have 8 people
in our department addressing requests. The performance could change over
time as the database grows, but it is working fine at this time.

Russell Mosemann, Ph.D. * Computing Services * Concordia University, Nebraska
"A joke cannot be funny and explained at the same time." -
Quantum characterics of humor

<VirtualHost *>
Servername rt.example.net
ServerAlias rt.example.com
AddDefaultCharset UTF-8

DocumentRoot /local/rt3/share/html
<Directory "/local/rt3/share/html">
    Options FollowSymLinks
    AllowOverride None
    Order Allow,Deny
    Allow from all
</Directory>

PerlModule Apache2 Apache::compat
PerlModule Apache::DBI
PerlRequire /local/rt3/bin/webmux.pl

<Location />
    SetHandler perl-script
    PerlHandler RT::Mason
</Location>