Rt-mailgate needs http for comment

I had apache set to allow rt over https only. Trying over http would fail.

rt-mailgate was working perfectly fine over https when using “–action
correspond”. However, when using “–action comment”, it fails saying it
is unable to connect.

When I changed my apache configuration to allow http on local
connections, it started working.

I suspect there is some code in the comment path of rt-mailgate that is
forcing it over the http connection, rather than properly deriving the
connection from the url parameter.

Being new to rt, I am open to the possibility I misconfigured
something. Is anyone else able to reproduce this?

Joseph D. Wagner

I had apache set to allow rt over https only. Trying over http would fail.

rt-mailgate was working perfectly fine over https when using
"–action correspond". However, when using “–action comment”, it
fails saying it is unable to connect.

When I changed my apache configuration to allow http on local
connections, it started working.

I suspect there is some code in the comment path of rt-mailgate that
is forcing it over the http connection, rather than properly
deriving the connection from the url parameter.

Being new to rt, I am open to the possibility I misconfigured
something. Is anyone else able to reproduce this?

I strongly suspect misconfiguration in your /etc/aliases. The only
difference between correspond and comment paths is the value of a
query parameter that they POST:

https://github.com/bestpractical/rt/blob/stable/bin/rt-mailgate.in#L168-L170

Check to make sure that you have https:// on all of your aliases, and
that you’ve run newaliases (or equivalent) after updating them.

  • Alex

Here it is. I left everything intact except the url.

prc: "|/usr/bin/rt-mailgate --queue ‘Performance Review’
–action correspond --url https://xxxx.xxxx/rt"
prc-staff: “|/usr/bin/rt-mailgate --queue ‘Performance Review’
–action comment --url https://xxxx.xxxx/rt

JoeOn 09/05/2015 11:32 PM, Alex Vandiver wrote:

On Sat, Sep 05, 2015 at 11:22:48PM -0700, Joseph D. Wagner wrote:

I had apache set to allow rt over https only. Trying over http would fail.

rt-mailgate was working perfectly fine over https when using
"–action correspond". However, when using “–action comment”, it
fails saying it is unable to connect.

When I changed my apache configuration to allow http on local
connections, it started working.

I suspect there is some code in the comment path of rt-mailgate that
is forcing it over the http connection, rather than properly
deriving the connection from the url parameter.

Being new to rt, I am open to the possibility I misconfigured
something. Is anyone else able to reproduce this?
I strongly suspect misconfiguration in your /etc/aliases. The only
difference between correspond and comment paths is the value of a
query parameter that they POST:

 https://github.com/bestpractical/rt/blob/stable/bin/rt-mailgate.in#L168-L170

Check to make sure that you have https:// on all of your aliases, and
that you’ve run newaliases (or equivalent) after updating them.

  • Alex

Here it is. I left everything intact except the url.
[snip]

Those look fine. Double-check that you have not multiply-defined
prc-staff elsewhere in aliases, and that you’ve run newaliases.
Short of that, my only suggestion is to turn on bug logging in your
MTA – I can say with certainty that rt-mailgate doesn’t deal
differently with correspond vs comment and http/https connections.

  • Alex

Ok, I’m inching closer. I found out that it works if I run it from the
command line, but not when sendmail fires it off. (This probably gave
me the false sense that it worked by switching to HTTP.)

I turned on debug level logging in RT. It logged a bunch of stuff when
run from the command line, but it didn’t log anything when sendmail did it.

Joseph D. Wagner

Figured it out. I created a catch-all address in virtusertable. Unknown
to me, virtusertable gets processed before aliases, so it was hitting
the catch-all and never made it to aliases.

Joseph D. WagnerOn 09/06/2015 12:13 PM, Alex Vandiver wrote:

On Sun, Sep 06, 2015 at 12:31:28AM -0700, Joseph D. Wagner wrote:

Here it is. I left everything intact except the url.
[snip]
Those look fine. Double-check that you have not multiply-defined
prc-staff elsewhere in aliases, and that you’ve run newaliases.
Short of that, my only suggestion is to turn on bug logging in your
MTA – I can say with certainty that rt-mailgate doesn’t deal
differently with correspond vs comment and http/https connections.

  • Alex