Rt-mailgate/libdb4.3 error on debian? RT3.4 and 3.6

I recently started having trouble with rt-mailgate where I get the
error at the bottom of this email.
I checked my aptitude logs to see what I had upgraded, and there
are a number of packages, though libdb4.3 looks somewhat promising. I
have not tried downgrading it yet.
I assumed that since I am running debian testing, and RT was
orphaned a while back, that something was broken, and perhaps would be
fixed in upgrading to 3.6. So, I went ahead and did that (amazing how
easy it was…) but I still get the same error.

I can connect to the mail-gateway URL in my browser, and without 

any parameters, it will create a ticket with an empty body, etc. so it
seems like that is all working. I haven’t gone all the way down the path
yet, but it appears the failure is in LWP::Protocol, though that module
hasn’t been changed in a while, so it must be something upstream affecting
it.
Any ideas? I know there are others of you running Debian - anyone
up-to-date on the testing branch?

procmail: Executing “/usr/bin/rt-mailgate,–debug,–queue,Support,
–action,correspond,–url,https://limedaley.com/support/

Connecting to https://limedaley.com/sup
port//REST/1.0/NoAuth/mail-gateway
at /usr/bin/rt-mailgate line 99, <> line 1.
An Error Occurred
500 Can’t connect to limedaley.com:443 (Illegal seek)
This is /usr/bin/rt-mailgate exiting because of an undefined server error
at /usr/bin/rt-mailgate line 147, <> line 1.
procmail: Program failure (75) of “/usr/bin/rt-mailgate”

I recently started having trouble with rt-mailgate where I get the
error at the bottom of this email.

Any ideas? I know there are others of you running Debian - anyone
up-to-date on the testing branch?

procmail: Executing “/usr/bin/rt-mailgate,–debug,–queue,Support,
–action,correspond,–url,https://limedaley.com/support/

Connecting to https://limedaley.com/sup
port//REST/1.0/NoAuth/mail-gateway at /usr/bin/rt-mailgate
line 99, <> line 1.
An Error Occurred

500 Can’t connect to limedaley.com:443 (Illegal seek)
This is /usr/bin/rt-mailgate exiting because of an undefined server error at
/usr/bin/rt-mailgate line 147, <> line 1.
procmail: Program failure (75) of “/usr/bin/rt-mailgate”

Ah, it is an https (in some library, not with my certs AFAIK) 

problem. If I move the server to plain http it is fine.

The article at:

http://wiki.bestpractical.com/index.cgi?SpreadsheetDisplayedFields

Has been spammed since yesterday when I checked it around 4:45pm.

Is there an easy way to delete the latest revision or does the article
Need to be edited with a copy/paste of the previous revision that is correct?

T.J. Maciak

Internet/Intranet Developer
Department of IT
City of Grand Rapids
P: (616)456-3713
F: (616)456-3448

The article at:

http://wiki.bestpractical.com/index.cgi?SpreadsheetDisplayedFields

Has been spammed since yesterday when I checked it around 4:45pm.

Is there an easy way to delete the latest revision or does the article
Need to be edited with a copy/paste of the previous revision that is correct?

I always just click:

“revisions” (defaults to second newest revision)
then "edit"
then “save”

This will remove the last edit. Sometimes the spammers are smarter than
that, and edit a couple revisions, so you need to check the diffs.