Rt-mailgate/fetchmailrc question: email not leaving inbox

I have been using rt-mailgate and fetchmailrc to retrieve support emails
from our mail server and feed them to RT. My /etc/fetchmailrc looks like
this:

set syslog;
set daemon 20;

poll "mail.domain.com"
with protocol imap
username rt password weak
mda “/usr/bin/perl /usr/bin/rt-mailgate --url https://localhost/
–queue support --action correspond”

Usually, after fetchmail grabs the new mail and feeds it to rt-mailgate,
the email leaves the rt inbox in the mail server. Well, since last
afternoon it has not been doing that. The email is still being send to
rt and becomes a ticket (or a followup to one) but it just now stays in
the inbox as new mail.

Any suggestions?

I have been using rt-mailgate and fetchmailrc to retrieve support emails
from our mail server and feed them to RT. My /etc/fetchmailrc looks like
this:

set syslog;
set daemon 20;

poll "mail.domain.com"
with protocol imap
username rt password weak
mda “/usr/bin/perl /usr/bin/rt-mailgate --url https://localhost/
–queue support --action correspond”

Usually, after fetchmail grabs the new mail and feeds it to rt-mailgate, the
email leaves the rt inbox in the mail server. Well, since last afternoon it
has not been doing that. The email is still being send to rt and becomes a
ticket (or a followup to one) but it just now stays in the inbox as new
mail.

Any suggestions?

What’s changed? Something somewhere has changed, either with
fetchmail (did you just upgrade it) or with your mail server. If you
can identify that you’re most of the way to restoring the way it used
to work.

             Please keep list traffic on the list.

Rob MacGregor
Whoever fights monsters should see to it that in the process he
doesn’t become a monster. Friedrich Nietzsche