RT is hanging when trying to update tickets

I’m running RT 3.2.2 (just upgraded now to see if it may have
helped, was running 3.2.1) on Redhat 7.3 with perl 5.8.3 on
modperl with apache 1.3.31

Just today, RT has started hanging when I try to
submit any changes to tickets - it queries ok, I can log in,
log out, list all tickets etc, but it hangs when I
go to an update ticket page - it’s hard to describe, but it looks
like the page isn’t loading completely, and httpd is going crazy
and using lots of CPU.

On Monday I upgraded DBIx:Searchsomething from CPAN to try and
resolve some performance issues after seeing a thread suggesting
it here, and at the time it seemed ok - we went from 0.99 to 1.11.
I think I restarted apache at the time, but am not 100% sure.

The last thing I see in any apache log files is :

x.x.x.x - - [21/Oct/2004:11:31:35 +1000] “GET /NoAuth/webrt.css
HTTP/1.1” 200 7316
"http://xxx.xxx.xxx/Ticket/Update.html?Action=Comment&DefaultStatus=resolved&id=892"
“Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20040910”

and httpd is spinning, but doesn’t seem to be doing anything.

I’ve restarted mysqld and httpd adnauseum, to no avail.

Can anyone suggest where I should look to try and get it running
again? I’m kinda out of my depth (these things ‘just work’ usually!)
with debugging something broken in apache/modperl, and my users are
just a little … upset!

thanks!

Carl

Vivitec Pty. Ltd.
Suite 6, 51-55 City Rd.
Southbank, 3006.
Ph. +61 3 8626 5626
Fax +61 3 9682 1000

For the record, I had the same problem as Rich West :
http://lists.bestpractical.com/pipermail/rt-users/2004-October/026411.html

I didn’t have rt3.Attributes in my database. Funny that
it hadn’t complained in the past though? And under modperl,
no logs of anything error-ish that I could see.

Is it worth having something in the make update
that does a check of the database schema, to
catch lazy sods like me who don’t do the upgrade
properly? :slight_smile:

Carl

Vivitec Pty. Ltd.
Suite 6, 51-55 City Rd.
Southbank, 3006.
Ph. +61 3 8626 5626
Fax +61 3 9682 1000

Carl Brewer wrote:

For the record, I had the same problem as Rich West :
http://lists.bestpractical.com/pipermail/rt-users/2004-October/026411.html

I didn’t have rt3.Attributes in my database. Funny that
it hadn’t complained in the past though? And under modperl,
no logs of anything error-ish that I could see.
http://wiki.bestpractical.com/index.cgi?Debug
"Logging into standalone file"
Turn on “warning” level at least and you’ll see some records on almost
all errors. IMHO this option is most useful for admins on any RT system.

Hello

RT generates comment mails with subjects likeSubject: [Comment] Re: [Ticket #23] test
which leads to further subjects like
Subject: [Comment] Re: Re: [Ticket #23] eherherh
and so on.

Can this be changed to maybe the following?
Subject: Re: [Ticket #23] Comment: test

bye,

-christian-

Christian Hammers WESTEND GmbH | Internet-Business-Provider
Technik CISCO Systems Partner - Authorized Reseller
Lï¿œtticher Straï¿œe 10 Tel 0241/701333-11
ch@westend.com D-52064 Aachen Fax 0241/911879

I have installed rt-3.2.2 on a Redhat 2.1 AS linux system
with the latest up2dates patches installed. I have installed
apache-1.3.31 and mod_perl-1.29 from source.

After starting RT, when I click on the Ticket option
an apache process begins to use approx. 100% of the cpu.

I need to kill and restart apache before I can do anything else with
RT.

I have tracked down the problem to the
module /Search/Elements/EditSearches, at least that
appears to be where there is a problem.

If I comment out the line EditSearches line in /Search/Build.html
I don’t have the problem of the cpu going to 100%.
Of course the program probably doesn’t work properly then. (:slight_smile:

It looks like the problem is centered in the code below.
I have not been able to figure out what is happening to see
if the problem is really there and whether there is a fix.

paulw

Use FastCGI and add:

FastCgiServer /opt/rt3/bin/mason_handler.fcgi -idle-timeout 300 -processes
4 -init-start-delay 30

to your httpd.confOn Tue, 26 Oct 2004, Paul Williams wrote:

}I have installed rt-3.2.2 on a Redhat 2.1 AS linux system
}with the latest up2dates patches installed. I have installed
}apache-1.3.31 and mod_perl-1.29 from source.
}
}After starting RT, when I click on the Ticket option
}an apache process begins to use approx. 100% of the cpu.
}
}I need to kill and restart apache before I can do anything else with
}RT.
}
}I have tracked down the problem to the
}module /Search/Elements/EditSearches, at least that
}appears to be where there is a problem.
}
}If I comment out the line EditSearches line in /Search/Build.html
}I don’t have the problem of the cpu going to 100%.
}Of course the program probably doesn’t work properly then. (:slight_smile:
}
}It looks like the problem is centered in the code below.
}I have not been able to figure out what is happening to see
}if the problem is really there and whether there is a fix.
}
}paulw
}_______________________________________________
}http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users
}
}Be sure to check out the RT wiki at http://wiki.bestpractical.com
}

Matthew Joseff, Director Technical Operations
§ 703.519.1066 (f) 703.548.9151 (m) 202.415.6261
YellowBrix - Transforming Content Into Action.

Here is the fix.

The first part is to turn on debugging to see what is
happening. In /opt/rt3/etc/RT_SiteConfig.pm
change
Set($LogToFile , undef);
to
Set($LogToFile , ‘debug’);

Restart apache and the look in the log, in my case it was

  /opt/rt3/var/log/rt.log

The error message complained about a missing table
with the name Attributes.

At this point I needed assistance from our mysql expert
who set up the mysql database for rt.

He looked at some older versions of the software and discovered
that the Attributes table was added a few versions back.

The file /opt/rt3/etc/schema.mysql
provided the needed lines to modify the database.

paulw

The error message complained about a missing table
with the name Attributes.

At this point I needed assistance from our mysql expert
who set up the mysql database for rt.

He looked at some older versions of the software and discovered
that the Attributes table was added a few versions back.

The file /opt/rt3/etc/schema.mysql
provided the needed lines to modify the database.

So you missed steps in the upgrade procedure, which would have walked
you through this?

-j