Rt instance can't reply

Hello,

I just recently setup a new RT 4.0.10 instance and it’s working great
except for a certain key point. RT will reply to tickets by email but if
you try to update the ticket to the ‘reply’ address you get nothing back.
But the ticket itself is updated.

Currently I’m pulling RT’s mail from another server with the addresses ‘
request@mycompany.com’, ‘request-reply@mycompany.com’ and ‘
request-comment@mycompany.com

All three addresses seem to allow you to update the ticket but
request-reply and request-comment does not send the user back a reply. The
addresses are on another mail server and pulled down and into rt by a
fetchmail client called ‘getmail’. That worked really well for my last RT
server and seems to be doing it’s job here as well. Information is getting
into tickets by email.

I’m thinking this might be a scrip issue. This is what I see happening in
the logs when I send to the reply address:

Precedence: bulk

X-RT-Loop-Prevention: mycompany.com

RT-Ticket: mycompany.com #11

Managed-BY: RT 4.0.10 (http://www.bestpractical.com/rt/)

RT-Originator: tim.dunphy@mycompany.com

CC: request@mycompany.com

MIME-Version: 1.0

Content-Transfer-Encoding: 8bit

Content-Type: text/plain; charset=“utf-8”

X-RT-Original-Encoding: utf-8
(/usr/local/rt4/sbin/…/lib/RT/Action/SendEmail.pm:651)

[Fri Feb 22 19:32:02 2013] [debug]: Got user mail preference ‘Individual
messages’ for user
request@mycompany.com(/usr/local/rt4/sbin/…/lib/RT/Action/SendEmail.pm:665)

[Fri Feb 22 19:32:02 2013] [debug]: Removing deferred recipients from Cc:
line (/usr/local/rt4/sbin/…/lib/RT/Action/SendEmail.pm:674)

[Fri Feb 22 19:32:02 2013] [debug]: Setting deferred recipients for
attribute creation (/usr/local/rt4/sbin/…/lib/RT/Action/SendEmail.pm:683)

[Fri Feb 22 19:32:02 2013] [debug]: Working on mailfield Bcc; recipients
are (/usr/local/rt4/sbin/…/lib/RT/Action/SendEmail.pm:644)

[Fri Feb 22 19:32:02 2013] [debug]: Subject: Re: [Operations #11]
AutoReply: another test to the queueFrom: “Tim Dunphy via RT” request-reply@mycompany.com

Reply-To: request-reply@mycompany.com

In-Reply-To: CD4D31BE.E8401%tim.dunphy@mycompany.com

References: RT-Ticket-11@mycompany.com

rt-4.0.10-31060-1361559842-482.11-3-0@mycompany.com

CD4D31BE.E8401%tim.dunphy@mycompany.com

Message-ID: rt-4.0.10-31080-1361561522-380.11-6-0@mycompany.com

Precedence: bulk

X-RT-Loop-Prevention: mycompany.com

RT-Ticket: mycompany.com #11

Managed-BY: RT 4.0.10 (http://www.bestpractical.com/rt/)

RT-Originator: tim.dunphy@mycompany.com

CC: request@mycompany.com

MIME-Version: 1.0

Content-Transfer-Encoding: 8bit

Content-Type: text/plain; charset=“utf-8”

X-RT-Original-Encoding: utf-8
(/usr/local/rt4/sbin/…/lib/RT/Action/SendEmail.pm:651)

[Fri Feb 22 19:32:02 2013] [debug]: Removing deferred recipients from Bcc:
line (/usr/local/rt4/sbin/…/lib/RT/Action/SendEmail.pm:674)

[Fri Feb 22 19:32:02 2013] [debug]: Setting deferred recipients for
attribute creation (/usr/local/rt4/sbin/…/lib/RT/Action/SendEmail.pm:683)

[Fri Feb 22 19:32:02 2013] [debug]: No recipients found for deferred
delivery on transaction #108
(/usr/local/rt4/sbin/…/lib/RT/Action/SendEmail.pm:696)

[Fri Feb 22 19:32:02 2013] [info]: <
rt-4.0.10-31080-1361561522-380.11-6-0@mycompany.com> #11/108 - Scrip 6 On
Correspond Notify Requestors and Ccs
(/usr/local/rt4/sbin/…/lib/RT/Action/SendEmail.pm:285)

[Fri Feb 22 19:32:02 2013] [info]: <
rt-4.0.10-31080-1361561522-380.11-6-0@mycompany.com> sent Cc:
request@mycompany.com(/usr/local/rt4/sbin/…/lib/RT/Action/SendEmail.pm:316)

[Fri Feb 22 19:32:02 2013] [debug]: Converting ‘utf-8’ to ‘utf-8’ for
text/plain - Re: [Operations #11] AutoReply: another test to the queue
(/usr/local/rt4/sbin/…/lib/RT/I18N.pm:244)

[Fri Feb 22 19:32:02 2013] [debug]: About to think about scrips for
transaction #109 (/usr/local/rt4/sbin/…/lib/RT/Transaction.pm:173)

[Fri Feb 22 19:32:02 2013] [debug]: Committing scrip #1 on txn #108 of
ticket #11 (/usr/local/rt4/sbin/…/lib/RT/Scrips.pm:182)

[Fri Feb 22 19:32:02 2013] [debug]: Committing scrip #11 on txn #108 of
ticket #11 (/usr/local/rt4/sbin/…/lib/RT/Scrips.pm:182)

[Fri Feb 22 19:32:02 2013] [debug]: Found 0 scrips for TransactionBatch
stage with applicable type(s) Correspond for txn #108 on ticket #11
(/usr/local/rt4/sbin/…/lib/RT/Scrips.pm:377)

[Fri Feb 22 19:33:02 2013] [debug]: Converting ‘utf-8’ to ‘utf-8’ for
text/plain - Re: [Operations #11] AutoReply: another test to the queue
(/usr/local/rt4/sbin/…/lib/RT/I18N.pm:244)

[Fri Feb 22 19:33:02 2013] [critical]: RT Received mail (<
rt-4.0.10-31080-1361561522-380.11-6-0@mycompany.com>

) from itself. (/usr/local/rt4/sbin/…/lib/RT/Interface/Email.pm:1846)

[Fri Feb 22 19:33:02 2013] [crit]: RT thinks this message may be a bounce
(/usr/local/rt4/sbin/…/lib/RT/Interface/Email.pm:248)

[Fri Feb 22 19:33:02 2013] [error]: Could not record email: Message Bounced
(/usr/local/rt4/share/html/REST/1.0/NoAuth/mail-gateway:75)

I was hoping I could get some advice on how to get this to work.

Thanks,
Tim

GPG me!!

gpg --keyserver pool.sks-keyservers.net --recv-keys F186197B

I think my problem centers around this part of the logs:

[Fri Feb 22 20:39:02 2013] [info]: <
rt-4.0.10-3716-1361565542-874.2-6-0@mycompany.com> sent Cc:
request@mycompany.com(/usr/local/rt4/sbin/…/lib/RT/Action/SendEmail.pm:316)

[Fri Feb 22 20:39:02 2013] [debug]: Converting ‘utf-8’ to ‘utf-8’ for
text/plain - Re: [Operations #2] AutoReply: first ticket
(/usr/local/rt4/sbin/…/lib/RT/I18N.pm:244)

[Fri Feb 22 20:39:02 2013] [debug]: About to think about scrips for
transaction #160 (/usr/local/rt4/sbin/…/lib/RT/Transaction.pm:173)

[Fri Feb 22 20:39:02 2013] [debug]: Committing scrip #1 on txn #159 of
ticket #2 (/usr/local/rt4/sbin/…/lib/RT/Scrips.pm:182)

Thanks,

TimOn Fri, Feb 22, 2013 at 2:52 PM, Tim Dunphy bluethundr@gmail.com wrote:

Hello,

I just recently setup a new RT 4.0.10 instance and it’s working great
except for a certain key point. RT will reply to tickets by email but if
you try to update the ticket to the ‘reply’ address you get nothing back.
But the ticket itself is updated.

Currently I’m pulling RT’s mail from another server with the addresses ’
request@mycompany.com’, ‘request-reply@mycompany.com’ and ’
request-comment@mycompany.com

All three addresses seem to allow you to update the ticket but
request-reply and request-comment does not send the user back a reply. The
addresses are on another mail server and pulled down and into rt by a
fetchmail client called ‘getmail’. That worked really well for my last RT
server and seems to be doing it’s job here as well. Information is getting
into tickets by email.

I’m thinking this might be a scrip issue. This is what I see happening in
the logs when I send to the reply address:

Precedence: bulk

X-RT-Loop-Prevention: mycompany.com

RT-Ticket: mycompany.com #11

Managed-BY: RT 4.0.10 (Request Tracker — Best Practical Solutions)

RT-Originator: tim.dunphy@mycompany.com

CC: request@mycompany.com

MIME-Version: 1.0

Content-Transfer-Encoding: 8bit

Content-Type: text/plain; charset=“utf-8”

X-RT-Original-Encoding: utf-8
(/usr/local/rt4/sbin/…/lib/RT/Action/SendEmail.pm:651)

[Fri Feb 22 19:32:02 2013] [debug]: Got user mail preference ‘Individual
messages’ for user request@mycompany.com(/usr/local/rt4/sbin/…/lib/RT/Action/SendEmail.pm:665)

[Fri Feb 22 19:32:02 2013] [debug]: Removing deferred recipients from Cc:
line (/usr/local/rt4/sbin/…/lib/RT/Action/SendEmail.pm:674)

[Fri Feb 22 19:32:02 2013] [debug]: Setting deferred recipients for
attribute creation (/usr/local/rt4/sbin/…/lib/RT/Action/SendEmail.pm:683)

[Fri Feb 22 19:32:02 2013] [debug]: Working on mailfield Bcc; recipients
are (/usr/local/rt4/sbin/…/lib/RT/Action/SendEmail.pm:644)

[Fri Feb 22 19:32:02 2013] [debug]: Subject: Re: [Operations #11]
AutoReply: another test to the queue

From: “Tim Dunphy via RT” request-reply@mycompany.com

Reply-To: request-reply@mycompany.com

In-Reply-To: CD4D31BE.E8401%tim.dunphy@mycompany.com

References: RT-Ticket-11@mycompany.com

rt-4.0.10-31060-1361559842-482.11-3-0@mycompany.com

CD4D31BE.E8401%tim.dunphy@mycompany.com

Message-ID: rt-4.0.10-31080-1361561522-380.11-6-0@mycompany.com

Precedence: bulk

X-RT-Loop-Prevention: mycompany.com

RT-Ticket: mycompany.com #11

Managed-BY: RT 4.0.10 (Request Tracker — Best Practical Solutions)

RT-Originator: tim.dunphy@mycompany.com

CC: request@mycompany.com

MIME-Version: 1.0

Content-Transfer-Encoding: 8bit

Content-Type: text/plain; charset=“utf-8”

X-RT-Original-Encoding: utf-8
(/usr/local/rt4/sbin/…/lib/RT/Action/SendEmail.pm:651)

[Fri Feb 22 19:32:02 2013] [debug]: Removing deferred recipients from Bcc:
line (/usr/local/rt4/sbin/…/lib/RT/Action/SendEmail.pm:674)

[Fri Feb 22 19:32:02 2013] [debug]: Setting deferred recipients for
attribute creation (/usr/local/rt4/sbin/…/lib/RT/Action/SendEmail.pm:683)

[Fri Feb 22 19:32:02 2013] [debug]: No recipients found for deferred
delivery on transaction #108
(/usr/local/rt4/sbin/…/lib/RT/Action/SendEmail.pm:696)

[Fri Feb 22 19:32:02 2013] [info]: <
rt-4.0.10-31080-1361561522-380.11-6-0@mycompany.com> #11/108 - Scrip 6 On
Correspond Notify Requestors and Ccs
(/usr/local/rt4/sbin/…/lib/RT/Action/SendEmail.pm:285)

[Fri Feb 22 19:32:02 2013] [info]: <
rt-4.0.10-31080-1361561522-380.11-6-0@mycompany.com> sent Cc:
request@mycompany.com(/usr/local/rt4/sbin/…/lib/RT/Action/SendEmail.pm:316)

[Fri Feb 22 19:32:02 2013] [debug]: Converting ‘utf-8’ to ‘utf-8’ for
text/plain - Re: [Operations #11] AutoReply: another test to the queue
(/usr/local/rt4/sbin/…/lib/RT/I18N.pm:244)

[Fri Feb 22 19:32:02 2013] [debug]: About to think about scrips for
transaction #109 (/usr/local/rt4/sbin/…/lib/RT/Transaction.pm:173)

[Fri Feb 22 19:32:02 2013] [debug]: Committing scrip #1 on txn #108 of
ticket #11 (/usr/local/rt4/sbin/…/lib/RT/Scrips.pm:182)

[Fri Feb 22 19:32:02 2013] [debug]: Committing scrip #11 on txn #108 of
ticket #11 (/usr/local/rt4/sbin/…/lib/RT/Scrips.pm:182)

[Fri Feb 22 19:32:02 2013] [debug]: Found 0 scrips for TransactionBatch
stage with applicable type(s) Correspond for txn #108 on ticket #11
(/usr/local/rt4/sbin/…/lib/RT/Scrips.pm:377)

[Fri Feb 22 19:33:02 2013] [debug]: Converting ‘utf-8’ to ‘utf-8’ for
text/plain - Re: [Operations #11] AutoReply: another test to the queue
(/usr/local/rt4/sbin/…/lib/RT/I18N.pm:244)

[Fri Feb 22 19:33:02 2013] [critical]: RT Received mail (<
rt-4.0.10-31080-1361561522-380.11-6-0@mycompany.com>

) from itself. (/usr/local/rt4/sbin/…/lib/RT/Interface/Email.pm:1846)

[Fri Feb 22 19:33:02 2013] [crit]: RT thinks this message may be a bounce
(/usr/local/rt4/sbin/…/lib/RT/Interface/Email.pm:248)

[Fri Feb 22 19:33:02 2013] [error]: Could not record email: Message
Bounced (/usr/local/rt4/share/html/REST/1.0/NoAuth/mail-gateway:75)

I was hoping I could get some advice on how to get this to work.

Thanks,
Tim


GPG me!!

gpg --keyserver pool.sks-keyservers.net --recv-keys F186197B

GPG me!!

gpg --keyserver pool.sks-keyservers.net --recv-keys F186197B