RT install documentation error?

Hi folks,
This is in the install instructions that are on
http://www.helgrim.com/rtdocs/installation.html:

7.2.2 using a seperate webserver with mod_proxypass
Set up an apache process which binds itself to a high port on 127.0.0.1.
Set the following values in RT’s config.pm:
TODO: insert values from fsck.com/rt2/ here.
On your main apache webserver, install mod_proxypass and add the
directive:

 ProxyPass /rt/  http://localhost:<port>/rt/

…I assume something should be there instead of that TODO: line?
Can anyone point me in the right direction with this? I’m trying
to install RT2 on a Mandrake 8 system with the httpd and httpd-perl
processes, and I’m not able to get things working correctly. When
I go to http://localhost/rt2/, I just get a bunch of header statements
such as:

<& /Elements/Header, Title=>“Start page”, Refresh =>
$session{‘home_refresh_interval’} &> <& /Elements/Tabs, current_toptab =>
’’ &>

…everything compiled fine with RT (after a few attempts, anyway), so
I’m sure this just config and/or Apache problem. Thanks for any help.

Steve Gilbert
80/20 Software Tools

In addition to setting up your front end webserver with the ProxyPass
statement,

you need to configure the backend web server as described in the
section detailing how to set up RT on a webserver with mod_perl.

-jOn Mon, Oct 29, 2001 at 06:12:32AM -0800, Steve Gilbert wrote:

Hi folks,
This is in the install instructions that are on
http://www.helgrim.com/rtdocs/installation.html:

7.2.2 using a seperate webserver with mod_proxypass
Set up an apache process which binds itself to a high port on 127.0.0.1.
Set the following values in RT’s config.pm:
TODO: insert values from fsck.com/rt2/ here.
On your main apache webserver, install mod_proxypass and add the
directive:

 ProxyPass /rt/  http://localhost:<port>/rt/

…I assume something should be there instead of that TODO: line?
Can anyone point me in the right direction with this? I’m trying
to install RT2 on a Mandrake 8 system with the httpd and httpd-perl
processes, and I’m not able to get things working correctly. When
I go to http://localhost/rt2/, I just get a bunch of header statements
such as:

<& /Elements/Header, Title=>“Start page”, Refresh =>
$session{‘home_refresh_interval’} &> <& /Elements/Tabs, current_toptab =>
’’ &>

…everything compiled fine with RT (after a few attempts, anyway), so
I’m sure this just config and/or Apache problem. Thanks for any help.

Steve Gilbert
80/20 Software Tools


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

http://www.bestpractical.com/products/rt – Trouble Ticketing. Free.

In addition to setting up your front end webserver with the ProxyPass
statement,

you need to configure the backend web server as described in the
section detailing how to set up RT on a webserver with mod_perl.

That’s what I’ve done, Jesse, but does anything special need to
be added to config.pm? The line below seems to indicate this.
Thanks a lot for your help!

7.2.2 using a seperate webserver with mod_proxypass
Set up an apache process which binds itself to a high port on 127.0.0.1.
Set the following values in RT’s config.pm:
TODO: insert values from fsck.com/rt2/ here.

Steve Gilbert
80/20 Software Tools

It shouldn’t. The fsck.com values referred to are just that we have a really “interesting” setup here. It sounds like the RT config on the high-port apache is not right. The stuff you’re seeing is what you’d see if the mod_perl handler was not configured.

-jOn Mon, Oct 29, 2001 at 06:33:59AM -0800, Steve Gilbert wrote:

On Mon, 29 Oct 2001, Jesse Vincent wrote:

In addition to setting up your front end webserver with the ProxyPass
statement,

you need to configure the backend web server as described in the
section detailing how to set up RT on a webserver with mod_perl.

That’s what I’ve done, Jesse, but does anything special need to
be added to config.pm? The line below seems to indicate this.
Thanks a lot for your help!

7.2.2 using a seperate webserver with mod_proxypass
Set up an apache process which binds itself to a high port on 127.0.0.1.
Set the following values in RT’s config.pm:
TODO: insert values from fsck.com/rt2/ here.

Steve Gilbert
80/20 Software Tools

http://www.bestpractical.com/products/rt – Trouble Ticketing. Free.