RT-External-Auth debugging?

All,

I am trying to integrate RT::Authen:: ExternalAuth to my RT instance and it is not letting me log in. I have configured debugging in my RT_SiteConfig.pm:

Set($LogToFile, ‘debug’);
Set($LogDir, ‘/var/log/rt’);

but the only message I get indicating problems is a FAILED LOGIN error in the rt.log. How should I go about getting more detailed logging happening?

Cheers,
David

This often indicates that you havn’t enabled the extension. Or
installed incorrectly. If you’re on RT 3.8.2 then can check system
configuration via UI, especially Plugins option and loaded modules.On Tue, May 12, 2009 at 12:12 PM, David Hobley david.hobley@mionegroup.com wrote:

All,

I am trying to integrate RT::Authen:: ExternalAuth to my RT instance and it is not letting me log in. I have configured debugging in my RT_SiteConfig.pm:

Set($LogToFile, ‘debug’);
Set($LogDir, ‘/var/log/rt’);

but the only message I get indicating problems is a FAILED LOGIN error in the rt.log. How should I go about getting more detailed logging happening?


Cheers,
David


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Best regards, Ruslan.

Ruslan,

thanks for your reply - how can I check this from the UI exactly? Given I can’t login!

I have the following in my RT_SiteConfig.pm, so I thought I had it all configured:

Set($ExternalAuthPriority, [ ‘Primary_LDAP’ ]);
Set($ExternalInfoPriority, [ ‘Primary_LDAP’ ]);
Set($ExternalServiceUsesSSLorTLS, 0);
Set($AutoCreateNonExternalUsers, 0);

et($ExternalSettings, { ‘Primary_LDAP’ => { ‘type’ => ‘ldap’,
‘server’ => ‘my.ldap.host’,
‘base’ => ‘ou=people,dc=MY,dc=DOMAIN’,
‘filter’ => ‘(zimbraAccountStatus=active)’,
‘d_filter’ => ‘(zimbraAccountStatus=closed)’,
‘tls’ => 0,
‘ssl_version’ => 3,
‘net_ldap_args’ => [ version => 3 ],
‘group’ => ‘RT_GROUP’,
‘group_attr’ => ‘memberUid’,
‘attr_match_list’ => [ ‘Name’, ‘EmailAddress’ ],
‘attr_map’ => { ‘Name’ => ‘uid’,
‘EmailAddress’ => ‘zimbraMailDeliveryAddress’,
‘Organization’ => ‘company’,
‘RealName’ => ‘cn’,
‘ExternalAuthId’ => ‘uid’,
‘Gecos’ => ‘uid’,
‘WorkPhone’ => ‘telephoneNumber’,
‘Address1’ => ‘street’,
‘City’ => ‘l’,
‘State’ => ‘st’,
‘Zip’ => ‘postalCode’,
‘Country’ => ‘co’
}
}});

Set up any Plugins

Set(@Plugins, qw(Extension::QuickDelete));
Set(@Plugins, qw(RT::Authen::ExternalAuth));
Set(@Plugins, qw(RT::FM));

Cheers,
DavidFrom: “Ruslan Zakirov” ruslan.zakirov@gmail.com
To: “David Hobley” david.hobley@mionegroup.com
Cc: rt-users@lists.bestpractical.com
Sent: Tuesday, 12 May, 2009 6:21:57 PM GMT +10:00 Canberra / Melbourne / Sydney
Subject: Re: [rt-users] RT-External-Auth debugging?

This often indicates that you havn’t enabled the extension. Or
installed incorrectly. If you’re on RT 3.8.2 then can check system
configuration via UI, especially Plugins option and loaded modules.

Tue 12 May 2009 13:49:03 GMT
David Hobley wrote:

Ruslan,

thanks for your reply - how can I check this from the UI exactly? Given
I can’t login!

Local accounts can always login. Login as root to check the configuration.

I have the following in my RT_SiteConfig.pm, so I thought I had it all
configured:

Set up any Plugins

Set(@Plugins, qw(Extension::QuickDelete));
Set(@Plugins, qw(RT::Authen::ExternalAuth));
Set(@Plugins, qw(RT::FM));

You are overriding the @Plugins array twice. Replace these three lines with:

Set(@Plugins, qw(Extension::QuickDelete RT::Authen::ExternalAuth RT::FM));

lot more difficult.
order and makes replying cleanly a
it totally screws up the reading
Please try not to top-post because
By the way,
Kind Regards,

Mike Peachey, IT
Tel: +44 114 281 2655
Fax: +44 114 281 2951
Jennic Ltd, Furnival Street, Sheffield, S1 4QT, UK
Comp Reg No: 3191371 - Registered In England
http://www.jennic.com

Tue 12 May 2009 13:49:03 GMT
David Hobley wrote:

I have the following in my RT_SiteConfig.pm, so I thought I had it all
configured:

Set up any Plugins

Set(@Plugins, qw(Extension::QuickDelete));
Set(@Plugins, qw(RT::Authen::ExternalAuth));
Set(@Plugins, qw(RT::FM));

You are overriding the @Plugins array twice. Replace these three lines with:

Set(@Plugins, qw(Extension::QuickDelete RT::Authen::ExternalAuth RT::FM));

That fixed it - thanks Mike (& Ruslan) appreciate your responses.

Cheers,
David