RT Emails in Pine

On occasion our staff use “Pine” to read email remotely. Plain text emails
from RT show up in Pine as attachments rather than plain text, i.e.
[ Part 1, Text/PLAIN (charset: UTF-8 “Internet-standard Unicode”) 22 ]
[ Not Shown. Use the “V” command to view or save this part. ]

I’ve changed the default charset (in RT_SiteConfig.pm) to be us-ascii,
but the
message still can’t be viewed ‘inline’, Pine now says:

[ Part 1, Text/PLAIN  5 lines. ]
[ Not Shown. Use the "V" command to view or save this part. ]

Does anyone know of a configuration option to RT (or Pine) that will allow
Pine’s internal viewer to display these messages? I’ve already tried
all the
.pinerc options I can think of. Thanks for any assistance.

-r

Roy McMorran
Systems Administrator
MDI Biological Laboratory
Salisbury Cove, ME
mcmorran@mdibl.org

Does anyone know of a configuration option to RT (or Pine) that will
allow Pine’s internal viewer to display these messages? I’ve already
tried all the .pinerc options I can think of. Thanks for any
assistance.

The problem is probably with the RT configuration; I use Pine to work
with RT’s mails all the time (daily for 2 years now) & have never seen
this behavior.

I’m shooting in the dark, but can you send a sample of a message that
your Pine users can’t open, including all the headers? Just pasting the
full headers into an email to the list would probably be enough.

Chris Devers

I use pine… and don’t have any issues… Try turning on:

show-plain-text-internally in the config.

Ramon Kagan
York University, Computing and Network Services
Information Security - Senior Information Security Analyst
(416)736-2100 #20263
rkagan@yorku.ca


I have not failed. I have just I don’t know the secret to success,
found 10,000 ways that don’t work. but the secret to failure is
trying to please everybody.
- Thomas Edison - Bill Cosby
----------------------------------- ------------------------------------On Tue, 15 Mar 2005, Roy McMorran wrote:

On occasion our staff use “Pine” to read email remotely. Plain text emails
from RT show up in Pine as attachments rather than plain text, i.e.
[ Part 1, Text/PLAIN (charset: UTF-8 “Internet-standard Unicode”) 22 ]
[ Not Shown. Use the “V” command to view or save this part. ]

I’ve changed the default charset (in RT_SiteConfig.pm) to be us-ascii,
but the
message still can’t be viewed ‘inline’, Pine now says:

[ Part 1, Text/PLAIN  5 lines. ]
[ Not Shown. Use the "V" command to view or save this part. ]

Does anyone know of a configuration option to RT (or Pine) that will allow
Pine’s internal viewer to display these messages? I’ve already tried
all the
.pinerc options I can think of. Thanks for any assistance.

-r


Roy McMorran
Systems Administrator
MDI Biological Laboratory
Salisbury Cove, ME
mcmorran@mdibl.org


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

RT Administrator and Developer training is coming to your town soon! (Boston, San Francisco, Austin, Sydney) Contact training@bestpractical.com for details.

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Thanks for the quick replies!

Thusly spake Chris Devers on 3/15/2005 2:34 PM:

I’m shooting in the dark, but can you send a sample of a message that
your Pine users can’t open, including all the headers?

This one was after I changed Set($EmailOutputEncoding , ‘us-ascii’);

Return-Path: nobody@xxxxxxx.mdibl.org
X-Original-To: mcmorran@mdibl.org
Delivered-To: mcmorran@mdibl.org
Received: from xxxxxxx.mdibl.org (xxxxxxx [xxx.xxx.xxx.xxx])
by xxxxxxx.mdibl.org (Postfix) with ESMTP
id 54481A0E71; Tue, 15 Mar 2005 13:59:49 -0500 (EST)
Received: by xxxxxxx.mdibl.org (Postfix, from userid 60001)
id 483D35BCCA4; Tue, 15 Mar 2005 13:59:49 -0500 (EST)
Managed-BY: RT 3.4.1 (http://www.bestpractical.com/rt/)
MIME-Version: 1.0Subject: [mdibl.org #27] MySQL Backups
In-Reply-To: rt-27@mdibl.org
RT-Ticket: mdibl.org #27
Precedence: bulk
Content-Type: text/plain; charset="us-ascii"
Reply-To: rt@mdibl.org
Message-ID: rt-3.4.1-27-479-4.12.5385520901365@mdibl.org
To: “AdminCc of mdibl.org Ticket #27”: ;
X-RT-Loop-Prevention: mdibl.org
Content-Transfer-Encoding: 8-bit
RT-Originator: mcmorran@mdibl.org
From: “Roy McMorran via RT” rt@mdibl.org
X-RT-Original-Encoding: utf-8
Date: Tue, 15 Mar 2005 13:59:49 -0500 (EST)

Tue Mar 15 13:59:48 2005: Request 27 was acted upon.
Transaction: Ticket created by mcmorran
Queue: General
Subject: MySQL Backups
Owner: mcmorran
Requestors: mcmorran@mdibl.org
Status: new
Ticket <URL: http://xx.mdibl.org/Ticket/Display.html?id=27 >

----snip----
$ pine -v
Pine 4.33

show-plain-text-internally is enabled.

Thanks!
-r

Roy McMorran
Systems Administrator
MDI Biological Laboratory
Salisbury Cove, ME
mcmorran@mdibl.org

|# Thanks for the quick replies!
|#
|# > I’m shooting in the dark, but can you send a sample of a message that your
|# > Pine users can’t open, including all the headers?
|# This one was after I changed Set($EmailOutputEncoding , ‘us-ascii’);
|#
|# Content-Transfer-Encoding: 8-bit
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

Here’s how I fixed mine (virgin 3.4.1)

diff -c lib/RT/Action/SendEmail.pm local/lib/RT/Action/Se^ndEmail.pm

*** lib/RT/Action/SendEmail.pm Tue Feb 1 06:20:40 2005
— local/lib/RT/Action/SendEmail.pm Fri Mar 4 12:46:01 2005
*** 151,157 ****
$self->SetHeader( ‘Content-Type’, ‘text/plain; charset=“utf-8”’ );

  # fsck.com #5959: Since RT sends 8-bit mail, we should say so.

! $self->SetHeader( ‘Content-Transfer-Encoding’,‘8-bit’);

  RT::I18N::SetMIMEEntityToEncoding( $MIMEObj, $RT::EmailOutputEncoding,

— 151,157 ----
$self->SetHeader( ‘Content-Type’, ‘text/plain; charset=“utf-8”’ );

  # fsck.com #5959: Since RT sends 8-bit mail, we should say so.

! $self->SetHeader( ‘Content-Transfer-Encoding’,‘8bit’);

  RT::I18N::SetMIMEEntityToEncoding( $MIMEObj, $RT::EmailOutputEncoding,

            Tim Rosmus <trosmus@nwnexus.net>
               Postmaster / USENET / DNS
                  Northwest Nexus Inc.

Thusly spake Tim Rosmus on 3/15/2005 2:59 PM:

Here’s how I fixed mine (virgin 3.4.1)
! $self->SetHeader( ‘Content-Transfer-Encoding’,‘8bit’);

That did the trick. Thanks!

Roy McMorran
Systems Administrator
MDI Biological Laboratory
Salisbury Cove, ME 04672
mcmorran@mdibl.org

Thusly spake Tim Rosmus on 3/15/2005 2:59 PM:

Here’s how I fixed mine (virgin 3.4.1)
! $self->SetHeader( ‘Content-Transfer-Encoding’,‘8bit’);

The patch is already in svn and will be in 3.4.2 and 3.2.4

Thusly spake Tim Rosmus on 3/15/2005 2:59 PM:

Here’s how I fixed mine (virgin 3.4.1)
! $self->SetHeader( ‘Content-Transfer-Encoding’,‘8bit’);

That did the trick. Thanks!

FWIW, if you had that problem, the reason was likely an intermediate
mail server rewrapping the message to protect the 8-bit bits.

Cheers,
– jra
Jay R. Ashworth jra@baylink.com
Designer Baylink RFC 2100
Ashworth & Associates The Things I Think '87 e24
St Petersburg FL USA http://baylink.pitas.com +1 727 647 1274

  If you can read this... thank a system adminstrator.  Or two.  --me

Hello folks,
I’m building a fresh install of RT 3.4.2 on a new system:
Solaris 9, freshly paved
Perl 5.8.7
MySQL 4.1.2

and I’m hitting a wall at “make initdb” when it tries to “Create templates”:

root@testbed# gmake initdb
/usr/local/bin/perl //usr/local/rt3/sbin/rt-setup-database --action init
–dba root --prompt-for-dba-password
In order to create or update your RT database,this script needs to
connect to your mysql instance on localhost as root.
Please specify that user’s database password below. If the user has no
database
password, just press return.

Password:
Now creating a database for RT.
Creating mysql database rt3.
Now populating database schema.
Creating database schema.
Done setting up database schema.
Now inserting database ACLs
Done setting up database ACLs.
Now inserting RT core system objects
Checking for existing system user…not found. This appears to be a new
installation.
Creating system user…done.
Now inserting RT data
Creating Superuser ACL…done.
Creating groups…3.4.5.6.7.8.9.done.
Creating users…10.12.done.
Creating queues…1.2.done.
Creating ACL…2.3.done.
Creating ScripActions…1.2.3.4.5.6.7.8.9.10.11.12.13.14.15.16.17.done.
Creating ScripConditions…1.2.3.4.5.6.7.8.9.10.done.
Creating templates…1.gmake: *** [initialize-database] Bus Error (core
dumped)

It appears to be dying inside DBIx::SearchBuilder::Handle …here are
the last few lines of a perl -d trace
(I can provide the rest if needed):

DBIx::SearchBuilder::Handle::SimpleQuery(/usr/local/lib/perl5/site_perl/5.8.7/DBIx/SearchBuilder/Handle.pm:477):
477: my $executed;
478: {
DBIx::SearchBuilder::Handle::SimpleQuery(/usr/local/lib/perl5/site_perl/5.8.7/DBIx/SearchBuilder/Handle.pm:479):
479: no warnings ‘uninitialized’ ; # undef in bind_values
makes DBI sad
DBIx::SearchBuilder::Handle::SimpleQuery(/usr/local/lib/perl5/site_perl/5.8.7/DBIx/SearchBuilder/Handle.pm:480):
480: eval { $executed = $sth->execute(@bind_values) };
DBIx::SearchBuilder::Handle::SimpleQuery(/usr/local/lib/perl5/site_perl/5.8.7/DBIx/SearchBuilder/Handle.pm:480):
480: eval { $executed = $sth->execute(@bind_values) };

Any ideas on what might be wrong?

Thanks and best wishes,
-r

PS: Thanks for RT, it is awesome!

Roy McMorran
Systems Administrator
MDI Biological Laboratory
Old Bar Harbor Road
P.O. Box 35
Salisbury Cove, ME 04672
207-288-3605 Ext. 127
mcmorran@mdibl.org

Roy McMorran wrote:

Creating templates…1.gmake: *** [initialize-database] Bus Error (core
dumped)

It appears to be dying inside DBIx::SearchBuilder::Handle …here are
the last few lines of a perl -d trace
(I can provide the rest if needed):

Using DBD::mysql 3.000? Try any other version. :slight_smile:

Roy McMorran wrote:

Creating templates…1.gmake: *** [initialize-database] Bus Error (core
dumped)

Using DBD::mysql 3.000? Try any other version. :slight_smile:

Spot on! Updated to DBD::mysql 3.0002 and I’m on my way. Thanks Phil.
-r

Roy McMorran
Systems Administrator
MDI Biological Laboratory
Salisbury Cove, ME
mcmorran@mdibl.org