RT crashes during spreadsheet export with "...rt-server.fcgi" aborted: idle timeout (3 sec)

Hi all,

Would really appreciate any help/advise on this.

Centos 6.4
Mysql
RT 4.0.10

here is what’s in /etc/httpd/conf.d/rt.conf :

### Optional apache logs for RT # Ensure that your log rotation scripts know about these files # ErrorLog /opt/rt4/var/log/apache2.error # TransferLog /opt/rt4/var/log/apache2.access # LogLevel debug

AddDefaultCharset UTF-8

Alias /NoAuth/images/ /opt/rt4/share/html/NoAuth/images/
ScriptAlias / /opt/rt4/sbin/rt-server.fcgi/

DocumentRoot “/opt/rt4/share/html”

Order allow,deny
Allow from all

 Options +ExecCGI
 AddHandler fastcgi-script fcgi
</Location>

I have a queue called TOS with 34 “Ticket Custom Fields”, which is
reproducing a spreadsheet in RT and each ticket is one shipment record. All
works good!

Now occasionally we need to export some “Saved searches” contents into a
spreadsheet. When the search contains little amount of results, i.e. 19
tickets or 36 tickets, the export works as expected. When it contains for
example 56 tickets - the “Internal Server Error” in the browser.

Looking in the httpd log we have the following:

[Mon Feb 03 16:55:30 2014] [error] [client 10.x.x.x] FastCGI: comm with
server “/opt/rt4/sbin/rt-server.fcgi” aborted: idle timeout (3 sec),
referer:
http://support.company.com/Search/Results.html?Format=‘<b><a%20href%3D"%2FTicket%2FDisplay.html%3Fid%3D__id__">__id__<%2Fa><%2Fb>%2FTITLE%3A%23’%2C ‘<a%20href%3D"%2FTicket%2FUpdate.html%3FAction%3DComment%26amp%3Bid%3D__id__">__CustomField.{Shipper}__<%2Fa>’%2C ‘__CustomField.{Loadport}__’%2C '__CustomField.{I}__%2

And this above log line is very long listing all of the custom fields. Then
one second later the following comes into the log:

[Mon Feb 03 16:55:34 2014] [warn] FastCGI: server
“/opt/rt4/sbin/rt-server.fcgi” (pid 4995) terminated due to uncaught signal
‘13’ (Broken pipe)
[Mon Feb 03 16:55:34 2014] [warn] FastCGI: server
“/opt/rt4/sbin/rt-server.fcgi” restarted (pid 16011)

Any clues how to overcome this issue? We will need to be exporting into
spreadsheets on a monthly basis, and the amount of tickets in the queue
will be growing approx 100 per month.

Thanks in advance for your assistance!

Kind regards,
Alex Geo.

Signal 13 is just a broken pipe, as it says. You need to find out why it’s
broken. It’s probably running out of memory or taking too long. FastCGI
in my experience likes to timeout and not tell anyone that it did. I find
it strange that your idle timeout is only 3 seconds. It’ll likely timeout
often while it waits for the database to produce the query results.On 3 February 2014 09:19, Alex Geo. alex@russian-cyprus.org wrote:

Hi all,

Would really appreciate any help/advise on this.

Centos 6.4
Mysql
RT 4.0.10

here is what’s in /etc/httpd/conf.d/rt.conf :

### Optional apache logs for RT # Ensure that your log rotation scripts know about these files # ErrorLog /opt/rt4/var/log/apache2.error # TransferLog /opt/rt4/var/log/apache2.access # LogLevel debug

AddDefaultCharset UTF-8

Alias /NoAuth/images/ /opt/rt4/share/html/NoAuth/images/
ScriptAlias / /opt/rt4/sbin/rt-server.fcgi/

DocumentRoot “/opt/rt4/share/html”

Order allow,deny
Allow from all

 Options +ExecCGI
 AddHandler fastcgi-script fcgi
</Location>

I have a queue called TOS with 34 “Ticket Custom Fields”, which is
reproducing a spreadsheet in RT and each ticket is one shipment record. All
works good!

Now occasionally we need to export some “Saved searches” contents into a
spreadsheet. When the search contains little amount of results, i.e. 19
tickets or 36 tickets, the export works as expected. When it contains for
example 56 tickets - the “Internal Server Error” in the browser.

Looking in the httpd log we have the following:

[Mon Feb 03 16:55:30 2014] [error] [client 10.x.x.x] FastCGI: comm with
server “/opt/rt4/sbin/rt-server.fcgi” aborted: idle timeout (3 sec),
referer:
http://support.company.com/Search/Results.html?Format=‘<b><a%20href%3D"%2FTicket%2FDisplay.html%3Fid%3D__id__">__id__<%2Fa><%2Fb>%2FTITLE%3A%23’%2C ‘<a%20href%3D"%2FTicket%2FUpdate.html%3FAction%3DComment%26amp%3Bid%3D__id__">__CustomField.{Shipper}__<%2Fa>’%2C ‘__CustomField.{Loadport}__’%2C '__CustomField.{I}__%2

And this above log line is very long listing all of the custom fields.
Then one second later the following comes into the log:

[Mon Feb 03 16:55:34 2014] [warn] FastCGI: server
“/opt/rt4/sbin/rt-server.fcgi” (pid 4995) terminated due to uncaught signal
‘13’ (Broken pipe)
[Mon Feb 03 16:55:34 2014] [warn] FastCGI: server
“/opt/rt4/sbin/rt-server.fcgi” restarted (pid 16011)

Any clues how to overcome this issue? We will need to be exporting into
spreadsheets on a monthly basis, and the amount of tickets in the queue
will be growing approx 100 per month.

Thanks in advance for your assistance!

Kind regards,
Alex Geo.

Landon Stewart :: lstewart@iweb.com
Lead Specialist, Abuse and Security Management
Spécialiste principal, gestion des abus et sécurité
http://iweb.com :: +1 (888) 909-4932

Hi Landon,

Thanks a lot for the tip!

I checked my rt.conf file under apache conf.d directory and here is what
was in there: “FastCgiServer /opt/rt4/sbin/rt-server.fcgi -processes 5
-idle-timeout 3” Seems like the two extra zeroes were lost somewhere :slight_smile: .
Changed that to 300, now a spreadsheet export of 157 tickets works fine! It
takes around 7-8 seconds to generate.

So thanks for your advise and have a great day!

Regards,
Alex G.2014-02-03 Landon Stewart lstewart@iweb.com:

Signal 13 is just a broken pipe, as it says. You need to find out why
it’s broken. It’s probably running out of memory or taking too long.
FastCGI in my experience likes to timeout and not tell anyone that it did.
I find it strange that your idle timeout is only 3 seconds. It’ll likely
timeout often while it waits for the database to produce the query results.


Landon Stewart :: lstewart@iweb.com
Lead Specialist, Abuse and Security Management
Spécialiste principal, gestion des abus et sécurité
http://iweb.com :: +1 (888) 909-4932