RT::Authen::ExternalAuth - LDAP Accounts Not Shown in Users List

I have the latest RT::Authen::ExternalAuth installed and working with
RT 3.8.8. I can log in as a user in our LDAP directory, and a
corresponding record is created in the users table in the rt3 database
(Postgres 9). But when I log in as root and try to add that user to a
new group, it lists only Enoch Root in the Users list under Add Members.

Not sure if it’s relevant but when I log in with the LDAP account I
see this error in syslog:

RT: DBD::Pg::db selectall_hashref failed: ERROR: column "disabled"
does not exist at character 13
(/usr/local/rt3/local/plugins/RT-Authen-ExternalAuth/lib/RT/Authen/ExternalAuth/DBI.pm:279)

Appreciate any help.

Thanks-

Lee

I have the latest RT::Authen::ExternalAuth installed and working
with RT 3.8.8. I can log in as a user in our LDAP directory, and a
corresponding record is created in the users table in the rt3
database (Postgres 9). But when I log in as root and try to add that
user to a new group, it lists only Enoch Root in the Users list
under Add Members.

Those users are unprivileged by default, search for them

Not sure if it’s relevant but when I log in with the LDAP account I
see this error in syslog:

RT: DBD::Pg::db selectall_hashref failed: ERROR: column "disabled"
does not exist at character 13 (/usr/local/rt3/local/plugins/RT-Authen-ExternalAuth/lib/RT/Authen/ExternalAuth/DBI.pm:279)

sounds like you left the default dbi example config in place, rather
than only enabling the ldap config.

-kevin

I have the latest RT::Authen::ExternalAuth installed and working
with RT 3.8.8. I can log in as a user in our LDAP directory, and a
corresponding record is created in the users table in the rt3
database (Postgres 9). But when I log in as root and try to add that
user to a new group, it lists only Enoch Root in the Users list
under Add Members.

Those users are unprivileged by default, search for them

Not sure if it’s relevant but when I log in with the LDAP account I
see this error in syslog:

RT: DBD::Pg::db selectall_hashref failed: ERROR: column "disabled"
does not exist at character 13
(/usr/local/rt3/local/plugins/RT-Authen-ExternalAuth/lib/RT/Authen/ExternalAuth/DBI.pm:279)

sounds like you left the default dbi example config in place, rather
than only enabling the ldap config.

-kevin

Kevin-

Great suggestions. I incorrectly assumed I needed to keep dbi in place
for root login, but I disabled dbi and I can still log in as root. I
found the LDAP accounts under Configuration > Users > Find, checked
"Let this user be granted rights", and I’m now able to add them to the
Group.

Thanks alot for your help, it is greatly appreciated.

Lee