RT::Authen::ExternalAuth insall issue on RT3.8.0

I was wondering if anyone has been able to get RT 3.8.0 to connect
with LDAP using this plugin? I see there have not been any updates on
the bug in 5 weeks?

http://rt.cpan.org/Public/Bug/Display.html?id=37767

Thanks,
Cj B

Try looking at this, I documented my steps here (last post, all the way
at the bottom)

http://www.gossamer-threads.com/lists/rt/users/77286-----Original Message-----
From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Chris
Black
Sent: Thursday, September 11, 2008 4:00 PM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] RT::Authen::ExternalAuth insall issue on RT3.8.0

I was wondering if anyone has been able to get RT 3.8.0 to connect
with LDAP using this plugin? I see there have not been any updates on
the bug in 5 weeks?

http://rt.cpan.org/Public/Bug/Display.html?id=37767

Thanks,
Cj B
http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Helmuth’s suggestion helped, once I figured out you have to fill in the disabled filter option in the RT_SiteConfig.pm for the LDAP settings.

I set it to:
‘d_filter’ => ‘(&(objectCategory=person)(objectClass=user) (userAccountControl:1.2.840.113556.1.4.803:=2))’,

(For Microsoft Active Directory’s disabled users)

David J Kirk

System Administrator
Center 7