RT/apache creating many directories in /tmp

Hi, I’m currently running RT 3.0.5 on a redhat 9 machine with apache
1.3. I am getting a ton of directories left in /tmp which apache/rt
never cleans up, so I have to do so manually. The directories are owned
by apache and have names like:
0ycv4AVG3W
13d27J4urr

The directories seem to be created when a new email is sent to the RT
address and a ticket is created (although I’m not positive on this). In
my searches around the lists I’ve found a couple of scripts to help
clean these directories up, but I haven’t seen any type of patch for RT
to prevent the directories from being created. Has this been addressed
in a newer version than 3.0.5?

Thanks,
Jeff

Hi, I’m currently running RT 3.0.5 on a redhat 9 machine with apache
1.3. I am getting a ton of directories left in /tmp which apache/rt
never cleans up, so I have to do so manually. The directories are owned
by apache and have names like:
0ycv4AVG3W
13d27J4urr

The directories seem to be created when a new email is sent to the RT
address and a ticket is created (although I’m not positive on this). In
my searches around the lists I’ve found a couple of scripts to help
clean these directories up, but I haven’t seen any type of patch for RT
to prevent the directories from being created. Has this been addressed
in a newer version than 3.0.5?

I discovered this the hard way. I ran out of room for temp file entries
and all RT-destined tickets started bouncing.

I’m using RT 3.0.4 and FreeBSD 4.7. FreeBSD includes a feature to clear
/tmp daily. It is disabled by default. I turned it on and my problem was
solved (using the bandaid approach). You might want to check and see if
redhat has a similar feature.

For reference, in FreeBSD 4.7 I have a /etc/periodic.conf file containing:

Please make all changes to this file, not to /etc/defaults/periodic.conf.

This file contains overrides from /etc/defaults/periodic.conf.

daily_clean_disks_enable=“YES” # Delete files daily
daily_clean_tmps_enable=“YES” # Delete stuff daily
daily_clean_tmps_ignore=".X*-lock quota.user quota.group mysql.sock" # Don’t delete these

-Bill

<=> ASK and you shall receive <=>

Hi Bill, thanks for the info. I’m not aware of redhat/linux having a
similar feature - although I could do it pretty easily through crontab
or cfengine. It just bugs me because these directories should be
getting cleaned up by RT in the first place IMO…

-JeffOn Wed, 2003-11-19 at 10:24, bill@daze.net wrote:

I discovered this the hard way. I ran out of room for temp file entries
and all RT-destined tickets started bouncing.

I’m using RT 3.0.4 and FreeBSD 4.7. FreeBSD includes a feature to clear
/tmp daily. It is disabled by default. I turned it on and my problem was
solved (using the bandaid approach). You might want to check and see if
redhat has a similar feature.

For reference, in FreeBSD 4.7 I have a /etc/periodic.conf file containing:

Please make all changes to this file, not to /etc/defaults/periodic.conf.

This file contains overrides from /etc/defaults/periodic.conf.

daily_clean_disks_enable=“YES” # Delete files daily
daily_clean_tmps_enable=“YES” # Delete stuff daily
daily_clean_tmps_ignore=".X*-lock quota.user quota.group mysql.sock" # Don’t delete these

-Bill


<=> ASK and you shall receive <=>

Hi Bill, thanks for the info. I’m not aware of redhat/linux having a
similar feature - although I could do it pretty easily through crontab
or cfengine. It just bugs me because these directories should be
getting cleaned up by RT in the first place IMO…

They should be getting cleaned up by RT whenever the process using
them exits. I know we did work on this for 3.0.6 or so. I’d be curious
to hear if people are still seeing it with current releases.

-j

-Jeff

I discovered this the hard way. I ran out of room for temp file entries
and all RT-destined tickets started bouncing.

I’m using RT 3.0.4 and FreeBSD 4.7. FreeBSD includes a feature to clear
/tmp daily. It is disabled by default. I turned it on and my problem was
solved (using the bandaid approach). You might want to check and see if
redhat has a similar feature.

For reference, in FreeBSD 4.7 I have a /etc/periodic.conf file containing:

Please make all changes to this file, not to /etc/defaults/periodic.conf.

This file contains overrides from /etc/defaults/periodic.conf.

daily_clean_disks_enable=“YES” # Delete files daily
daily_clean_tmps_enable=“YES” # Delete stuff daily
daily_clean_tmps_ignore=".X*-lock quota.user quota.group mysql.sock" # Don’t delete these

-Bill


<=> ASK and you shall receive <=>


rt-devel mailing list
rt-devel@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-devel

http://www.bestpractical.com/rt – Trouble Ticketing. Free.

Hi Jesse, I’d be glad to give the latest version a try and see if the
problem has already been resolved - however, it may take me a little
while before I have time to do so. Has anyone else on the list
experienced this problem (with RT >= 3.0.5)?

-JeffOn Wed, 2003-11-19 at 10:41, Jesse Vincent wrote:

They should be getting cleaned up by RT whenever the process using
them exits. I know we did work on this for 3.0.6 or so. I’d be curious
to hear if people are still seeing it with current releases.

-j

Jeff Sheltren wrote:

Hi Jesse, I’d be glad to give the latest version a try and see if the
problem has already been resolved - however, it may take me a little
while before I have time to do so. Has anyone else on the list
experienced this problem (with RT >= 3.0.5)?

[mob22@manticore rt3]$ ls /tmp
0JB1dsGLA6 ahXtMH6X71 ExF2ypEViz JFklRjOTsI pctjJe1feR T9kmsDZVJn
0mnkrsTXwI AJwUi7XD2X f8zs57V7Vm JfQJ5ynYUn PilfbXXM8M TDwo2wDtay
1Ceopasz6n aNxpIPet1D fCm5GmGuLe jGQTxYVIC9 pPNpsqi9bl tkgSqkWtID

Yes - rt = 3.0.6

Max.

Hi Bill, thanks for the info. I’m not aware of redhat/linux having a
similar feature - although I could do it pretty easily through crontab
or cfengine. It just bugs me because these directories should be
getting cleaned up by RT in the first place IMO…

Install the tmpwatch rpm. It drops a crontab entry into /etc/cron.daily/

I’ve seen this problem with 3.0.5, I’m going to move to 3.0.7 this week
because I noticed perl was using 175M. Hopefully that was fixed with the
circular reference fix in 3.0.7.

-james

Jeff Sheltren wrote:

Hi, I’m currently running RT 3.0.5 on a redhat 9 machine with apache
1.3. I am getting a ton of directories left in /tmp which apache/rt
never cleans up, so I have to do so manually. The directories are owned
by apache and have names like:
0ycv4AVG3W
13d27J4urr

as i know it is a MIME::Entry problem
directory name is 10 symbols

I solved this problem via crontab:

crontab -l

10 1 * * * (find /tmp -user webserv -group webgroup -name “???”
-atime +1 | xargs rm -rf )