RT almost setup. Ran into a few glitches , possible path issue?

Greetings to the RT community,

I have been trying to setup RT on an Ubuntu 6.06.1 machine since 

this morning but I’ve only gotten so far. I apt-get’ed the package ,
marked /usr/share/request-tracker3.6/html as my document root for apache
(no vhosts) and added the following into my httpd.conf file.

FastCgiServer /usr/share/request-tracker3.6/libexec/mason_handler.fcgi
-idle-timeout 120 -processes 4
AddHandler fastcgi-script fcgi
ScriptAlias / /usr/share/request-tracker3.6/libexec/mason_handler.fcgi

I got up to the point where I can see the RT screen when I visit my site
a http://mysite:3000/ ( I run apache on 3000) but it looks as if the
stylesheets are missing somehow and so are the images. When I hover a
link it looks like http://Search/Build.html and so forth.

Is this a path issue? Where am I wrong? I checked everything in my
/etc/request-tracker3.6/ config files there and tried many scenarios
with the paths still with no luck to fix the look and the functionality
of the links.

By the way I have the document root /usr/share/request-tracker3.6
chowned for www-data and that includes the /etc/request-tracker3.6 files.

But the problem remains that it looks like the path is wrong somehow.
Can someone be of assistance ? I am loosing my head here.

Many Thanks,
Mario A. Spinthiras
Nicosia , Cyprus