RT 4 & ExternalAuth with AD Problems

RT 4.0.4
ExternalAuth 0.09
CentOS 5.7 64 bit
Win 2008r2 AD

This is a fresh install of RT 4 and I’m having problems with authentication. First off, just going to the login page, I see:

            [Thu Dec 15 20:52:56 2011] [debug]: Autohandler called ExternalAuth. Response: (0, ExternalAuthPriority not defined, please check your configuration file.) (/opt/rt4/local/plugins/RT-Authen-ExternalAuth/html/Elements/DoAuth:11)

I also do a perl -c RT_SiteConfig.pm and get the following:

            Bad name after attr_map' at RT_SiteConfig.pm line 70.

RT_SiteConfig.pm is pretty straight forward, what am I missing?

Any configuration directives you include here will override

RT’s default configuration file, RT_Config.pm

To include a directive here, just copy the equivalent statement

from RT_Config.pm and change the value. We’ve included a single

sample value below.

This file is actually a perl module, so you can include valid

perl code, as well.

The converse is also true, if this file isn’t valid perl, you’re

going to run into trouble. To check your SiteConfig file, use

this comamnd:

perl -c /path/to/your/etc/RT_SiteConfig.pm

You must restart your webserver after making changes to this file.

Set($rtname, ‘dotomi.com’);
Set($Organization, “dotomi.com”);
Set($CorrespondAddress, ‘hdtest@dotomi.com’);
Set($CommentAddress, ‘hdtest@dotomi.com’);
Set($WebDomain, “it.dotomi.com”);
Set($WebPath, “/rt4”);
Set($Timezone, “US/Central”);
Set(@Plugins,qw(RT::Authen::ExternalAuth) );

Set($DatabaseType, “mysql”);
Set($DatabaseHost, “10.110.xxx.xxx”);
Set($DatabaseRTHost, “10.110.xxx.xxx”);
Set($DatabasePort, “3306”);
Set($DatabaseUser, “xxxxxx”);
Set($DatabasePassword, q{xxxxxx});
Set($DatabaseName, q{rt4});

Set($LogToSyslog, undef);
Set($LogToScreen, undef);
Set($LogToFile, “info”);
Set($LogDir, q{/opt/logs/rt});
Set($LogToFileNamed, “rt4.log”); #log to rt4.log
Set($LogToFile , ‘debug’);

Set($OwnerEmail, ‘noc@dotomi.com’);
Set($RTAddressRegexp , ‘^hdtest@dotomi.com$’);
Set($SetOutgoingMailFrom, 1);
Set($SMTPServer, 10.110.xxx.xxx);
Set($DefaultQueue, “Helpdesk”);
Set(%GnuPG, Enable => 0);

Set($ExternalAuthPriority, [‘DTMAD’]);
Set($ExternalInfoPriority, [‘DTMAD’]);
Set($ExternalServiceUsesSSLorTLS, 0);
Set($AutoCreateNonExternalUsers, 0);
Set($ExternalSettings, {
‘DTMAD’ => {
‘type’ => ‘ldap’,
‘auth’ => 1,
‘info’ => 1,
‘server’ => ‘wdc-o02.dotomi.com’,
‘user’ => ‘DOTOMI\apache’,
‘pass’ => ‘xxxxxx’,
‘base’ => ‘OU=Dotomi_Inc,DC=dotomi,DC=com’,
‘filter’ => ‘(objectclass=person)’,
‘attr_match_list’ => [ ‘Name’,
‘attr_map’ => [ ‘Name’ => ‘sAMAccountName’,
‘EmailAddress’ => ‘mail’,
‘RealName’ => ‘cn’


You’re missing a closing quote at the end of this line, which breaks