RT 4.2.9 Incoming Email configuration with https

HI,

I am currently testing to upgrade to RT 4.2.9. I am running 4.2.6 successfully under normal http: (port 80). I am not wanting to sacrifice the https: ability with the upgrade to 4.2.9 and would like to still be able to use the full email functionality of RT.

Here is my setup. I am running Ubuntu 14.04.1 LTS; I have apache 2 installed with mysql; postfix, and fetchmail. My email server is Microsoft Exchange 2010.

I cannot, for the life of me, get the incoming email setup to work with https: enabled. In 4.2.6 I had to disable the redirect and go with just HTTP. Everything I have looked on the Wiki, forums, and blogs all point to Request Tracker 3 and other things. I have read documentation after documentation.

I am getting the following

Feb 24 15:14:25 hostname fetchmail[1178]: MDA returned nonzero status 75
Feb 24 15:14:25 hostname fetchmail[1178]: not flushed

I know this means wrong queue. I went through that with 4.2.6 and, like I said, eventually found the resolution to be switch from HTTPS redirect to simple HTTP. I know this is supposed to work somehow.

Here is my /etc/aliases file:

root@servername:~# cat /etc/aliases

See man 5 aliases for format

postmaster: root

rt: “|/opt/rt4/bin/rt-mailgate --queue General --action correspond --url https://rttest.domain.local/

Here is my /etc/fetchmailrc file:

#Daemon Mode

This file must be chmod 0600, owner fetchmail

set daemon 20
set syslog
set invisible
set no bouncemail

Hosts to Poool

Defaults ==========================================================

Set antispam to -1, since it is far easier to use that together with

no bouncemail

defaults:

timeout 300

antispam -1

batchlimit 100

poll exchange.domain.local protocol pop3

username “user@domain.com” password “password” mda “/opt/rt4/bin/rt-mailgate --queue General --action correspond --url https://rttest.domain.local/

no keep;

V/R,

Daniel Moore
IT Systems Technician
Osborne Wood Products, Inc.
[http://hosting-source.bm23.com/9241/public/OsborneLogo111.jpg]
P: 706.282.5764
F: 888.777.4304
http://www.osbornewood.com

Worth noting, it may or may not impact your situation, is the
–no-verify-ssl flag you can put on your poll command.

I had a similar situation, different errors, but similar with the https /
cert issue.

set daemon 60
set invisible
set no bouncemail
set no syslog
set logfile /var/log/fetchmail.log
poll myexchangeserver.domain.com protocol imap username "rt-correspondance"
password “password” mda “/opt/rt4/bin/rt-mailgate –no-verify-ssl --queue
’IT General’ --action correspond --url https://rt.domain.com/
http://jamie.vsecu.com/” no keepOn Tue, Feb 24, 2015 at 3:19 PM, Daniel Moore Daniel.Moore@osbornewood.com wrote:

HI,

I am currently testing to upgrade to RT 4.2.9. I am running 4.2.6
successfully under normal http: (port 80). I am not wanting to sacrifice
the https: ability with the upgrade to 4.2.9 and would like to still be
able to use the full email functionality of RT.

Here is my setup. I am running Ubuntu 14.04.1 LTS; I have apache 2
installed with mysql; postfix, and fetchmail. My email server is Microsoft
Exchange 2010.

I cannot, for the life of me, get the incoming email setup to work with
https: enabled. In 4.2.6 I had to disable the redirect and go with just
HTTP. Everything I have looked on the Wiki, forums, and blogs all point to
Request Tracker 3 and other things. I have read documentation after
documentation.

I am getting the following

Feb 24 15:14:25 hostname fetchmail[1178]: MDA returned nonzero status 75

Feb 24 15:14:25 hostname fetchmail[1178]: not flushed

I know this means wrong queue. I went through that with 4.2.6 and, like I
said, eventually found the resolution to be switch from HTTPS redirect to
simple HTTP. I know this is supposed to work somehow.

Here is my /etc/aliases file:

root@servername:~# cat /etc/aliases

See man 5 aliases for format

postmaster: root

rt: “|/opt/rt4/bin/rt-mailgate --queue General --action correspond
–url https://rttest.domain.local/

Here is my /etc/fetchmailrc file:

#Daemon Mode

This file must be chmod 0600, owner fetchmail

set daemon 20

set syslog

set invisible

set no bouncemail

######################################################################

Hosts to Poool

######################################################################

Defaults ==========================================================

Set antispam to -1, since it is far easier to use that together with

no bouncemail

defaults:

timeout 300

antispam -1

batchlimit 100

poll exchange.domain.local protocol pop3

username "user@domain.com" password “password” mda
"/opt/rt4/bin/rt-mailgate --queue General --action correspond --url
https://rttest.domain.local/"

no keep;

V/R,

Daniel Moore

IT Systems Technician

Osborne Wood Products, Inc.

[image: http://hosting-source.bm23.com/9241/public/OsborneLogo111.jpg]

P: 706.282.5764

F: 888.777.4304

http://www.osbornewood.com