Rt 4.2.1

I have installed fedora 20 32bit apache, mysql and CPAN

I then run yum update.

I downloaded rt-4.2.1

./configure -with-web-user=apache -with-web-group=apache

I ran fixdeps till it gave “all dependencies found”



AddDefaultCharset UTF-8

ScriptAlias /rt /opt/rt4/sbin/rt-server.fcgi

Document root “/var/www”

<Location /rt>

                            Order allow,deny

                            Allow from all

                            Options +ExecCGI

                            AddHandler fastcgi-script fcgi


If I run /opt/rt4/sbin/rt-server --port 8080

Then on firefox on the same PC as RT is installed and run URL I can login to RT and it works OK

I then stop rt-server --port 8080

Change RT_SiteConfig.pm

Set( $rtname, ‘mydomain.com’);

Set( $WebPath, ‘/rt’);

Set ( $Webdomain, ‘’);

Restart httpd

and then in firefox run URL it opens rt-server.fcgi so I
can read the document it doesn’t run RT

I need rt to run as /RT and not as /

What am I doing wrong

ScriptAlias /rt /opt/rt4/sbin/rt-server.fcgi

You are missing:

  1. A trailing slash on rt-server.fcgi/
  2. The FastCgiServer directive.

Please give http://docs.bestpractical.com/web_deployment a complete

  • Alex