RT 4.0.1 upgrade, plus mod_fcgid - NoAuth not parsed by mason?

Yesterday I did a test install of 4.0.1 on a fresh CentOS 6 VM, with
mod_fcgid. It all worked fine, so today I did a dump of our running
3.8.6 server to test an upgrade.

The db migration all went OK, and I’ve got the base rt4 code with none
of our local changes. However, what I get in the web page now (with the
same Apache config as yesterday - cut & pasted from the
web_deployment.pod for mod_fcgid) is an unstyled login page. If I log
in, I get a download request for Login.html, and if I manually fetch the
aileron-squished stylesheet, I get the raw Mason code for it.

The logs don’t show anything unusual, and I get the same behaviour using
the standalone server.

I’ve tried removing the extra Alias for /NoAuth/images/, just in case,
but no change. It’s also worth mentioning that I do get the Best
Practical logo on the login page OK.

Where can I look to find out why Mason isn’t parsing these pages? Is
there any more debugging I can turn on to see where the requests are
actually being handled (and why)?

Thanks for any pointers…


Just as an update - I switched to a new database, ran make
initialize-database, and just fired up the rt-server standalone server,
and I still get this problem. Turning on debug logging in RT_SiteConfig
(to file) doesn’t seem to change how much logging I get.

Anyway, just wiping the /opt/rt4 directory altogether, running make
install, then pointing it at the already-migrated database has cleared
whatever the issue was, and I can see my data in RT 4 just fine. I’ve
been clearing the Mason cache anyway, so what else is there in a bare
install that might be ‘sticky’ like that?