RT 3 Solaris 9 x86 will not install Session Request andDBI

Well the Apache::Session module is failing when it looks for the dbfile
stuff. These are the bdb libs like the BerekelyDB. You should be able to
force install that one and still be okay. Either that or you can go and get
the Berkeley db from sleepycat and install it if you don’t have db support.
We recently upgraded our solaris environment to 9 but I don’t remember if
db4 was part of it (although every other app imaginable was).

You can also try setting:

export LDFLAGS=“-L/usr/local/lib -L/usr/lib -L/lib/mysql
export CPPFLAGS=”-I/usr/local/include -I/include/mysql -I
/usr/include -I/include"

Also, if I remember, I installed the Apache::DBI and Apache::Session
manually. Also installed the DBD::mysql manually as well. Had something to
do with there being an error during the initial configure part that flew by
so fast on CPAN that I missed it. The sources are in your .cpan/build
directory if you have attempted to install already.-----Original Message-----
From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Randy Millis
Sent: Thursday, January 22, 2004 2:48 PM
To: rt-users@lists.fsck.com
Subject: [rt-users] RT 3 Solaris 9 x86 will not install Session Request
andDBI

I am trying to simulate my production Sparc environment on a PIII 866
running Solaris 9 x86, so I can do an upgrade walk through of RT 3.0.3 and
some other testing. I searched the list and did some googling to no avail -
I did not find an fix yet. :frowning:

System info:

SunOS hostname-removed 5.9 Generic_112234-08 i86pc i386 i86pc
perl, v5.8.1 built for i86pc-solaris
Apache/1.3.29 (Unix) (build using Apachetoolbox-1.5.69)
Compiled-in modules:
http_core.c
mod_env.c
mod_log_config.c
mod_mime.c
mod_negotiation.c
mod_status.c
mod_include.c
mod_autoindex.c
mod_dir.c
mod_cgi.c
mod_asis.c
mod_imap.c
mod_actions.c
mod_userdir.c
mod_alias.c
mod_access.c
mod_auth.c
mod_so.c
mod_setenvif.c
mod_perl.c
mod_php4.c
mysql Ver 12.22 Distrib 4.0.17, for pc-solaris2.9 (i386)

I am missing the following and they will not install:

-cut-
perl sbin/rt-test-dependencies --with-mysql --with-modperl1 | grep MISS

    Apache::Session 1.53...MISSING
    Apache::Request ...MISSING
    Apache::DBI ...MISSING

-cut-

Detaisl are:

-cut-
cpan> install Apache::Session
Failed Test Stat Wstat Total Fail Failed List of Failed
t/99dbfile.t 2 512 ?? ?? % ??
t/99dbfilestore.t 2 512 ?? ?? % ??
6 tests skipped.
Failed 2/18 test scripts, 88.89% okay. 0/89 subtests failed, 100.00% okay.
gmake: *** [test_dynamic] Error 29
/opt/sfw/bin/gmake test – NOT OK
Running make install
make test had returned bad status, won’t install without force

cpan> install Apache::Request

‘blib/lib’, ‘blib/arch’)" t/.t
t/
…t/*.t does not exist
FAILED–1 test script could be run, alas–no output ever seen
gmake: *** [test_dynamic] Error 2
/opt/sfw/bin/gmake test – NOT OK
Running make install
make test had returned bad status, won’t install without force

cpan> install Apache::DBI

Failed Test Stat Wstat Total Fail Failed List of Failed
t/10mysql.t 1 256 10 1 10.00% 5
5 subtests skipped.
Failed 1/1 test scripts, 0.00% okay. 1/10 subtests failed, 90.00% okay.
gmake: *** [test_dynamic] Error 2
/opt/sfw/bin/gmake test – NOT OK
Running make install
make test had returned bad status, won’t install without force

rt-users mailing list
rt-users@lists.bestpractical.com
http://lists.bestpractical.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm