RT 3.8 nginx HTTPS + fastcgi_server redirects to HTTP

Hi all,
I’m migrating an Apache only HTTPS + mod_perl to a nginx + fastcgi.
But new setup after I open up the login page in https://servername and
insert my username+password, I get redirected to http://servername
thus I’m unable to connect as there isn’t any HTTP configured and I
only run HTTPS.
After I login and if I go directly to https://servername it works and only
breaks again from HTTPS to HTTP when I use the search box.
Any ideas on what is forcing this redirection ?

I ran fastcgi_server with:
/var/www/rt3/bin/fastcgi_server --port 9000 -n 5

/var/www/rt3/etc/RT_SiteConfig.pm:
Set($WebPath, ‘’);
Set($WebBaseURL , ‘https://servername’);
Set($WebURL , $WebBaseURL . $WebPath . ‘/’);

/etc/nginx/sites-enabled/default:
server {
listen 443;
server_name servername;

            ssl on;
            ssl_certificate      /etc/ssl/servername.crt;
            ssl_certificate_key  /etc/ssl/private/servername.key;

            location / {
            root           /var/rt3/share/html;
            fastcgi_pass   127.0.0.1:9000;

            fastcgi_param  QUERY_STRING       $query_string;
            fastcgi_param  REQUEST_METHOD     $request_method;
            fastcgi_param  CONTENT_TYPE       $content_type;
            fastcgi_param  CONTENT_LENGTH     $content_length;
            fastcgi_param  PATH_INFO          $fastcgi_script_name;
            }

            location /NoAuth/images/ {
            alias   /var/www/rt3/share/html/NoAuth/images/;
            }

}

You must remove $WebPath, $WebBaseURL and $WebURL and set
$WebDomain $WebPort in your /var/www/rt3/etc/RT_SiteConfig.pm.

http://www.bestpractical.com/docs/rt/3.8/RT_Config.html#Web-Interface-Configuration

ChrisAm 12.11.2013 12:18, schrieb Colin:

Hi all,
I’m migrating an Apache only HTTPS + mod_perl to a nginx + fastcgi.
But new setup after I open up the login page in https://servername and
insert my username+password, I get redirected to http://servername
thus I’m unable to connect as there isn’t any HTTP configured and I
only run HTTPS.
After I login and if I go directly to https://servername it works and only
breaks again from HTTPS to HTTP when I use the search box.
Any ideas on what is forcing this redirection ?

I ran fastcgi_server with:
/var/www/rt3/bin/fastcgi_server --port 9000 -n 5

/var/www/rt3/etc/RT_SiteConfig.pm:
Set($WebPath, ‘’);
Set($WebBaseURL , ‘https://servername’);
Set($WebURL , $WebBaseURL . $WebPath . ‘/’);

/etc/nginx/sites-enabled/default:
server {
listen 443;
server_name servername;

            ssl on;
            ssl_certificate      /etc/ssl/servername.crt;
            ssl_certificate_key  /etc/ssl/private/servername.key;

            location / {
            root           /var/rt3/share/html;
            fastcgi_pass   127.0.0.1:9000;

            fastcgi_param  QUERY_STRING       $query_string;
            fastcgi_param  REQUEST_METHOD     $request_method;
            fastcgi_param  CONTENT_TYPE       $content_type;
            fastcgi_param  CONTENT_LENGTH     $content_length;
            fastcgi_param  PATH_INFO          $fastcgi_script_name;
            }

            location /NoAuth/images/ {
            alias   /var/www/rt3/share/html/NoAuth/images/;
            }

}