RT 3.8.7 : enabling the FCKeditor prevents sending 'text/plain' attachments

Following my previous posts on this ‘text/plain’ attachments topic :

as an introduction, I must say that I enabled the FCKeditor by default for all our users (Windows people which feel more comfortable
this way).

I ran more deep tests : I found something weird on Ubuntu :

  • running RT from Firefox, attaching a ‘text/plain’ file, the test recipient did not receive it
  • running RT from konqueror, it worked almost correctly, but konqueror was unable to run the FCKeditor; thus it just opened the
    ordinary ascii input field; and HERE, attaching the SAME previous text file (which was eventually assigned in RT with the same
    ’text/plain’ MIME type), the test recipient DID receive it !

Then I disabled the FCKeditor in my RT account, ran several tests from several browsers, severals PCs, several OSes, and regularly,
the ‘text/plain’ attachment was received.

I went back to the user who originally called for help on this topic, asked that she disable her FCKeditor, asked her to send again
the original file, and HERE the test recipient received it.

Can anybody reproduce this behaviour ?

Is it a bug ?

Regards

Robert GRASSO – System engineer

CEDRAT S.A.
15 Chemin de Malacher - Inovallée - 38246 MEYLAN cedex - FRANCE
Phone: +33 (0)4 76 90 50 45 - Fax: +33 (0)4 56 38 08 30
mailto:robert.grasso@cedrat.com - http://www.cedrat.com