RT 3.8.1 web interface

HiI’m having a few problems with the web interface of rt-3.8.1 on a new install of fedora 9 including all the latest updatesIn firefox on the localhost RT will run as follows http://localhost or http://localhost/rt both take me to RT login pageOn a remote PC if I try to connect to RT http://myIPaddress I get the default apache welcome pagewhen I try http://myIPaddress/rt I get 404 webpage could not be foundThe Fedora server will also be running mrtg as the main page (http://myIPaddress) so I need RT to run as http://myIPaddress/rtthis is my /etc/httpd/conf.d/rt.confNameVirtualHost localhost ServerAdmin webmaster@localhost DocumentRoot /opt/rt3/share/html Options FollowSymLinks AllowOverride None <Directory /opt/rt3/share/html> Options Indexes FollowSymLinks MultiViews AllowOverride None Order allow,deny allow from all ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/ <Directory “/usr/lib/cgi-bin”> AllowOverride None Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch Order allow,deny Allow from all # ErrorLog /var/log/apache2/error.log # Possible values include: debug, info, notice, warn, error, crit, # alert, emerg. LogLevel warn # CustomLog /var/log/apache2/access.log combined ServerSignature On Alias /rt “/opt/rt3/share/html” <Directory “/opt/rt3/share/html”> Options Indexes MultiViews FollowSymLinks AllowOverride None Order allow,deny Allow from all ServerName localhost DocumentRoot /opt/rt3/share/html AddDefaultCharset UTF-8 # optional apache logs for RT # ErrorLog /opt/rt3/var/log/apache2.error # TransferLog /opt/rt3/var/log/apache2.access PerlRequire “/opt/rt3/bin/webmux.pl” <Location /NoAuth/images> SetHandler default SetHandler perl-script PerlResponseHandler RT::Mason and my /opt/rt3/etc/RT_SiteConfig.pmSet( $rtname, ‘mydomain.com’);#Set(@Plugins,(qw(Extension::QuickDelete)));Set( $WebDomain, ‘localhost’);Set( $WebPath, ‘/rt’);Any ideas where I’m going wrong pleaseMany thanks in advanceNick
Talk to your Yahoo! Friends via Windows Live Messenger. Find out how.
http://www.windowslive.com/explore/messenger?ocid=TXT_TAGLM_WL_messenger_yahoo_082008

Hi Nick,

Might want to have a look at the mail below, I was having the same problem a few days ago and this sorted it for me.

Cheers,

AndyFrom: andrew.fay@hotmail.co.uk
To: ruz@bestpractical.com
Date: Fri, 22 Aug 2008 13:35:59 +0000
CC: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] rt 3.8.1 home link on interface

Thanks,

That worked!

Andy

Date: Fri, 22 Aug 2008 17:18:58 +0400
From: ruz@bestpractical.com
To: andrew.fay@hotmail.co.uk
Subject: Re: [rt-users] rt 3.8.1 home link on interface
CC: rt-users@lists.bestpractical.com

delete all the crap you have in your virtual host and leave something like:

NameVirtualHost *
<VirtualHost *>
ServerAdmin webmaster@localhost

ErrorLog /var/log/apache2/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog /var/log/apache2/access.log combined
# ServerSignature On

ServerName your.rt.server.hostname

DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

# optional apache logs for RT
# ErrorLog /opt/rt3/var/log/apache2.error
# TransferLog /opt/rt3/var/log/apache2.access

PerlRequire "/opt/rt3/bin/webmux.pl"

<Location /NoAuth/images>
    SetHandler default
</Location>
<Location />
    SetHandler perl-script
    PerlResponseHandler RT::Mason
</Location>

Set( $WebDomain, ‘localhost’ );
Set( $WebPath, ‘’ );

Also,

When i first hope RT the first page says no found…

if i click approvals which is

http://127.0.0.1/Approvals

then go back to home which is http://127.0.0.1/

I get RT at a glance up… otherwise i get It Works default apache page… so
i am pretty convinced i should be working in the root directory but have no
idea how to get rid of these default apache settings,

thanks,

Andy


From: andrew.fay@hotmail.co.uk
To: ruz@bestpractical.com
Date: Fri, 22 Aug 2008 13:06:46 +0000
CC: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] rt 3.8.1 home link on interface

Hi

I have tried that and all that happens is when i log on to 127.0.0.1/rt it
comes up with the login screen with no formatting… just text

I have noticed when I click links they are 127.0.0.1/search/simple.html etc
and they work so possibly I should be working in the root directory but I
have somehow set it to use /rt ? somewhere. I say this because if I try
127.0.0.1/rt/search/simple.html i get page not found

Sorry I am pretty new to this as last time I installed I used ubuntu
synaptic package manager to install : )

Thanks,

Andy


Date: Fri, 22 Aug 2008 17:01:33 +0400
From: ruz@bestpractical.com
To: andrew.fay@hotmail.co.uk
Subject: Re: [rt-users] rt 3.8.1 home link on interface
CC: rt-users@lists.bestpractical.com

Set( $WebDomain, ‘localhost’ );
Set( $WebPath, ‘/rt’ );

That’s all you need, as far as I can see. Domain is DOMAIN and is not
domain + path.

=item C<$WebPath>

If you’re putting the web ui somewhere other than at the root of
your server, you should set C<$WebPath> to the path you’ll be
serving RT at.

C<$WebPath> requires a leading / but no trailing /.

In most cases, you should leave C<$WebPath> set to ‘’ (an empty value).

=cut

Hi,

I have tried changing:

Set( $WebDomain, ‘localhost/rt’ );

No effect?

Thanks,

Andy


Date: Fri, 22 Aug 2008 16:18:57 +0400
From: ruz@bestpractical.com
To: andrew.fay@hotmail.co.uk
Subject: Re: [rt-users] rt 3.8.1 home link on interface
CC: rt-users@lists.bestpractical.com

Web* options in the RT config.

Hi,

How do I change the home link on the interface to not point at
127.0.0.1
?

my RT install is located at 127.0.0.1/rt

but 127.0.01 just goes to an apache default page that says : it
works

thanks in advance,

Andy


Get fish-slapping on Messenger! Play Now


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


Best regards, Ruslan.


Get fish-slapping on Messenger! Play Now


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


Best regards, Ruslan.


Best regards, Ruslan.


Find out how to make Messenger your very own TV! Try it Now!


Find out how to make Messenger your very own TV! Try it Now!


Best regards, Ruslan.

Find out how to make Messenger your very own TV! Try it Now!

Win New York holidays with Kellogg’s & Live Search
http://clk.atdmt.com/UKM/go/107571440/direct/01/