Rt 3.6 : apache2 configuration issues

I am trying to get RT 3.6 running with apache2 on Ubuntu for 2 weeks
now…
I’m not very advanced in RT nor Linux

I really look at a lot of places to find the right helpful information
about apache2 settings for RT 3.6 that are required to get out of the
“almost here”.

I know that my apache2 configuration is wrong and found a lot about this
but never in this particular configuration. RT3.6 + apache2 Parameter
samples are always related to RT 3.4+apache2 or RT3.6+Apache and did not
work. I tried almost all samples available in related links from your
advices:

http://wiki.bestpractical.com/ (the place lots of answers)
Carbon60: Cloud Consulting - Services and Solutions (searchable list archives)
http://www.google.com/ (I generally start
"+RT+MostUniqueErrMsg") And some more…

Can anyone point me in the right direction?

Thanks.

Manuel Eschenbrenner

Sorry for the repetition.
Just experiencing some delay in using this for the first time while changing
accounts records.

Regards,

Manuel E

Can you post your httpd.conf, the rt section?On Wed, 2006-10-11 at 14:14 +0200, Manuel ESCHENBRENNER wrote:

I am trying to get RT 3.6 running with apache2 on Ubuntu for 2 weeks
now…
I’m not very advanced in RT nor Linux

I really look at a lot of places to find the right helpful information
about apache2 settings for RT 3.6 that are required to get out of the
“almost here”.

I know that my apache2 configuration is wrong and found a lot about this
but never in this particular configuration. RT3.6 + apache2 Parameter
samples are always related to RT 3.4+apache2 or RT3.6+Apache and did not
work. I tried almost all samples available in related links from your
advices:

http://wiki.bestpractical.com/ (the place lots of answers)
Carbon60: Cloud Consulting - Services and Solutions (searchable list archives)
http://www.google.com/ (I generally start
"+RT+MostUniqueErrMsg") And some more…

Can anyone point me in the right direction?

Thanks.

Manuel Eschenbrenner


The rt-users Archives

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Scott T. Hildreth shildret@scotth.emsphone.com

Here they are…
As I said this are just copies of example found in links since I do not
understand all directives implications especially those related to INODB and
perl.

First here are my current general configuration:

RT: 3.6.0 (from RT.pm)
Perl: Rev 5 ver 8 sub 7 Linux 2.6.10 i486 linux-thread-multi
MySQL: 5.0.22 Debian_0ubuntu6.06.2
Apache2: 2.0.55

Config file (copy from my Windows PC)

ServerName MYSERVERNAME
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

this line applies to Apache2+mod_perl2 only

Below line might be incorrect, I had to use:

PerlModule Apache2::compat

mod_perl 2.0.1 from FC4 Linux

PerlModule Apache2 Apache::compat

PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl

SetHandler perl-script PerlHandler RT::Mason This one gives me the syntax error on line 10 (first PerlModule) ...

I guess perl is not properly linked to apache2…
How can I check this?
I tried several different but there is always something wrong somewhere

Thanks

Manuel

-----Message d’origine-----De : Scott T. Hildreth [mailto:shildret@scotth.emsphone.com]
Envoyé : mercredi 11 octobre 2006 15:41
À : Manuel ESCHENBRENNER
Cc : rt-users@lists.bestpractical.com
Objet : Re: [rt-users] rt 3.6 : apache2 configuration issues

Can you post your httpd.conf, the rt section?

Here they are…
As I said this are just copies of example found in links since I do not
understand all directives implications especially those related to INODB and
perl.

Do you have mod_perl installed?

Here is what I have (I don’t use a VirtualHost)

Alias /rt /usr/local/rt-3.6pre0/share/html/

<Location /rt>
SetHandler perl-script
PerlHandler RT::Mason

PerlModule Apache::DBI

PerlRequire /usr/local/rt-3.6pre0/bin/webmux.pl

<Directory /usr/local/rt-3.6pre0/share/html>

... (I left out the ldap settings) 


<Files *.*>
    SetHandler perl-script
    PerlHandler RT::Mason
</Files>

PerlModule Apache2 Apache::compat <= You don’t need this.

PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl

SetHandler perl-script PerlHandler RT::Mason ------------ This one gives me the syntax error on line 10 (first PerlModule) ...

I guess perl is not properly linked to apache2…
How can I check this?
I tried several different but there is always something wrong somewhere

Thanks

Manuel

-----Message d’origine-----
De : Scott T. Hildreth [mailto:shildret@scotth.emsphone.com]
Envoyé : mercredi 11 octobre 2006 15:41
À : Manuel ESCHENBRENNER
Cc : rt-users@lists.bestpractical.com
Objet : Re: [rt-users] rt 3.6 : apache2 configuration issues

Can you post your httpd.conf, the rt section?

I am trying to get RT 3.6 running with apache2 on Ubuntu for 2 weeks
now…
I’m not very advanced in RT nor Linux

I really look at a lot of places to find the right helpful information
about apache2 settings for RT 3.6 that are required to get out of the
“almost here”.

I know that my apache2 configuration is wrong and found a lot about this
but never in this particular configuration. RT3.6 + apache2 Parameter
samples are always related to RT 3.4+apache2 or RT3.6+Apache and did not
work. I tried almost all samples available in related links from your
advices:

http://wiki.bestpractical.com/ (the place lots of answers)
Carbon60: Cloud Consulting - Services and Solutions (searchable list archives)
http://www.google.com/ (I generally start
"+RT+MostUniqueErrMsg") And some more…

Can anyone point me in the right direction?

Thanks.

Manuel Eschenbrenner


The rt-users Archives

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Scott T. Hildreth shildreth@allantgroup.com

Please forgive me it finally fell working…

My expectations were correct: mod-perl for apache2 package was not properly
installed.

I found it simply searching apache2 packages:

My apache2 installed synaptic packages:

  • apache2
  • apache2-common
  • apache2-doc
  • apache2-mpm-worker
  • apache2-utils
  • libapache2-mod-perl2
  • libapache2-mod-perl2-dev

Then using the basic config file BUT reading author comment for apache2

ServerName RTServer DocumentRoot /opt/rt3/share/html AddDefaultCharset UTF-8
# next line was comment as it does not run
# PerlModule Apache2 Apache::compat

# Next line was uncomment and replace initial one
PerlModule Apache2::compat

Perlmodule Apache::DBI
PerRequire /opt/rt3/bin/webmux.pl

ErrorLog /var/log/apache2/RTerror.log
LogLevel info
CustomLog /var/log/apache2/RTaccess.log combined
ServerSignature On

<Location />
	SetHandler perl-script
	PerlHandler RT::Mason
w/Location>

Then I had some trouble with rt_user since underscore is not allowed in user
name with my ubuntu version.

I used rtuser instead, modifying RT_SiteConfig.pm to reflect this:

Set($DatabaseUser , ‘rtuser’);
Set($DatabasePassword , ‘MyPwd’);

I have still some problems login in RT but I get the RT login screen and the
initialize-database script was OK consequently I can read data in rt3 db
using MySQL commands.

Thank again for your tries to help.

Manuel