RT 3.6.6 Install on FC8 (Apache problems) Part 2

Okay, one problem solved. I turned off SELINUX and now httpd starts without an error.

Now, everything seems to be setup correctly, but I cannot bring up the RT login page. I can ping rtbak.xyzcorp.com, but when I try to browse to it, it just times out.

Here is my rt3.conf:

Alias /rt3 “//opt/rt3/share/html”

PerlModule Apache::DBI
PerlRequire /usr/sbin/webmux.pl

<Directory /opt/rt3/share/html>
AllowOverride All
Options ExecCGI FollowSymLinks

Order allow,deny
Allow from all

<Location /rt>
RewriteEngine On
RedirectMatch permanent (.*)/$ $1/index.html
AddDefaultCharset UTF-8
SetHandler perl-script
PerlHandler RT::Mason

<VirtualHost 10.9.10.251>
ServerName itadmin_test
ServerAlias rtbak.xyzcorp.com
DocumentRoot /opt/rt3/share/html

AddDefaultCharset UTF-8
PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl

<Location /rt3>
SetHandler perl-script
PerlHandler RT::Mason

Among other settings, I have the following in my RTSiteConfig.pm:

Set($WebURL, ‘http://rtbak.xyzcorp.com/’);
Set($WebBaseURL, ‘http://rtbak.xyzcorp.com/’);

Set($LogToFile , ‘debug’);
Set($LogDir, ‘/opt/rt3/var/log’);
Set($LogToFileNamed , “rt.log”);

I have checked the rt.log and there is nothing in there. Where do I look next to see why rtbak.xyzcorp.com or 10.9.10.251 is not bringing up the RT login page?

Thanks,
Shannon----- Original Message ----
From: Shannon Adams shannon_adams68@yahoo.com
Sent: Monday, May 12, 2008 8:38:19 PM
Subject: Re: [rt-users] RT 3.6.6 Install on FC8 (Apache problems)

In short, I have an old server running FC4 and RT 3.6.6. I have installed a new server running FC8, but I am having trouble getting RT 3.6.6 running on it. Here are some more details:

fc4 httpd version running Apache/2.0.54
fc8 httpd version running Apache/2.2.8 (Unix)

The user running httpd on fc4 is “apache”. I am attempting to start httpd with “service httpd start” as root on fc8 - just as I do on fc4. Permissions, owner, and group are exactly the same between the two machines starting at /opt/rt3. For example, both servers show this for /opt/rt3/var/mason_data:

drwxr-xr-x 2 apache apache 4096 2008-05-12 10:16 cache
drwxr-xr-x 2 apache apache 4096 2008-05-12 10:16 etc
drwxr-xr-x 2 apache apache 4096 2008-05-12 10:16 obj

However, when starting httpd on fc8, I get the message below. It appears to be permissions related, but the permissions between the two servers starting at /opt/rt3 are exactly the same. I would really appreciate any assistance. This is driving me nuts!

Thanks,
Shannon

Be a better friend, newshound, and
know-it-all with Yahoo! Mobile. Try it now. Home | Yahoo Mobile

Okay, one problem solved. I turned off SELINUX and now httpd starts without an error.

OK, that’s one default removed…

Now, everything seems to be setup correctly, but I cannot bring up the RT login page. I can ping rtbak.xyzcorp.com, but when I try to browse to it, it just times out.

Check your iptables config - by default it only permits access to the
SSH daemon after an installation. You could use system-config-firewall
to sort this, or simply edit /etc/sysconfig/iptables and then issue a
“service iptables restart”.

Graeme